Every CVE Search/ Get API key

CVE-2012-4434

fwknop before 2.0.3 allow remote authenticated users to cause a denial of service (server crash)...

8.8 HighFix available

fwknop before 2.0.3 allow remote authenticated users to cause a denial of service (server crash) or possibly execute arbitrary code.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

3.31%Down 0.1 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 8.8

fwknop before 2.0.3 allow remote authenticated users to cause a denial of service (server crash) or possibly execute arbitrary code.

Record
CVE-2012-4434
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
6.5 MediumAV:N/AC:L/Au:S/C:P/I:P/A:P
Weakness
CWE-276
Updated
2026-11-02
CVE List No score

fwknop before 2.0.3 allow remote authenticated users to cause a denial of service (server crash) or possibly execute arbitrary code.

Record
CVE-2012-4434
Updated
2026-11-02
EUVDEUVD-2012-4368 No score

fwknop before 2.0.3 allow remote authenticated users to cause a denial of service (server crash) or possibly execute arbitrary code.

Record
EUVD-2012-4368
Updated
2026-11-03
GitHub AdvisoriesGHSA-hh46-vfhf-rqg7 No score

fwknop before 2.0.3 allow remote authenticated users to cause a denial of service (server crash)...

fwknop before 2.0.3 allow remote authenticated users to cause a denial of service (server crash) or possibly execute arbitrary code.

Record
GHSA-hh46-vfhf-rqg7
Updated
2026-11-02
OSV 8.8

fwknop before 2.0.3 allow remote authenticated users to cause a denial of service (server crash) or possibly execute arbitrary code.

Record
CVE-2012-4434
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2012-4434 8.8

fwknop before 2.0.3 allow remote authenticated users to cause a denial of service (server crash) or possibly execute arbitrary code.

Record
DEBIAN-CVE-2012-4434
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
fwknop
Debian:12
before 2.0.3-1
2.0.3-1
fwknop
Debian:13
before 2.0.3-1
2.0.3-1
fwknop
Debian:14
before 2.0.3-1
2.0.3-1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2012-4434 is a high vulnerability (CVSS 8.8) in Cipherdyne Fwknop, published January 9, 2020. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.31%, the 88th percentile. Fixed in fwknop 2.0.3-1.

References

MoveEnter Open