Every CVE Search/ Get API key

CVE-2012-4435

fwknop before 2.0.3 does not properly validate IP addresses, which allows remote authenticated...

4.0 MediumFix available

fwknop before 2.0.3 does not properly validate IP addresses, which allows remote authenticated users to cause a denial of service (server crash) via a long IP address.

Exploit likelihood

2.33%Up 1.1 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 4.0

fwknop before 2.0.3 does not properly validate IP addresses, which allows remote authenticated users to cause a denial of service (server crash) via a long IP address.

Record
CVE-2012-4435
CVSS 2.0
4.0 MediumAV:N/AC:L/Au:S/C:N/I:N/A:P
Weakness
CWE-20
Updated
2026-11-02
CVE List No score

fwknop before 2.0.3 does not properly validate IP addresses, which allows remote authenticated users to cause a denial of service (server crash) via a long IP address.

Record
CVE-2012-4435
Updated
2026-11-02
EUVDEUVD-2012-4369 No score

fwknop before 2.0.3 does not properly validate IP addresses, which allows remote authenticated users to cause a denial of service (server crash) via a long IP address.

Record
EUVD-2012-4369
Updated
2026-11-03
GitHub AdvisoriesGHSA-jvjc-qf53-pgj7 No score

fwknop before 2.0.3 does not properly validate IP addresses, which allows remote authenticated...

fwknop before 2.0.3 does not properly validate IP addresses, which allows remote authenticated users to cause a denial of service (server crash) via a long IP address.

Record
GHSA-jvjc-qf53-pgj7
Weakness
CWE-20
Updated
2026-11-02
OSV No score

fwknop before 2.0.3 does not properly validate IP addresses, which allows remote authenticated users to cause a denial of service (server crash) via a long IP address.

Record
CVE-2012-4435
Updated
2026-11-02
OSVDEBIAN-CVE-2012-4435 No score

fwknop before 2.0.3 does not properly validate IP addresses, which allows remote authenticated users to cause a denial of service (server crash) via a long IP address.

Record
DEBIAN-CVE-2012-4435
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
fwknop
Debian:12
before 2.0.3-1
2.0.3-1
fwknop
Debian:13
before 2.0.3-1
2.0.3-1
fwknop
Debian:14
before 2.0.3-1
2.0.3-1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2012-4435 is a medium vulnerability (CVSS 4.0) in Cipherdyne Fwknop, published October 22, 2012. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.33%, the 83rd percentile. Fixed in fwknop 2.0.3-1.

References

Show 6 moreShow less
MoveEnter Open