Every CVE Search/ Get API key

CVE-2012-6634

wp-admin/media-upload.php in WordPress before 3.3.3 allows remote attackers to obtain sensitive...

6.4 MediumFix available

wp-admin/media-upload.php in WordPress before 3.3.3 allows remote attackers to obtain sensitive information or bypass intended media-attachment restrictions via a post_id value.

Exploit likelihood

2.05%Up 1.0 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 6.4

wp-admin/media-upload.php in WordPress before 3.3.3 allows remote attackers to obtain sensitive information or bypass intended media-attachment restrictions via a post_id value.

Record
CVE-2012-6634
CVSS 2.0
6.4 MediumAV:N/AC:L/Au:N/C:P/I:P/A:N
Weakness
CWE-264
Updated
2026-11-02
CVE List No score

wp-admin/media-upload.php in WordPress before 3.3.3 allows remote attackers to obtain sensitive information or bypass intended media-attachment restrictions via a post_id value.

Record
CVE-2012-6634
Updated
2026-11-02
EUVDEUVD-2012-6480 No score

wp-admin/media-upload.php in WordPress before 3.3.3 allows remote attackers to obtain sensitive information or bypass intended media-attachment restrictions via a post_id value.

Record
EUVD-2012-6480
Updated
2026-11-03
GitHub AdvisoriesGHSA-44pr-x897-56j8 No score

wp-admin/media-upload.php in WordPress before 3.3.3 allows remote attackers to obtain sensitive...

wp-admin/media-upload.php in WordPress before 3.3.3 allows remote attackers to obtain sensitive information or bypass intended media-attachment restrictions via a post_id value.

Record
GHSA-44pr-x897-56j8
Updated
2026-11-02
OSV No score

wp-admin/media-upload.php in WordPress before 3.3.3 allows remote attackers to obtain sensitive information or bypass intended media-attachment restrictions via a post_id value.

Record
CVE-2012-6634
Updated
2026-11-02
OSVDEBIAN-CVE-2012-6634 No score

wp-admin/media-upload.php in WordPress before 3.3.3 allows remote attackers to obtain sensitive information or bypass intended media-attachment restrictions via a post_id value.

Record
DEBIAN-CVE-2012-6634
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
wordpress
Debian:12
before 3.4+dfsg-1
3.4+dfsg-1
wordpress
Debian:13
before 3.4+dfsg-1
3.4+dfsg-1
wordpress
Debian:14
before 3.4+dfsg-1
3.4+dfsg-1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2012-6634 is a medium vulnerability (CVSS 6.4) in Wordpress, published January 21, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.05%, the 81st percentile. Fixed in wordpress 3.4+dfsg-1.

References

MoveEnter Open