CVE-2013-0306
Django is vulnerable to Denial of Service attack in formset
The form library in Django 1.3.x before 1.3.6, 1.4.x before 1.4.4, and 1.5 before release candidate 2 allows remote attackers to bypass intended resource limits for formsets and cause a denial of service (memory consumption) or trigger server errors via a modified max_num parameter.
Exploit likelihood
What each source reports
NVD Score used
5.0
The form library in Django 1.3.x before 1.3.6, 1.4.x before 1.4.4, and 1.5 before release candidate 2 allows remote attackers to bypass intended resource limits for formsets and cause a denial of service (memory consumption) or trigger server errors via a modified max_num parameter.
- Record
CVE-2013-0306- CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:N/I:N/A:P - Weakness
- CWE-189
- Updated
- 2026-11-02
CVE List No score
The form library in Django 1.3.x before 1.3.6, 1.4.x before 1.4.4, and 1.5 before release candidate 2 allows remote attackers to bypass intended resource limits for formsets and cause a denial of service (memory consumption) or trigger server errors via a modified max_num parameter.
- Record
CVE-2013-0306- Updated
- 2026-11-02
EUVDEUVD-2013-0005 No score
The form library in Django 1.3.x before 1.3.6, 1.4.x before 1.4.4, and 1.5 before release candidate 2 allows remote attackers to bypass intended resource limits for formsets and cause a denial of service (memory consumption) or trigger server errors via a modified max_num parameter.
- Record
EUVD-2013-0005- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-g8xg-jgj6-49r3
6.9
Django is vulnerable to Denial of Service attack in formset
The form library in Django 1.3.x before 1.3.6, 1.4.x before 1.4.4, and 1.5 before release candidate 2 allows remote attackers to bypass intended resource limits for formsets and cause a denial of service (memory consumption) or trigger server errors via a modified max_num parameter.
- Record
GHSA-g8xg-jgj6-49r3- CVSS 4.0
- 6.9 Medium
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N - CVSS 3.1
- 5.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L - Weakness
- CWE-400
- Updated
- 2026-11-02
OSVGHSA-g8xg-jgj6-49r3
6.9
Django is vulnerable to Denial of Service attack in formset
The form library in Django 1.3.x before 1.3.6, 1.4.x before 1.4.4, and 1.5 before release candidate 2 allows remote attackers to bypass intended resource limits for formsets and cause a denial of service (memory consumption) or trigger server errors via a modified max_num parameter.
- Record
GHSA-g8xg-jgj6-49r3- CVSS 4.0
- 6.9 Medium
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N - CVSS 3.1
- 5.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L - Weakness
- CWE-400
- Updated
- 2026-11-02
OSV No score
The form library in Django 1.3.x before 1.3.6, 1.4.x before 1.4.4, and 1.5 before release candidate 2 allows remote attackers to bypass intended resource limits for formsets and cause a denial of service (memory consumption) or trigger server errors via a modified max_num parameter.
- Record
CVE-2013-0306- Updated
- 2026-11-02
OSVDEBIAN-CVE-2013-0306 No score
The form library in Django 1.3.x before 1.3.6, 1.4.x before 1.4.4, and 1.5 before release candidate 2 allows remote attackers to bypass intended resource limits for formsets and cause a denial of service (memory consumption) or trigger server errors via a modified max_num parameter.
- Record
DEBIAN-CVE-2013-0306- Updated
- 2026-11-02
OSVPYSEC-2013-17 No score
The form library in Django 1.3.x before 1.3.6, 1.4.x before 1.4.4, and 1.5 before release candidate 2 allows remote attackers to bypass intended resource limits for formsets and cause a denial of service (memory consumption) or trigger server errors via a modified max_num parameter.
- Record
PYSEC-2013-17- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
djangoPyPI |
1.3 up to 1.3.6 | 1.3.6 |
djangoPyPI |
1.4 up to 1.4.4 | 1.4.4 |
python-djangoDebian:12 |
before 1.4.4-1 | 1.4.4-1 |
python-djangoDebian:13 |
before 1.4.4-1 | 1.4.4-1 |
python-djangoDebian:14 |
before 1.4.4-1 | 1.4.4-1 |
python-djangoDebian:6.0 From an advisory covering 4 CVEs |
before 1.2.3-3+squeeze5, plus listed versions 1.2.3-31.2.3-3+squeeze11.2.3-3+squeeze21.2.3-3+squeeze3 |
1.2.3-3+squeeze5 |
djangoPyPI |
1.3 up to 1.3.6, plus listed versions 1.3.11.3.21.3.31.3.41.3.5 |
1.3.6 |
djangoPyPI |
1.4 up to 1.4.4, plus listed versions 1.4.11.4.21.4.3 |
1.4.4 |
djangoPyPI |
1.3 up to 1.3.6, 1.4 up to 1.4.4, plus listed versions 1.3.11.3.21.3.31.3.41.3.51.4.11.4.21.4.3 |
1.3.61.4.4 |
Django14Red Hat:openstack:2::el6 From an advisory covering 4 CVEs |
before 0:1.4.4-1.el6ost | 0:1.4.4-1.el6ost |
Django14-docRed Hat:openstack:2::el6 From an advisory covering 4 CVEs |
before 0:1.4.4-1.el6ost | 0:1.4.4-1.el6ost |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2013-0306 is a medium vulnerability (CVSS 5.0) in Djangoproject Django, published February 27, 2013. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.65%, the 85th percentile. Fixed in django 1.3.6.
References
djangoproject.com/weblog/2013/feb/19/security
ubuntu.com/usn/usn-1757-1
debian.org/security/2013/dsa-2634
rhn.redhat.com/errata/RHSA-2013-0670.html
nvd.nist.gov/vuln/detail/CVE-2013-0306
github.com/django/django/commit/0cc350a896f70ace18280410eb616a9197d862b0
Show 25 moreShow less
github.com/django/django/commit/d7094bbce8cb838f3b40f504f198c098ff1cf727
github.com/pypa/advisory-database/tree/main/vulns/django/PYSEC-2013-17.yaml
github.com/advisories/GHSA-g8xg-jgj6-49r3
security-tracker.debian.org/tracker/CVE-2013-0306
github.com/django/django
access.redhat.com/errata/RHSA-2013:0670
access.redhat.com/security/updates/classification
bugzilla.redhat.com/show_bug.cgi?id=912982
bugzilla.redhat.com/show_bug.cgi?id=913037
bugzilla.redhat.com/show_bug.cgi?id=913039
bugzilla.redhat.com/show_bug.cgi?id=913041
bugzilla.redhat.com/show_bug.cgi?id=913042
bugzilla.redhat.com/show_bug.cgi?id=913808
security.access.redhat.com/data/csaf/v2/advisories/2013/rhsa-2013_0670.json
access.redhat.com/security/cve/CVE-2013-0305
cve.org/CVERecord?id=CVE-2013-0305
nvd.nist.gov/vuln/detail/CVE-2013-0305
access.redhat.com/security/cve/CVE-2013-0306
cve.org/CVERecord?id=CVE-2013-0306
access.redhat.com/security/cve/CVE-2013-1664
cve.org/CVERecord?id=CVE-2013-1664
nvd.nist.gov/vuln/detail/CVE-2013-1664
access.redhat.com/security/cve/CVE-2013-1665
cve.org/CVERecord?id=CVE-2013-1665
nvd.nist.gov/vuln/detail/CVE-2013-1665