Every CVE Search/ Get API key

CVE-2013-2503

Privoxy before 3.0.21 does not properly handle Proxy-Authenticate and Proxy-Authorization headers...

5.8 MediumPublic exploitFix available

Privoxy before 3.0.21 does not properly handle Proxy-Authenticate and Proxy-Authorization headers in the client-server data stream, which makes it easier for remote HTTP servers to spoof the intended proxy service via a 407 (aka Proxy Authentication Required) HTTP status code.

Exploit likelihood

4.63%Down 2.4 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.8

Privoxy before 3.0.21 does not properly handle Proxy-Authenticate and Proxy-Authorization headers in the client-server data stream, which makes it easier for remote HTTP servers to spoof the intended proxy service via a 407 (aka Proxy Authentication Required) HTTP status code.

Record
CVE-2013-2503
CVSS 2.0
5.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:N
Weakness
CWE-20
Updated
2026-11-02
CVE List No score

Privoxy before 3.0.21 does not properly handle Proxy-Authenticate and Proxy-Authorization headers in the client-server data stream, which makes it easier for remote HTTP servers to spoof the intended proxy service via a 407 (aka Proxy Authentication Required) HTTP status code.

Record
CVE-2013-2503
Updated
2026-11-02
EUVDEUVD-2013-2449 No score

Privoxy before 3.0.21 does not properly handle Proxy-Authenticate and Proxy-Authorization headers in the client-server data stream, which makes it easier for remote HTTP servers to spoof the intended proxy service via a 407 (aka Proxy Authentication Required) HTTP status code.

Record
EUVD-2013-2449
Updated
2026-11-03
GitHub AdvisoriesGHSA-xwv2-6j43-gjcx No score

Privoxy before 3.0.21 does not properly handle Proxy-Authenticate and Proxy-Authorization headers...

Privoxy before 3.0.21 does not properly handle Proxy-Authenticate and Proxy-Authorization headers in the client-server data stream, which makes it easier for remote HTTP servers to spoof the intended proxy service via a 407 (aka Proxy Authentication Required) HTTP status code.

Record
GHSA-xwv2-6j43-gjcx
Weakness
CWE-20
Updated
2026-11-02
OSV No score

Privoxy before 3.0.21 does not properly handle Proxy-Authenticate and Proxy-Authorization headers in the client-server data stream, which makes it easier for remote HTTP servers to spoof the intended proxy service via a 407 (aka Proxy Authentication Required) HTTP status code.

Record
CVE-2013-2503
Updated
2026-11-02
OSVDEBIAN-CVE-2013-2503 No score

Privoxy before 3.0.21 does not properly handle Proxy-Authenticate and Proxy-Authorization headers in the client-server data stream, which makes it easier for remote HTTP servers to spoof the intended proxy service via a 407 (aka Proxy Authentication Required) HTTP status code.

Record
DEBIAN-CVE-2013-2503
Updated
2026-11-02
OSVUBUNTU-CVE-2013-2503 No score

Privoxy before 3.0.21 does not properly handle Proxy-Authenticate and Proxy-Authorization headers in the client-server data stream, which makes it easier for remote HTTP servers to spoof the intended proxy service via a 407 (aka Proxy Authentication Required) HTTP status code.

Record
UBUNTU-CVE-2013-2503
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
privoxy
Debian:12
before 3.0.21-1
3.0.21-1
privoxy
Debian:13
before 3.0.21-1
3.0.21-1
privoxy
Debian:14
before 3.0.21-1
3.0.21-1

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
Exploit-DBPrivoxy Proxy - Authentication Information Disclosure2013-03-11

History

History
RecordedChangedSources
affected
aliasesEUVD
first indexedCVE List, Exploit-DB, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2013-2503 is a medium vulnerability (CVSS 5.8) in Privoxy, published March 11, 2013. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 4.63%, the 91st percentile. Fixed in privoxy 3.0.21-1.

References

MoveEnter Open