Every CVE Search/ Get API key

CVE-2013-4207

Buffer overflow in sshbn.c in PuTTY before 0.63 allows remote SSH servers to cause a denial of...

4.3 MediumFix available

Buffer overflow in sshbn.c in PuTTY before 0.63 allows remote SSH servers to cause a denial of service (crash) via an invalid DSA signature that is not properly handled during computation of a modular inverse and triggers the overflow during a division by zero by the bignum functionality, a different vulnerability than CVE-2013-4206.

Exploit likelihood

1.83%Up 0.7 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 4.3

Buffer overflow in sshbn.c in PuTTY before 0.63 allows remote SSH servers to cause a denial of service (crash) via an invalid DSA signature that is not properly handled during computation of a modular inverse and triggers the overflow during a division by zero by the bignum functionality, a different vulnerability than CVE-2013-4206.

Record
CVE-2013-4207
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:N/A:P
Weakness
CWE-119
Updated
2026-11-02
CVE List No score

Buffer overflow in sshbn.c in PuTTY before 0.63 allows remote SSH servers to cause a denial of service (crash) via an invalid DSA signature that is not properly handled during computation of a modular inverse and triggers the overflow during a division by zero by the bignum functionality, a different vulnerability than CVE-2013-4206.

Record
CVE-2013-4207
Updated
2026-11-02
EUVDEUVD-2013-4112 No score

Buffer overflow in sshbn.c in PuTTY before 0.63 allows remote SSH servers to cause a denial of service (crash) via an invalid DSA signature that is not properly handled during computation of a modular inverse and triggers the overflow during a division by zero by the bignum functionality, a different vulnerability than CVE-2013-4206.

Record
EUVD-2013-4112
Updated
2026-11-03
GitHub AdvisoriesGHSA-gqcg-rpgj-92fp No score

Buffer overflow in sshbn.c in PuTTY before 0.63 allows remote SSH servers to cause a denial of...

Buffer overflow in sshbn.c in PuTTY before 0.63 allows remote SSH servers to cause a denial of service (crash) via an invalid DSA signature that is not properly handled during computation of a modular inverse and triggers the overflow during a division by zero by the bignum functionality, a different vulnerability than CVE-2013-4206.

Record
GHSA-gqcg-rpgj-92fp
Weakness
CWE-119
Updated
2026-11-02
OSV No score

Buffer overflow in sshbn.c in PuTTY before 0.63 allows remote SSH servers to cause a denial of service (crash) via an invalid DSA signature that is not properly handled during computation of a modular inverse and triggers the overflow during a division by zero by the bignum functionality, a different vulnerability than CVE-2013-4206.

Record
CVE-2013-4207
Updated
2026-11-02
OSVDEBIAN-CVE-2013-4207 No score

Buffer overflow in sshbn.c in PuTTY before 0.63 allows remote SSH servers to cause a denial of service (crash) via an invalid DSA signature that is not properly handled during computation of a modular inverse and triggers the overflow during a division by zero by the bignum functionality, a different vulnerability than CVE-2013-4206.

Record
DEBIAN-CVE-2013-4207
Updated
2026-11-02
OSVMGASA-2013-0242 No score

Updated putty and filezilla packages fixes security vulnerability

PuTTY versions 0.62 and earlier - as well as all software that integrates these versions of PuTTY - are vulnerable to an integer overflow leading to heap overflow during the SSH handshake before authentication, caused by improper bounds checking of the length parameter received from the SSH server. This allows remote attackers to cause denial of service, and may have more severe impact on the operation of software that uses PuTTY code (CVE-2013-4852).

PuTTY versions 0.62 and earlier - as well as all software that integrates these versions of PuTTY - are vulnerable to a heap-corrupting buffer underrun bug in the modmul function which performs modular multiplication (CVE-2013-4206).

PuTTY versions 0.62 and earlier - as well as all software that integrates these versions of PuTTY - are vulnerable to a buffer overflow vulnerability in the calculation of modular inverses when verifying a DSA signature (CVE-2013-4207).

PuTTY versions 0.62 and earlier - as well as all software that integrates these versions of PuTTY - are vulnerable to private keys left in memory after being used by PuTTY tools (CVE-2013-4208).

Record
MGASA-2013-0242
Updated
2026-11-02
OSVopenSUSE-SU-2024:10399-1 No score

filezilla-3.23.0.2-1.1 on GA media

These are all security issues fixed in the filezilla-3.23.0.2-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10399-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
filezilla
Debian:12
before 3.7.3-1
3.7.3-1
filezilla
Debian:13
before 3.7.3-1
3.7.3-1
filezilla
Debian:14
before 3.7.3-1
3.7.3-1
putty
Debian:12
before 0.63-1
0.63-1
putty
Debian:13
before 0.63-1
0.63-1
putty
Debian:14
before 0.63-1
0.63-1
putty
Debian:6.0
before 0.60+2010-02-20-1+squeeze2, plus listed versions
0.60+2010-02-20-10.60+2010-02-20-1+squeeze1
0.60+2010-02-20-1+squeeze2
putty
Debian:7
before 0.62-9+deb7u1, plus listed versions
0.62-9
0.62-9+deb7u1
putty
Mageia:2
before 0.63-1.mga2
0.63-1.mga2
filezilla
Mageia:2
before 3.7.3-1.mga2
3.7.3-1.mga2
putty
Mageia:3
before 0.63-1.mga3
0.63-1.mga3
filezilla
Mageia:3
before 3.7.3-1.mga3
3.7.3-1.mga3
filezilla
openSUSE:Tumbleweed
before 3.23.0.2-1.1
3.23.0.2-1.1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2013-4207 is a medium vulnerability (CVSS 4.3) in Putty, published August 9, 2013. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.83%, the 78th percentile. Fixed in filezilla 3.7.3-1.

References

Show 13 moreShow less
MoveEnter Open