Every CVE Search/ Get API key

CVE-2013-4522

Moodle vulnerable to Exposure of Sensitive Information to an Unauthorized Actor

5.0 MediumFix available

lib/filelib.php in Moodle through 2.2.11, 2.3.x before 2.3.10, 2.4.x before 2.4.7, and 2.5.x before 2.5.3 does not send "Cache-Control: private" HTTP headers, which allows remote attackers to obtain sensitive information by requesting a file that had been previously retrieved by a caching proxy server.

Exploit likelihood

1.54%Up 0.4 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.0

lib/filelib.php in Moodle through 2.2.11, 2.3.x before 2.3.10, 2.4.x before 2.4.7, and 2.5.x before 2.5.3 does not send "Cache-Control: private" HTTP headers, which allows remote attackers to obtain sensitive information by requesting a file that had been previously retrieved by a caching proxy server.

Record
CVE-2013-4522
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:P/I:N/A:N
Weakness
CWE-200
Updated
2026-11-02
CVE List No score

lib/filelib.php in Moodle through 2.2.11, 2.3.x before 2.3.10, 2.4.x before 2.4.7, and 2.5.x before 2.5.3 does not send "Cache-Control: private" HTTP headers, which allows remote attackers to obtain sensitive information by requesting a file that had been previously retrieved by a caching proxy server.

Record
CVE-2013-4522
Updated
2026-11-02
EUVDEUVD-2013-4381 No score

lib/filelib.php in Moodle through 2.2.11, 2.3.x before 2.3.10, 2.4.x before 2.4.7, and 2.5.x before 2.5.3 does not send "Cache-Control: private" HTTP headers, which allows remote attackers to obtain sensitive information by requesting a file that had been previously retrieved by a caching proxy server.

Record
EUVD-2013-4381
Updated
2026-11-03
GitHub AdvisoriesGHSA-vm9c-39jx-q45w 6.9

Moodle vulnerable to Exposure of Sensitive Information to an Unauthorized Actor

lib/filelib.php in Moodle through 2.2.11, 2.3.x before 2.3.10, 2.4.x before 2.4.7, and 2.5.x before 2.5.3 does not send "Cache-Control: private" HTTP headers, which allows remote attackers to obtain sensitive information by requesting a file that had been previously retrieved by a caching proxy server.

Record
GHSA-vm9c-39jx-q45w
CVSS 4.0
6.9 MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N
Weakness
CWE-200
Updated
2026-11-02
OSVGHSA-vm9c-39jx-q45w 6.9

Moodle vulnerable to Exposure of Sensitive Information to an Unauthorized Actor

lib/filelib.php in Moodle through 2.2.11, 2.3.x before 2.3.10, 2.4.x before 2.4.7, and 2.5.x before 2.5.3 does not send "Cache-Control: private" HTTP headers, which allows remote attackers to obtain sensitive information by requesting a file that had been previously retrieved by a caching proxy server.

Record
GHSA-vm9c-39jx-q45w
CVSS 4.0
6.9 MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N
Weakness
CWE-200
Updated
2026-11-02
OSVMGASA-2013-0356 No score

Updated moodle package fixes security vulnerabilities

Some files were being delivered with incorrect headers in Moodle before 2.4.7, meaning they could be cached downstream (CVE-2013-4522).

Cross-site scripting in Moodle before 2.4.7 due to JavaScript in messages being executed on some pages (CVE-2013-4523).

The file system repository in Moodle before 2.4.7 was allowing access to files beyond the Moodle file area (CVE-2013-4524).

Cross-site scripting in Moodle before 2.4. due to JavaScript in question answers being executed on the Quiz Results page (CVE-2013-4525).

Record
MGASA-2013-0356
Updated
2026-11-02
OSVUBUNTU-CVE-2013-4522 No score

lib/filelib.php in Moodle through 2.2.11, 2.3.x before 2.3.10, 2.4.x before 2.4.7, and 2.5.x before 2.5.3 does not send "Cache-Control: private" HTTP headers, which allows remote attackers to obtain sensitive information by requesting a file that had been previously retrieved by a caching proxy server.

Record
UBUNTU-CVE-2013-4522
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
moodle/moodle
Packagist
before 2.3.10
2.3.10
moodle/moodle
Packagist
2.4.0-beta up to 2.4.7
2.4.7
moodle/moodle
Packagist
2.5.0-beta up to 2.5.3
2.5.3
moodle/moodle
Packagist
before 2.3.10, plus listed versions
v2.3.4v2.3.5v2.3.6v2.3.7v2.3.8v2.3.9
2.3.10
moodle/moodle
Packagist
2.4.0-beta up to 2.4.7, plus listed versions
v2.4.0v2.4.0-rc1v2.4.1v2.4.2v2.4.3v2.4.4v2.4.5v2.4.6
2.4.7
moodle/moodle
Packagist
2.5.0-beta up to 2.5.3, plus listed versions
v2.5.0v2.5.0-betav2.5.0-rc1v2.5.1v2.5.2
2.5.3
moodle
Mageia:3
From an advisory covering 4 CVEs
before 2.4.7-1.mga3
2.4.7-1.mga3

History

History
RecordedChangedSources
affected, facts
affected
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2013-4522 is a medium vulnerability (CVSS 5.0) in Moodle, published November 26, 2013. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.54%, the 75th percentile. Fixed in moodle/moodle 2.3.10.

References

Show 10 moreShow less
MoveEnter Open