Every CVE Search/ Get API key

CVE-2013-5018

The is_asn1 function in strongSwan 4.1.11 through 5.0.4 does not properly validate the return...

4.3 Medium

The is_asn1 function in strongSwan 4.1.11 through 5.0.4 does not properly validate the return value of the asn1_length function, which allows remote attackers to cause a denial of service (segmentation fault) via a (1) XAuth username, (2) EAP identity, or (3) PEM encoded file that starts with a 0x04, 0x30, or 0x31 character followed by an ASN.1 length value that triggers an integer overflow.

Exploit likelihood

2.99%Up 1.2 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 4.3

The is_asn1 function in strongSwan 4.1.11 through 5.0.4 does not properly validate the return value of the asn1_length function, which allows remote attackers to cause a denial of service (segmentation fault) via a (1) XAuth username, (2) EAP identity, or (3) PEM encoded file that starts with a 0x04, 0x30, or 0x31 character followed by an ASN.1 length value that triggers an integer overflow.

Record
CVE-2013-5018
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:N/A:P
Weakness
CWE-119
Updated
2026-11-02
CVE List No score

The is_asn1 function in strongSwan 4.1.11 through 5.0.4 does not properly validate the return value of the asn1_length function, which allows remote attackers to cause a denial of service (segmentation fault) via a (1) XAuth username, (2) EAP identity, or (3) PEM encoded file that starts with a 0x04, 0x30, or 0x31 character followed by an ASN.1 length value that triggers an integer overflow.

Record
CVE-2013-5018
Updated
2026-11-02
EUVDEUVD-2013-4860 No score

The is_asn1 function in strongSwan 4.1.11 through 5.0.4 does not properly validate the return value of the asn1_length function, which allows remote attackers to cause a denial of service (segmentation fault) via a (1) XAuth username, (2) EAP identity, or (3) PEM encoded file that starts with a 0x04, 0x30, or 0x31 character followed by an ASN.1 length value that triggers an integer overflow.

Record
EUVD-2013-4860
Updated
2026-11-03
GitHub AdvisoriesGHSA-7xq3-j5px-xf94 No score

The is_asn1 function in strongSwan 4.1.11 through 5.0.4 does not properly validate the return...

The is_asn1 function in strongSwan 4.1.11 through 5.0.4 does not properly validate the return value of the asn1_length function, which allows remote attackers to cause a denial of service (segmentation fault) via a (1) XAuth username, (2) EAP identity, or (3) PEM encoded file that starts with a 0x04, 0x30, or 0x31 character followed by an ASN.1 length value that triggers an integer overflow.

Record
GHSA-7xq3-j5px-xf94
Weakness
CWE-119
Updated
2026-11-02
OSVopenSUSE-SU-2024:10579-1 No score

strongswan-5.3.5-1.1 on GA media

These are all security issues fixed in the strongswan-5.3.5-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10579-1
Updated
2026-11-02
OSVSUSE-SU-2015:1227-1 No score

Security update for strongswan

This update fixes a NULL ptr dereference (DoS) via ID_DER_ASN1_DN ID payloads.

Security Issue reference:

* CVE-2014-2891
  <http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-2891>
Record
SUSE-SU-2015:1227-1
Updated
2026-11-02
OSVUBUNTU-CVE-2013-5018 No score

The is_asn1 function in strongSwan 4.1.11 through 5.0.4 does not properly validate the return value of the asn1_length function, which allows remote attackers to cause a denial of service (segmentation fault) via a (1) XAuth username, (2) EAP identity, or (3) PEM encoded file that starts with a 0x04, 0x30, or 0x31 character followed by an ASN.1 length value that triggers an integer overflow.

Record
UBUNTU-CVE-2013-5018
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
strongswan
openSUSE:Tumbleweed
From an advisory covering 11 CVEs
before 5.3.5-1.1
5.3.5-1.1

History

History
RecordedChangedSources
affected, facts
affected
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2013-5018 is a medium vulnerability (CVSS 4.3) in Strongswan, published August 28, 2013. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.99%, the 87th percentile. No source names a fixed version.

References

Show 27 moreShow less
MoveEnter Open