CVE-2013-7098
OpenConnect VPN client with GnuTLS before 5.02 contains a heap overflow if MTU is increased on...
OpenConnect VPN client with GnuTLS before 5.02 contains a heap overflow if MTU is increased on reconnection.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
OpenConnect VPN client with GnuTLS before 5.02 contains a heap overflow if MTU is increased on reconnection.
- Record
CVE-2013-7098- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-787
- Updated
- 2026-11-02
CVE List No score
OpenConnect VPN client with GnuTLS before 5.02 contains a heap overflow if MTU is increased on reconnection.
- Record
CVE-2013-7098- Updated
- 2026-11-02
EUVDEUVD-2013-6884 No score
OpenConnect VPN client with GnuTLS before 5.02 contains a heap overflow if MTU is increased on reconnection.
- Record
EUVD-2013-6884- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-5fg5-5jx7-ph2f No score
OpenConnect VPN client with GnuTLS before 5.02 contains a heap overflow if MTU is increased on...
OpenConnect VPN client with GnuTLS before 5.02 contains a heap overflow if MTU is increased on reconnection.
- Record
GHSA-5fg5-5jx7-ph2f- Updated
- 2026-11-02
OSV
9.8
OpenConnect VPN client with GnuTLS before 5.02 contains a heap overflow if MTU is increased on reconnection.
- Record
CVE-2013-7098- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2013-7098
9.8
OpenConnect VPN client with GnuTLS before 5.02 contains a heap overflow if MTU is increased on reconnection.
- Record
DEBIAN-CVE-2013-7098- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVopenSUSE-SU-2024:10553-1 No score
openconnect-7.07-1.3 on GA media
These are all security issues fixed in the openconnect-7.07-1.3 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:10553-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
openconnectDebian:12 |
before 5.02-1 | 5.02-1 |
openconnectDebian:13 |
before 5.02-1 | 5.02-1 |
openconnectDebian:14 |
before 5.02-1 | 5.02-1 |
openconnectopenSUSE:Tumbleweed From an advisory covering 3 CVEs |
before 7.07-1.3 | 7.07-1.3 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2013-7098 is a critical vulnerability (CVSS 9.8) in Infradead Openconnect, published February 13, 2020. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.54%, the 75th percentile. Fixed in openconnect 5.02-1.