CVE-2013-7284
The PlRPC module, possibly 0.2020 and earlier, for Perl uses the Storable module, which allows...
The PlRPC module, possibly 0.2020 and earlier, for Perl uses the Storable module, which allows remote attackers to execute arbitrary code via a crafted request, which is not properly handled when it is deserialized.
Exploit likelihood
What each source reports
NVD Score used
6.8
The PlRPC module, possibly 0.2020 and earlier, for Perl uses the Storable module, which allows remote attackers to execute arbitrary code via a crafted request, which is not properly handled when it is deserialized.
- Record
CVE-2013-7284- CVSS 2.0
- 6.8 Medium
AV:N/AC:M/Au:N/C:P/I:P/A:P - Weakness
- CWE-94
- Updated
- 2026-11-02
CVE List No score
The PlRPC module, possibly 0.2020 and earlier, for Perl uses the Storable module, which allows remote attackers to execute arbitrary code via a crafted request, which is not properly handled when it is deserialized.
- Record
CVE-2013-7284- Updated
- 2026-11-02
EUVDEUVD-2013-7062 No score
The PlRPC module, possibly 0.2020 and earlier, for Perl uses the Storable module, which allows remote attackers to execute arbitrary code via a crafted request, which is not properly handled when it is deserialized.
- Record
EUVD-2013-7062- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-7r2w-qgmh-r769 No score
The PlRPC module, possibly 0.2020 and earlier, for Perl uses the Storable module, which allows...
The PlRPC module, possibly 0.2020 and earlier, for Perl uses the Storable module, which allows remote attackers to execute arbitrary code via a crafted request, which is not properly handled when it is deserialized.
- Record
GHSA-7r2w-qgmh-r769- Weakness
- CWE-94
- Updated
- 2026-11-02
OSVSUSE-SU-2020:2238-1 No score
Security update for perl-PlRPC
This update for perl-PlRPC fixes the following issues:
- Security notice: [bsc#858243, CVE-2013-7284]
- Document security vulnerability on Storable and reply attack
- Add perl-PlRPC-CVE-2013-7284.patch
- Record
SUSE-SU-2020:2238-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
perl-PlRPCSUSE:Linux Enterprise Server 12 SP5 |
before 0.2020-25.3.1 | 0.2020-25.3.1 |
perl-PlRPCSUSE:Linux Enterprise Server for SAP Applications 12 SP5 |
before 0.2020-25.3.1 | 0.2020-25.3.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2013-7284 is a medium vulnerability (CVSS 6.8) in Malcolm Nooning Pirpc, published April 29, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.82%, the 86th percentile. Fixed in perl-PlRPC 0.2020-25.3.1.