Every CVE Search/ Get API key

CVE-2014-3005

XML external entity (XXE) vulnerability in Zabbix 1.8.x before 1.8.21rc1, 2.0.x before 2.0.13rc1,...

9.8 CriticalFix available

XML external entity (XXE) vulnerability in Zabbix 1.8.x before 1.8.21rc1, 2.0.x before 2.0.13rc1, 2.2.x before 2.2.5rc1, and 2.3.x before 2.3.2 allows remote attackers to read arbitrary files or potentially execute arbitrary code via a crafted DTD in an XML request.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

6.46%Down 0.3 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 9.8

XML external entity (XXE) vulnerability in Zabbix 1.8.x before 1.8.21rc1, 2.0.x before 2.0.13rc1, 2.2.x before 2.2.5rc1, and 2.3.x before 2.3.2 allows remote attackers to read arbitrary files or potentially execute arbitrary code via a crafted DTD in an XML request.

Record
CVE-2014-3005
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-611
Updated
2026-11-02
CVE List No score

XML external entity (XXE) vulnerability in Zabbix 1.8.x before 1.8.21rc1, 2.0.x before 2.0.13rc1, 2.2.x before 2.2.5rc1, and 2.3.x before 2.3.2 allows remote attackers to read arbitrary files or potentially execute arbitrary code via a crafted DTD in an XML request.

Record
CVE-2014-3005
Updated
2026-11-02
EUVDEUVD-2014-3027 No score

XML external entity (XXE) vulnerability in Zabbix 1.8.x before 1.8.21rc1, 2.0.x before 2.0.13rc1, 2.2.x before 2.2.5rc1, and 2.3.x before 2.3.2 allows remote attackers to read arbitrary files or potentially execute arbitrary code via a crafted DTD in an XML request.

Record
EUVD-2014-3027
Updated
2026-11-03
GitHub AdvisoriesGHSA-5xxv-j4hw-gp2p 9.8

XML external entity (XXE) vulnerability in Zabbix 1.8.x before 1.8.21rc1, 2.0.x before 2.0.13rc1,...

XML external entity (XXE) vulnerability in Zabbix 1.8.x before 1.8.21rc1, 2.0.x before 2.0.13rc1, 2.2.x before 2.2.5rc1, and 2.3.x before 2.3.2 allows remote attackers to read arbitrary files or potentially execute arbitrary code via a crafted DTD in an XML request.

Record
GHSA-5xxv-j4hw-gp2p
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-611
Updated
2026-11-02
OSV 9.8

XML external entity (XXE) vulnerability in Zabbix 1.8.x before 1.8.21rc1, 2.0.x before 2.0.13rc1, 2.2.x before 2.2.5rc1, and 2.3.x before 2.3.2 allows remote attackers to read arbitrary files or potentially execute arbitrary code via a crafted DTD in an XML request.

Record
CVE-2014-3005
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2014-3005 9.8

XML external entity (XXE) vulnerability in Zabbix 1.8.x before 1.8.21rc1, 2.0.x before 2.0.13rc1, 2.2.x before 2.2.5rc1, and 2.3.x before 2.3.2 allows remote attackers to read arbitrary files or potentially execute arbitrary code via a crafted DTD in an XML request.

Record
DEBIAN-CVE-2014-3005
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2014-3005 9.8

XML external entity (XXE) vulnerability in Zabbix 1.8.x before 1.8.21rc1, 2.0.x before 2.0.13rc1, 2.2.x before 2.2.5rc1, and 2.3.x before 2.3.2 allows remote attackers to read arbitrary files or potentially execute arbitrary code via a crafted DTD in an XML request.

Record
UBUNTU-CVE-2014-3005
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVMGASA-2014-0433 No score

Updated zabbix package fixes security vulnerability

It was reported that the Zabbix frontend supported an XML data import feature, where on the server it used DOMDocument to parse the XML. By default, DOMDocument also parses the external DTD, which could allow a remote attacker to use a crafted XML file causing Zabbix to read an arbitrary local file, and send the contents of the specified file to a remote server (CVE-2014-3005).

Record
MGASA-2014-0433
Updated
2026-11-02
OSVUSN-4767-1 No score

zabbix vulnerabilities

Fu Chuang discovered that Zabbix did not properly parse IPs. A remote attacker could possibly use this issue to execute arbitrary code. This issue only affected Ubuntu 14.04 ESM, Ubuntu 16.04 ESM and Ubuntu 18.04 ESM. (CVE-2020-11800)

It was discovered that Zabbix incorrectly handled certain requests. A remote attacker could possibly use this issue to execute arbitrary code. This issue only affected Ubuntu 14.04 ESM and Ubuntu 16.04 ESM. (CVE-2017-2824, CVE-2017-2825)

It was discovered that Zabbix incorrectly handled certain XML files. A remote attacker could possibly use this issue to read arbitrary files or potentially execute arbitrary code. This issue only affected Ubuntu 14.04 ESM. (CVE-2014-3005)

It was discovered that Zabbix incorrectly handled certain inputs. A remote attacker could possibly use this issue to execute arbitrary SQL commands. This issue only affected Ubuntu 14.04 ESM. (CVE-2016-10134, CVE-2016-4338)

It was discovered that Zabbix incorrectly handled the request parameter. A remote attacker could possibly use this issue to redirect requests to external links. This issue only affected Ubuntu 14.04 ESM and Ubuntu 18.04 ESM. (CVE-2016-10742)

It was discovered that Zabbix incorrectly handled failed login attempts. A remote attacker could possibly use this issue to enumerate users. (CVE-2019-15132)

It was discovered that Zabbix did not properly validate input. A remote attacker could exploit this to conduct cross-site scripting (XSS) attacks. This issue only affected Ubuntu 16.04 ESM, Ubuntu 18.04 ESM and Ubuntu 20.04 ESM. (CVE-2020-15803)

Record
USN-4767-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
zabbix
Debian:12
before 1:2.2.5+dfsg-1
1:2.2.5+dfsg-1
zabbix
Debian:13
before 1:2.2.5+dfsg-1
1:2.2.5+dfsg-1
zabbix
Debian:14
before 1:2.2.5+dfsg-1
1:2.2.5+dfsg-1
zabbix
Mageia:3
before 2.0.13-1.mga3
2.0.13-1.mga3
zabbix
Mageia:4
before 2.0.13-1.mga4
2.0.13-1.mga4
zabbix
Ubuntu:Pro:14.04:LTS
before 1:2.2.2+dfsg-1ubuntu1+esm1, plus listed versions
1:2.0.6+dfsg-1ubuntu21:2.2.0+dfsg-1ubuntu11:2.2.0+dfsg-6ubuntu11:2.2.1+dfsg-1ubuntu31:2.2.2+dfsg-1ubuntu1
1:2.2.2+dfsg-1ubuntu1+esm1
zabbix
Ubuntu:Pro:14.04:LTS
before 1:2.2.2+dfsg-1ubuntu1+esm4, plus listed versions
1:2.0.6+dfsg-1ubuntu21:2.2.0+dfsg-1ubuntu11:2.2.0+dfsg-6ubuntu11:2.2.1+dfsg-1ubuntu31:2.2.2+dfsg-1ubuntu11:2.2.2+dfsg-1ubuntu1+esm11:2.2.2+dfsg-1ubuntu1+esm3
1:2.2.2+dfsg-1ubuntu1+esm4
zabbix
Ubuntu:Pro:16.04:LTS
before 1:2.4.7+dfsg-2ubuntu2.1+esm3, plus listed versions
1:2.4.6+dfsg-11:2.4.7+dfsg-11:2.4.7+dfsg-21:2.4.7+dfsg-2ubuntu21:2.4.7+dfsg-2ubuntu2.11:2.4.7+dfsg-2ubuntu2.1+esm11:2.4.7+dfsg-2ubuntu2.1+esm2
1:2.4.7+dfsg-2ubuntu2.1+esm3
zabbix
Ubuntu:Pro:18.04:LTS
before 1:3.0.12+dfsg-1ubuntu0.1~esm3, plus listed versions
1:3.0.7+dfsg-31:3.0.12+dfsg-11:3.0.12+dfsg-1ubuntu0.1~esm11:3.0.12+dfsg-1ubuntu0.1~esm2
1:3.0.12+dfsg-1ubuntu0.1~esm3
zabbix
Ubuntu:Pro:20.04:LTS
before 1:4.0.17+dfsg-1ubuntu0.1~esm1, plus listed versions
1:4.0.4+dfsg-1build21:4.0.4+dfsg-1build31:4.0.11+dfsg-11:4.0.14+dfsg-11:4.0.15+dfsg-11:4.0.16+dfsg-11:4.0.16+dfsg-1build11:4.0.17+dfsg-1
1:4.0.17+dfsg-1ubuntu0.1~esm1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2014-3005 is a critical vulnerability (CVSS 9.8) in Zabbix, published October 29, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 6.46%, the 93rd percentile. Fixed in zabbix 1:2.2.5+dfsg-1.

References

Show 19 moreShow less
MoveEnter Open