Every CVE Search/ Get API key

CVE-2014-3622

Use-after-free vulnerability in the add_post_var function in the Posthandler component in PHP 5.6...

9.8 Critical

Use-after-free vulnerability in the add_post_var function in the Posthandler component in PHP 5.6.x before 5.6.1 might allow remote attackers to execute arbitrary code by leveraging a third-party filter extension that accesses a certain ksep value.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

3.12%Down 2.5 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 9.8

Use-after-free vulnerability in the add_post_var function in the Posthandler component in PHP 5.6.x before 5.6.1 might allow remote attackers to execute arbitrary code by leveraging a third-party filter extension that accesses a certain ksep value.

Record
CVE-2014-3622
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Weakness
CWE-416
Updated
2026-11-02
CVE List No score

Use-after-free vulnerability in the add_post_var function in the Posthandler component in PHP 5.6.x before 5.6.1 might allow remote attackers to execute arbitrary code by leveraging a third-party filter extension that accesses a certain ksep value.

Record
CVE-2014-3622
Updated
2026-11-02
EUVDEUVD-2014-3584 No score

Use-after-free vulnerability in the add_post_var function in the Posthandler component in PHP 5.6.x before 5.6.1 might allow remote attackers to execute arbitrary code by leveraging a third-party filter extension that accesses a certain ksep value.

Record
EUVD-2014-3584
Updated
2026-11-03
GitHub AdvisoriesGHSA-9whx-7f88-q2wx No score

Use-after-free vulnerability in the add_post_var function in the Posthandler component in PHP 5.6...

Use-after-free vulnerability in the add_post_var function in the Posthandler component in PHP 5.6.x before 5.6.1 might allow remote attackers to execute arbitrary code by leveraging a third-party filter extension that accesses a certain ksep value.

Record
GHSA-9whx-7f88-q2wx
Updated
2026-11-02
OSVopenSUSE-SU-2024:10290-1 No score

apache2-mod_php7-7.0.14-1.4 on GA media

These are all security issues fixed in the apache2-mod_php7-7.0.14-1.4 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10290-1
Updated
2026-11-02
OSVopenSUSE-SU-2024:10344-1 No score

apache2-mod_php5-5.6.28-1.1 on GA media

These are all security issues fixed in the apache2-mod_php5-5.6.28-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10344-1
Updated
2026-11-02
OSVopenSUSE-SU-2024:11169-1 No score

php8-8.0.11-1.1 on GA media

These are all security issues fixed in the php8-8.0.11-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:11169-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
php7
openSUSE:Tumbleweed
From an advisory covering 70 CVEs
before 7.0.14-1.4
7.0.14-1.4
php5
openSUSE:Tumbleweed
From an advisory covering 71 CVEs
before 5.6.28-1.1
5.6.28-1.1
php8
openSUSE:Tumbleweed
From an advisory covering 97 CVEs
before 8.0.11-1.1
8.0.11-1.1

History

History
RecordedChangedSources
affected, facts
aliases, productsEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2014-3622 is a critical vulnerability (CVSS 9.8) in Php, published February 19, 2020. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.12%, the 87th percentile. No source names a fixed version.

References

Show 114 moreShow less
MoveEnter Open