Every CVE Search/ Get API key

CVE-2014-4349

Multiple cross-site scripting (XSS) vulnerabilities in phpMyAdmin 4.1.x before 4.1.14.1 and 4.2.x...

3.5 LowFix available

Multiple cross-site scripting (XSS) vulnerabilities in phpMyAdmin 4.1.x before 4.1.14.1 and 4.2.x before 4.2.4 allow remote authenticated users to inject arbitrary web script or HTML via a crafted table name that is improperly handled after a (1) hide or (2) unhide action.

Exploit likelihood

2.15%Up 0.9 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 3.5

Multiple cross-site scripting (XSS) vulnerabilities in phpMyAdmin 4.1.x before 4.1.14.1 and 4.2.x before 4.2.4 allow remote authenticated users to inject arbitrary web script or HTML via a crafted table name that is improperly handled after a (1) hide or (2) unhide action.

Record
CVE-2014-4349
CVSS 2.0
3.5 LowAV:N/AC:M/Au:S/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

Multiple cross-site scripting (XSS) vulnerabilities in phpMyAdmin 4.1.x before 4.1.14.1 and 4.2.x before 4.2.4 allow remote authenticated users to inject arbitrary web script or HTML via a crafted table name that is improperly handled after a (1) hide or (2) unhide action.

Record
CVE-2014-4349
Updated
2026-11-02
EUVDEUVD-2014-4276 No score

Multiple cross-site scripting (XSS) vulnerabilities in phpMyAdmin 4.1.x before 4.1.14.1 and 4.2.x before 4.2.4 allow remote authenticated users to inject arbitrary web script or HTML via a crafted table name that is improperly handled after a (1) hide or (2) unhide action.

Record
EUVD-2014-4276
Updated
2026-11-03
GitHub AdvisoriesGHSA-47r4-gvw9-7fw7 No score

Multiple cross-site scripting (XSS) vulnerabilities in phpMyAdmin 4.1.x before 4.1.14.1 and 4.2.x...

Multiple cross-site scripting (XSS) vulnerabilities in phpMyAdmin 4.1.x before 4.1.14.1 and 4.2.x before 4.2.4 allow remote authenticated users to inject arbitrary web script or HTML via a crafted table name that is improperly handled after a (1) hide or (2) unhide action.

Record
GHSA-47r4-gvw9-7fw7
Weakness
CWE-79
Updated
2026-11-02
OSV No score

Multiple cross-site scripting (XSS) vulnerabilities in phpMyAdmin 4.1.x before 4.1.14.1 and 4.2.x before 4.2.4 allow remote authenticated users to inject arbitrary web script or HTML via a crafted table name that is improperly handled after a (1) hide or (2) unhide action.

Record
CVE-2014-4349
Updated
2026-11-02
OSVDEBIAN-CVE-2014-4349 No score

Multiple cross-site scripting (XSS) vulnerabilities in phpMyAdmin 4.1.x before 4.1.14.1 and 4.2.x before 4.2.4 allow remote authenticated users to inject arbitrary web script or HTML via a crafted table name that is improperly handled after a (1) hide or (2) unhide action.

Record
DEBIAN-CVE-2014-4349
Updated
2026-11-02
OSVMGASA-2014-0275 No score

Updated phpmyadmin packages fix CVE-2014-4349

Updated phpmyadmin packages fix security vulnerability:

In phpMyAdmin before 4.1.14, it is possible to trigger an XSS when hiding or unhiding a crafted table name in the navigation, due to unescaped HTML output in the navigation items hiding feature. Note that this vulnerability can only be triggered by someone who logged in to phpMyAdmin, as the usual token protection prevents non-logged-in users from accessing the required form (CVE-2014-4349).

Record
MGASA-2014-0275
Updated
2026-11-02
OSVopenSUSE-SU-2024:10054-1 No score

phpMyAdmin-4.6.5.2-1.1 on GA media

These are all security issues fixed in the phpMyAdmin-4.6.5.2-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10054-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
phpmyadmin
Debian:12
before 4:4.2.5-1
4:4.2.5-1
phpmyadmin
Debian:13
before 4:4.2.5-1
4:4.2.5-1
phpmyadmin
Debian:14
before 4:4.2.5-1
4:4.2.5-1
phpmyadmin
Mageia:3
before 4.1.14.1-1.mga3
4.1.14.1-1.mga3
phpmyadmin
Mageia:4
before 4.1.14.1-1.mga4
4.1.14.1-1.mga4
phpMyAdmin
openSUSE:Tumbleweed
From an advisory covering 124 CVEs
before 4.6.5.2-1.1
4.6.5.2-1.1

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2014-4349 is a low vulnerability (CVSS 3.5) in Phpmyadmin, published June 25, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.15%, the 82nd percentile. Fixed in phpmyadmin 4:4.2.5-1.

References

Show 129 moreShow less
MoveEnter Open