Every CVE Search/ Get API key

CVE-2014-5008

Snoopy allows remote attackers to execute arbitrary commands.

9.8 CriticalFix available

Snoopy allows remote attackers to execute arbitrary commands.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

4.13%Up 2.0 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 9.8

Snoopy allows remote attackers to execute arbitrary commands.

Record
CVE-2014-5008
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-77
Updated
2026-11-02
CVE List No score

Snoopy allows remote attackers to execute arbitrary commands.

Record
CVE-2014-5008
Updated
2026-11-02
EUVDEUVD-2014-4910 No score

Snoopy allows remote attackers to execute arbitrary commands.

Record
EUVD-2014-4910
Updated
2026-11-03
GitHub AdvisoriesGHSA-cpmq-w8c4-79w6 9.8

Snoopy allows remote attackers to execute arbitrary commands.

Snoopy allows remote attackers to execute arbitrary commands.

Record
GHSA-cpmq-w8c4-79w6
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-77
Updated
2026-11-02
OSV 9.8

Snoopy allows remote attackers to execute arbitrary commands.

Record
CVE-2014-5008
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2014-5008 9.8

Snoopy allows remote attackers to execute arbitrary commands.

Record
DEBIAN-CVE-2014-5008
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
Show 5 moreShow less
OSVRHSA-2017:0211 8.1

Red Hat Security Advisory: nagios security update

Record
RHSA-2017:0211
CVSS 3.0
8.1 HighCVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVRHSA-2017:0212 8.1

Red Hat Security Advisory: nagios security update

Record
RHSA-2017:0212
CVSS 3.0
8.1 HighCVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVRHSA-2017:0213 8.1

Red Hat Security Advisory: nagios security update

Record
RHSA-2017:0213
CVSS 3.0
8.1 HighCVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVRHSA-2017:0214 8.1

Red Hat Security Advisory: nagios security update

Record
RHSA-2017:0214
CVSS 3.0
8.1 HighCVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2014-5008 9.8

Snoopy allows remote attackers to execute arbitrary commands.

Record
UBUNTU-CVE-2014-5008
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
libphp-snoopy
Debian:12
before 2.0.0-1
2.0.0-1
libphp-snoopy
Debian:6.0
From an advisory covering 2 CVEs
before 2.0.0-1~deb6u1, plus listed versions
1.2.4-2
2.0.0-1~deb6u1
libphp-snoopy
Debian:7
From an advisory covering 2 CVEs
before 2.0.0-1~deb7u1, plus listed versions
1.2.4-22.0.0-1~deb6u1
2.0.0-1~deb7u1
nagios
Red Hat:openstack:5::el7
From an advisory covering 5 CVEs
before 0:3.5.1-9.el7
0:3.5.1-9.el7
nagios-common
Red Hat:openstack:5::el7
From an advisory covering 5 CVEs
before 0:3.5.1-9.el7
0:3.5.1-9.el7
nagios-debuginfo
Red Hat:openstack:5::el7
From an advisory covering 5 CVEs
before 0:3.5.1-9.el7
0:3.5.1-9.el7
nagios-devel
Red Hat:openstack:5::el7
From an advisory covering 5 CVEs
before 0:3.5.1-9.el7
0:3.5.1-9.el7
nagios
Red Hat:openstack:5::el6
From an advisory covering 5 CVEs
before 0:3.5.1-9.el6
0:3.5.1-9.el6
nagios-common
Red Hat:openstack:5::el6
From an advisory covering 5 CVEs
before 0:3.5.1-9.el6
0:3.5.1-9.el6
nagios-debuginfo
Red Hat:openstack:5::el6
From an advisory covering 5 CVEs
before 0:3.5.1-9.el6
0:3.5.1-9.el6
Show 7 moreShow less
Affected packages
PackageAffectedFixed
nagios-devel
Red Hat:openstack:5::el6
From an advisory covering 5 CVEs
before 0:3.5.1-9.el6
0:3.5.1-9.el6
nagios
Red Hat:openstack:6::el7
From an advisory covering 5 CVEs
before 0:3.5.1-9.el7
0:3.5.1-9.el7
nagios-common
Red Hat:openstack:6::el7
From an advisory covering 5 CVEs
before 0:3.5.1-9.el7
0:3.5.1-9.el7
nagios-debuginfo
Red Hat:openstack:6::el7
From an advisory covering 5 CVEs
before 0:3.5.1-9.el7
0:3.5.1-9.el7
nagios
Red Hat:openstack:7::el7
From an advisory covering 5 CVEs
before 0:3.5.1-9.el7
0:3.5.1-9.el7
nagios-common
Red Hat:openstack:7::el7
From an advisory covering 5 CVEs
before 0:3.5.1-9.el7
0:3.5.1-9.el7
nagios-debuginfo
Red Hat:openstack:7::el7
From an advisory covering 5 CVEs
before 0:3.5.1-9.el7
0:3.5.1-9.el7

History

History
RecordedChangedSources
affected, facts
affected
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2014-5008 is a critical vulnerability (CVSS 9.8) in Snoopy, published May 2, 2015. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 4.13%, the 90th percentile. Fixed in libphp-snoopy 2.0.0-1.

References

Show 38 moreShow less
MoveEnter Open