CVE-2014-5021
Cross-site scripting (XSS) vulnerability in the Form API in Drupal 6.x before 6.32 and possibly 7...
Cross-site scripting (XSS) vulnerability in the Form API in Drupal 6.x before 6.32 and possibly 7.x before 7.29 allows remote authenticated users with the "administer taxonomy" permission to inject arbitrary web script or HTML via an option group label.
Exploit likelihood
What each source reports
NVD Score used
2.1
Cross-site scripting (XSS) vulnerability in the Form API in Drupal 6.x before 6.32 and possibly 7.x before 7.29 allows remote authenticated users with the "administer taxonomy" permission to inject arbitrary web script or HTML via an option group label.
- Record
CVE-2014-5021- CVSS 2.0
- 2.1 Low
AV:N/AC:H/Au:S/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
Cross-site scripting (XSS) vulnerability in the Form API in Drupal 6.x before 6.32 and possibly 7.x before 7.29 allows remote authenticated users with the "administer taxonomy" permission to inject arbitrary web script or HTML via an option group label.
- Record
CVE-2014-5021- Updated
- 2026-11-02
EUVDEUVD-2014-4920 No score
Cross-site scripting (XSS) vulnerability in the Form API in Drupal 6.x before 6.32 and possibly 7.x before 7.29 allows remote authenticated users with the "administer taxonomy" permission to inject arbitrary web script or HTML via an option group label.
- Record
EUVD-2014-4920- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-c33g-h7g2-frf6 No score
Cross-site scripting (XSS) vulnerability in the Form API in Drupal 6.x before 6.32 and possibly 7...
Cross-site scripting (XSS) vulnerability in the Form API in Drupal 6.x before 6.32 and possibly 7.x before 7.29 allows remote authenticated users with the "administer taxonomy" permission to inject arbitrary web script or HTML via an option group label.
- Record
GHSA-c33g-h7g2-frf6- Weakness
- CWE-79
- Updated
- 2026-11-02
OSVMGASA-2014-0322 No score
Updated drupal packages fix security vulnerabilities
An information disclosure vulnerability was discovered in Drupal before 7.27. When pages are cached for anonymous users, form state may leak between anonymous users. Sensitive or private information recorded for one anonymous user could thus be disclosed to other users interacting with the same form at the same time (CVE-2014-2983).
Multiple security issues in Drupal before 7.29, including a denial of service issue, an access bypass issue in the File module, and multiple cross-site scripting issues (CVE-2014-5019, CVE-2014-5020, CVE-2014-5021, CVE-2014-5022).
Drupal has been updated to version 7.29, fixing this and other bugs.
- Record
MGASA-2014-0322- Updated
- 2026-11-02
OSVUBUNTU-CVE-2014-5021 No score
Cross-site scripting (XSS) vulnerability in the Form API in Drupal 6.x before 6.32 and possibly 7.x before 7.29 allows remote authenticated users with the "administer taxonomy" permission to inject arbitrary web script or HTML via an option group label.
- Record
UBUNTU-CVE-2014-5021- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
drupal7Debian:7 From an advisory covering 4 CVEs |
before 7.14-2+deb7u5, plus listed versions 7.14-27.14-2+deb7u17.14-2+deb7u1~bpo60+17.14-2+deb7u27.14-2+deb7u2~bpo60+17.14-2+deb7u37.14-2+deb7u47.14-2+deb7u4~bpo60+1 |
7.14-2+deb7u5 |
drupalMageia:3 From an advisory covering 5 CVEs |
before 7.29-1.mga3 | 7.29-1.mga3 |
drupalMageia:4 From an advisory covering 5 CVEs |
before 7.29-1.mga4 | 7.29-1.mga4 |
drupal7Ubuntu:Pro:14.04:LTS |
All versions, plus listed versions 7.23-17.24-17.24-27.26-17.26-1ubuntu0.17.26-1ubuntu0.1+esm17.26-1ubuntu0.1+esm27.26-1ubuntu0.1+esm3 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2014-5021 is a low vulnerability (CVSS 2.1) in Drupal, published July 20, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.10%, the 65th percentile. No source names a fixed version.
References
debian.org/security/2014/dsa-2983
drupal.org/SA-CORE-2014-003
nvd.nist.gov/vuln/detail/CVE-2014-5021
github.com/advisories/GHSA-c33g-h7g2-frf6
advisories.mageia.org/MGASA-2014-0322.html
bugs.mageia.org/show_bug.cgi?id=13271
Show 10 moreShow less
drupal.org/SA-CORE-2014-002
drupal.org/drupal-7.27
drupal.org/drupal-7.27-release-notes
drupal.org/drupal-7.28
drupal.org/drupal-7.28-release-notes
drupal.org/drupal-7.29
drupal.org/drupal-7.29-release-notes
debian.org/security/2014/dsa-2913
ubuntu.com/security/CVE-2014-5021
cve.org/CVERecord?id=CVE-2014-5021