Every CVE Search/ Get API key

CVE-2014-5022

Cross-site scripting (XSS) vulnerability in the Ajax system in Drupal 7.x before 7.29 allows...

4.3 Medium

Cross-site scripting (XSS) vulnerability in the Ajax system in Drupal 7.x before 7.29 allows remote attackers to inject arbitrary web script or HTML via vectors involving forms with an Ajax-enabled textfield and a file field.

Exploit likelihood

1.00%Down 0.1 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 4.3

Cross-site scripting (XSS) vulnerability in the Ajax system in Drupal 7.x before 7.29 allows remote attackers to inject arbitrary web script or HTML via vectors involving forms with an Ajax-enabled textfield and a file field.

Record
CVE-2014-5022
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

Cross-site scripting (XSS) vulnerability in the Ajax system in Drupal 7.x before 7.29 allows remote attackers to inject arbitrary web script or HTML via vectors involving forms with an Ajax-enabled textfield and a file field.

Record
CVE-2014-5022
Updated
2026-11-02
EUVDEUVD-2014-4921 No score

Cross-site scripting (XSS) vulnerability in the Ajax system in Drupal 7.x before 7.29 allows remote attackers to inject arbitrary web script or HTML via vectors involving forms with an Ajax-enabled textfield and a file field.

Record
EUVD-2014-4921
Updated
2026-11-03
GitHub AdvisoriesGHSA-j47j-5wh7-4gmm No score

Cross-site scripting (XSS) vulnerability in the Ajax system in Drupal 7.x before 7.29 allows...

Cross-site scripting (XSS) vulnerability in the Ajax system in Drupal 7.x before 7.29 allows remote attackers to inject arbitrary web script or HTML via vectors involving forms with an Ajax-enabled textfield and a file field.

Record
GHSA-j47j-5wh7-4gmm
Weakness
CWE-79
Updated
2026-11-02
OSVMGASA-2014-0322 No score

Updated drupal packages fix security vulnerabilities

An information disclosure vulnerability was discovered in Drupal before 7.27. When pages are cached for anonymous users, form state may leak between anonymous users. Sensitive or private information recorded for one anonymous user could thus be disclosed to other users interacting with the same form at the same time (CVE-2014-2983).

Multiple security issues in Drupal before 7.29, including a denial of service issue, an access bypass issue in the File module, and multiple cross-site scripting issues (CVE-2014-5019, CVE-2014-5020, CVE-2014-5021, CVE-2014-5022).

Drupal has been updated to version 7.29, fixing this and other bugs.

Record
MGASA-2014-0322
Updated
2026-11-02
OSVUBUNTU-CVE-2014-5022 No score

Cross-site scripting (XSS) vulnerability in the Ajax system in Drupal 7.x before 7.29 allows remote attackers to inject arbitrary web script or HTML via vectors involving forms with an Ajax-enabled textfield and a file field.

Record
UBUNTU-CVE-2014-5022
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
drupal7
Debian:7
From an advisory covering 4 CVEs
before 7.14-2+deb7u5, plus listed versions
7.14-27.14-2+deb7u17.14-2+deb7u1~bpo60+17.14-2+deb7u27.14-2+deb7u2~bpo60+17.14-2+deb7u37.14-2+deb7u47.14-2+deb7u4~bpo60+1
7.14-2+deb7u5
drupal
Mageia:3
From an advisory covering 5 CVEs
before 7.29-1.mga3
7.29-1.mga3
drupal
Mageia:4
From an advisory covering 5 CVEs
before 7.29-1.mga4
7.29-1.mga4
drupal7
Ubuntu:Pro:14.04:LTS
All versions, plus listed versions
7.23-17.24-17.24-27.26-17.26-1ubuntu0.17.26-1ubuntu0.1+esm17.26-1ubuntu0.1+esm27.26-1ubuntu0.1+esm3
None known

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2014-5022 is a medium vulnerability (CVSS 4.3) in Drupal, published July 20, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.00%, the 62nd percentile. No source names a fixed version.

References

Show 10 moreShow less
MoveEnter Open