Every CVE Search/ Get API key

CVE-2014-5270

Libgcrypt before 1.5.4, as used in GnuPG and other products, does not properly perform ciphertext...

2.1 LowFix available

Libgcrypt before 1.5.4, as used in GnuPG and other products, does not properly perform ciphertext normalization and ciphertext randomization, which makes it easier for physically proximate attackers to conduct key-extraction attacks by leveraging the ability to collect voltage data from exposed metal, a different vector than CVE-2013-4576.

Exploit likelihood

0.53%Down 0.5 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 2.1

Libgcrypt before 1.5.4, as used in GnuPG and other products, does not properly perform ciphertext normalization and ciphertext randomization, which makes it easier for physically proximate attackers to conduct key-extraction attacks by leveraging the ability to collect voltage data from exposed metal, a different vector than CVE-2013-4576.

Record
CVE-2014-5270
CVSS 2.0
2.1 LowAV:L/AC:L/Au:N/C:P/I:N/A:N
Weakness
CWE-200
Updated
2026-11-02
CVE List No score

Libgcrypt before 1.5.4, as used in GnuPG and other products, does not properly perform ciphertext normalization and ciphertext randomization, which makes it easier for physically proximate attackers to conduct key-extraction attacks by leveraging the ability to collect voltage data from exposed metal, a different vector than CVE-2013-4576.

Record
CVE-2014-5270
Updated
2026-11-02
EUVDEUVD-2014-5163 No score

Libgcrypt before 1.5.4, as used in GnuPG and other products, does not properly perform ciphertext normalization and ciphertext randomization, which makes it easier for physically proximate attackers to conduct key-extraction attacks by leveraging the ability to collect voltage data from exposed metal, a different vector than CVE-2013-4576.

Record
EUVD-2014-5163
Updated
2026-11-03
GitHub AdvisoriesGHSA-47gj-9v97-r4c7 No score

Libgcrypt before 1.5.4, as used in GnuPG and other products, does not properly perform ciphertext...

Libgcrypt before 1.5.4, as used in GnuPG and other products, does not properly perform ciphertext normalization and ciphertext randomization, which makes it easier for physically proximate attackers to conduct key-extraction attacks by leveraging the ability to collect voltage data from exposed metal, a different vector than CVE-2013-4576.

Record
GHSA-47gj-9v97-r4c7
Weakness
CWE-200
Updated
2026-11-02
OSV No score

Libgcrypt before 1.5.4, as used in GnuPG and other products, does not properly perform ciphertext normalization and ciphertext randomization, which makes it easier for physically proximate attackers to conduct key-extraction attacks by leveraging the ability to collect voltage data from exposed metal, a different vector than CVE-2013-4576.

Record
CVE-2014-5270
Updated
2026-11-02
OSVDEBIAN-CVE-2014-5270 No score

Libgcrypt before 1.5.4, as used in GnuPG and other products, does not properly perform ciphertext normalization and ciphertext randomization, which makes it easier for physically proximate attackers to conduct key-extraction attacks by leveraging the ability to collect voltage data from exposed metal, a different vector than CVE-2013-4576.

Record
DEBIAN-CVE-2014-5270
Updated
2026-11-02
Show 5 moreShow less
OSVMGASA-2014-0365 No score

Updated libgcrypt packages fix CVE-2014-5270

Updated libgcrypt packages fix security vulnerability:

The libgcrypt library before version 1.5.4 is vulnerable to an ELGAMAL side-channel attack (CVE-2014-5270).

Record
MGASA-2014-0365
Updated
2026-11-02
OSVMGASA-2014-0381 No score

Updated gnupg packages fix CVE-2014-5270

Updated gnupg packages fix security vulnerability:

The gnupg program before version 1.4.16 is vulnerable to an ELGAMAL side-channel attack (CVE-2014-5270).

Record
MGASA-2014-0381
Updated
2026-11-02
OSVUBUNTU-CVE-2014-5270 No score

Libgcrypt before 1.5.4, as used in GnuPG and other products, does not properly perform ciphertext normalization and ciphertext randomization, which makes it easier for physically proximate attackers to conduct key-extraction attacks by leveraging the ability to collect voltage data from exposed metal, a different vector than CVE-2013-4576.

Record
UBUNTU-CVE-2014-5270
Updated
2026-11-02
OSVUSN-2339-2 No score

libgcrypt11 vulnerability

Daniel Genkin, Adi Shamir, and Eran Tromer discovered that Libgcrypt was susceptible to an adaptive chosen ciphertext attack via physical side channels. A local attacker could use this attack to possibly recover private keys.

Record
USN-2339-2
Updated
2026-11-02
OSVUSN-2554-1 No score

gnupg, gnupg2 vulnerabilities

Daniel Genkin, Lev Pachmanov, Itamar Pipman, and Eran Tromer discovered that GnuPG was susceptible to an attack via physical side channels. A local attacker could use this attack to possibly recover private keys. (CVE-2014-3591)

Daniel Genkin, Adi Shamir, and Eran Tromer discovered that GnuPG was susceptible to an attack via physical side channels. A local attacker could use this attack to possibly recover private keys. (CVE-2015-0837)

Hanno Böck discovered that GnuPG incorrectly handled certain malformed keyrings. If a user or automated system were tricked into opening a malformed keyring, a remote attacker could use this issue to cause GnuPG to crash, resulting in a denial of service, or possibly execute arbitrary code. (CVE-2015-1606, CVE-2015-1607)

In addition, this update improves GnuPG security by validating that the keys returned by keyservers match those requested.

Record
USN-2554-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
libgcrypt20
Debian:12
before 1.6.0-2
1.6.0-2
libgcrypt20
Debian:13
before 1.6.0-2
1.6.0-2
libgcrypt20
Debian:14
before 1.6.0-2
1.6.0-2
gnupg
Debian:6.0
before 1.4.10-4+squeeze6, plus listed versions
1.4.10-41.4.10-4+squeeze11.4.10-4+squeeze21.4.10-4+squeeze31.4.10-4+squeeze41.4.10-4+squeeze5
1.4.10-4+squeeze6
libgcrypt11
Debian:6.0
before 1.4.5-2+squeeze2, plus listed versions
1.4.5-21.4.5-2+squeeze1
1.4.5-2+squeeze2
gnupg
Debian:7
before 1.4.12-7+deb7u6, plus listed versions
1.4.12-71.4.12-7+deb7u11.4.12-7+deb7u21.4.12-7+deb7u31.4.12-7+deb7u41.4.12-7+deb7u5
1.4.12-7+deb7u6
libgcrypt11
Debian:7
before 1.5.0-5+deb7u2, plus listed versions
1.5.0-51.5.0-5+deb7u1
1.5.0-5+deb7u2
libgcrypt
Mageia:3
before 1.5.4-1.mga3
1.5.4-1.mga3
libgcrypt
Mageia:4
before 1.5.4-1.mga4
1.5.4-1.mga4
gnupg
Mageia:3
before 1.4.14-1.4.mga3
1.4.14-1.4.mga3
libgcrypt11
Ubuntu:14.04:LTS
before 1.5.3-2ubuntu4.1, plus listed versions
1.5.0-3ubuntu31.5.3-2ubuntu11.5.3-2ubuntu4
1.5.3-2ubuntu4.1
gnupg
Ubuntu:14.04:LTS
From an advisory covering 5 CVEs
before 1.4.16-1ubuntu2.3, plus listed versions
1.4.14-1ubuntu21.4.15-1.1ubuntu11.4.15-1.1ubuntu21.4.15-2ubuntu11.4.16-1ubuntu11.4.16-1ubuntu21.4.16-1ubuntu2.1
1.4.16-1ubuntu2.3
gnupg2
Ubuntu:14.04:LTS
From an advisory covering 5 CVEs
before 2.0.22-3ubuntu1.3, plus listed versions
2.0.20-1ubuntu32.0.22-1ubuntu12.0.22-3ubuntu12.0.22-3ubuntu1.1
2.0.22-3ubuntu1.3

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2014-5270 is a low vulnerability (CVSS 2.1) in Gnupg Libgcrypt, published August 18, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.53%, the 45th percentile. Fixed in libgcrypt20 1.6.0-2.

References

Show 17 moreShow less
MoveEnter Open