CVE-2014-6610
Asterisk Open Source 11.x before 11.12.1 and 12.x before 12.5.1 and Certified Asterisk 11.6...
Asterisk Open Source 11.x before 11.12.1 and 12.x before 12.5.1 and Certified Asterisk 11.6 before 11.6-cert6, when using the res_fax_spandsp module, allows remote authenticated users to cause a denial of service (crash) via an out of call message, which is not properly handled in the ReceiveFax dialplan application.
Exploit likelihood
What each source reports
NVD Score used
4.0
Asterisk Open Source 11.x before 11.12.1 and 12.x before 12.5.1 and Certified Asterisk 11.6 before 11.6-cert6, when using the res_fax_spandsp module, allows remote authenticated users to cause a denial of service (crash) via an out of call message, which is not properly handled in the ReceiveFax dialplan application.
- Record
CVE-2014-6610- CVSS 2.0
- 4.0 Medium
AV:N/AC:L/Au:S/C:N/I:N/A:P - Weakness
- CWE-19
- Updated
- 2026-11-02
CVE List No score
Asterisk Open Source 11.x before 11.12.1 and 12.x before 12.5.1 and Certified Asterisk 11.6 before 11.6-cert6, when using the res_fax_spandsp module, allows remote authenticated users to cause a denial of service (crash) via an out of call message, which is not properly handled in the ReceiveFax dialplan application.
- Record
CVE-2014-6610- Updated
- 2026-11-02
EUVDEUVD-2014-6489 No score
Asterisk Open Source 11.x before 11.12.1 and 12.x before 12.5.1 and Certified Asterisk 11.6 before 11.6-cert6, when using the res_fax_spandsp module, allows remote authenticated users to cause a denial of service (crash) via an out of call message, which is not properly handled in the ReceiveFax dialplan application.
- Record
EUVD-2014-6489- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-f9gh-gm49-v657 No score
Asterisk Open Source 11.x before 11.12.1 and 12.x before 12.5.1 and Certified Asterisk 11.6...
Asterisk Open Source 11.x before 11.12.1 and 12.x before 12.5.1 and Certified Asterisk 11.6 before 11.6-cert6, when using the res_fax_spandsp module, allows remote authenticated users to cause a denial of service (crash) via an out of call message, which is not properly handled in the ReceiveFax dialplan application.
- Record
GHSA-f9gh-gm49-v657- Updated
- 2026-11-02
OSV No score
Asterisk Open Source 11.x before 11.12.1 and 12.x before 12.5.1 and Certified Asterisk 11.6 before 11.6-cert6, when using the res_fax_spandsp module, allows remote authenticated users to cause a denial of service (crash) via an out of call message, which is not properly handled in the ReceiveFax dialplan application.
- Record
CVE-2014-6610- Updated
- 2026-11-02
OSVDEBIAN-CVE-2014-6610 No score
Asterisk Open Source 11.x before 11.12.1 and 12.x before 12.5.1 and Certified Asterisk 11.6 before 11.6-cert6, when using the res_fax_spandsp module, allows remote authenticated users to cause a denial of service (crash) via an out of call message, which is not properly handled in the ReceiveFax dialplan application.
- Record
DEBIAN-CVE-2014-6610- Updated
- 2026-11-02
OSVMGASA-2014-0490 No score
Updated asterisk packages fix CVE-2014-6610 and mitigate POODLE
Updated asterisk packages fix security vulnerabilities:
In Asterisk Open Source 11.x before 11.12.1, when an out of call message, delivered by either the SIP or PJSIP channel driver or the XMPP stack, is handled in Asterisk, a crash can occur if the channel servicing the message is sent into the ReceiveFax dialplan application while using the res_fax_spandsp module (CVE-2014-6610).
In Asterisk Open Source 11.x before 11.13.1, the res_jabber and res_xmpp module both use SSLv3 exclusively, and are hence susceptible to CVE-2014-3566, a.k.a. POODLE. Also, the core TLS handling, used by the chan_sip channel driver, Asterisk Manager Interface (AMI), and the Asterisk HTTP server, defaults to allowing SSLv3/SSLv2 fallback. This allows a MITM to potentially force a connection to fallback to SSLv3, exposing it to the POODLE vulnerability.
Asterisk has been updated to version 11.14.1, which fixes the CVE-2014-6610 issue, and in which it no longer uses SSLv3 for the res_jabber/res_xmpp modules. Additionally, when the encryption method is not specified, the default handling in the TLS core no longer allows for a fallback to SSLv3 or SSLv2. These changes mitigate the POODLE vulnerability.
Other security issues fixed in 11.14.1 include:
Mixed IP address families in access control lists may permit unwanted traffic (AST-2014-012)
High call load may result in hung channels in ConfBridge (AST-2014-014).
Permission escalation through ConfBridge actions/dialplan functions (AST-2014-017).
The DB dialplan function when executed from an external protocol (for instance AMI), could result in a privilege escalation (AST-2014-018).
- Record
MGASA-2014-0490- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
asteriskDebian:14 |
before 1:11.12.1~dfsg-1, plus listed versions 0.1.11-30.1.11-3woody11:1.0.5-21:1.0.5-41:1.0.6-1 Show 45 moreShow less1:1.0.6-21:1.0.7-11:1.0.7.dfsg.1-11:1.0.7.dfsg.1-21:1.0.7.dfsg.1-2sarge11:1.0.7.dfsg.1-2sarge21:1.0.7.dfsg.1-2sarge31:1.0.7.dfsg.1-2sarge41:1.0.7.dfsg.1-2sarge51:1.0.7.dfsg.1-2sarge61:1.0.9.dfsg-11:1.0.9.dfsg-31:1.0.9.dfsg-41:1.0.9.dfsg-51:1.0.9.dfsg-61:1.2.0-beta1.dfsg-11:1.2.0-beta2.dfsg-11:1.2.0-beta2.dfsg-21:1.2.0-beta2.dfsg-31:1.2.0-rc1.dfsg-11:1.2.0-rc2.dfsg-11:1.2.0.dfsg-11:1.2.0.dfsg-21:1.2.0.dfsg-31:1.2.0.dfsg-41:1.2.0.dfsg-51:1.2.0.dfsg-61:1.2.1.dfsg-11:1.2.1.dfsg-21:1.2.1.dfsg-31:1.2.10.dfsg-11:1.2.10.dfsg-1bpo11:1.2.10.dfsg-21:1.2.10.dfsg-31:1.2.11.dfsg-11:1.2.12.1.dfsg-11:1.2.13~dfsg-11:1.2.13~dfsg-21:1.2.13~dfsg-2etch11:1.2.13~dfsg-2etch21:1.2.13~dfsg-2etch31:1.2.13~dfsg-2etch41:1.2.14~dfsg-11:1.2.14~dfsg-21:1.2.14~dfsg-3 |
1:11.12.1~dfsg-1 |
asteriskDebian:7 From an advisory covering 6 CVEs |
before 1:1.8.13.1~dfsg1-3+deb7u4, plus listed versions 1:1.8.13.1~dfsg-31:1.8.13.1~dfsg-3+deb7u11:1.8.13.1~dfsg-3+deb7u21:1.8.13.1~dfsg1-3+deb7u3 |
1:1.8.13.1~dfsg1-3+deb7u4 |
asteriskMageia:3 |
before 11.14.1-1.mga3 | 11.14.1-1.mga3 |
asteriskMageia:4 |
before 11.14.1-1.mga4 | 11.14.1-1.mga4 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2014-6610 is a medium vulnerability (CVSS 4.0) in Digium Asterisk, published November 26, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.52%, the 74th percentile. Fixed in asterisk 1:11.12.1~dfsg-1.
References
downloads.asterisk.org/pub/security/AST-2014-010.html
nvd.nist.gov/vuln/detail/CVE-2014-6610
github.com/advisories/GHSA-f9gh-gm49-v657
security-tracker.debian.org/tracker/CVE-2014-6610
advisories.mageia.org/MGASA-2014-0490.html
bugs.mageia.org/show_bug.cgi?id=14466
Show 8 moreShow less
downloads.asterisk.org/pub/security/AST-2014-011.html
downloads.asterisk.org/pub/security/AST-2014-012.html
downloads.asterisk.org/pub/security/AST-2014-014.html
downloads.asterisk.org/pub/security/AST-2014-017.html
downloads.asterisk.org/pub/security/AST-2014-018.html
downloads.asterisk.org/pub/telephony/asterisk/releases/ChangeLog-11.14.1
downloads.asterisk.org/pub/telephony/asterisk/asterisk-11.14.1-summary.html
mandriva.com/en/support/security/advisories/mbs1/MDVSA-2014%3A218
Left out here: 132 versions. The JSON record has them.