Every CVE Search/ Get API key

CVE-2014-7808

Apache Wicket insecure defaults

7.5 HighFix available

Apache Wicket before 1.5.13, 6.x before 6.19.0, and 7.x before 7.0.0-M5 make it easier for attackers to defeat a cryptographic protection mechanism and predict encrypted URLs by leveraging use of CryptoMapper as the default encryption provider.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
None
Availability
None

Exploit likelihood

1.11%Up 0.2 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

Apache Wicket before 1.5.13, 6.x before 6.19.0, and 7.x before 7.0.0-M5 make it easier for attackers to defeat a cryptographic protection mechanism and predict encrypted URLs by leveraging use of CryptoMapper as the default encryption provider.

Record
CVE-2014-7808
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:P/I:N/A:N
Weakness
CWE-310
Updated
2026-11-02
CVE List No score

Apache Wicket before 1.5.13, 6.x before 6.19.0, and 7.x before 7.0.0-M5 make it easier for attackers to defeat a cryptographic protection mechanism and predict encrypted URLs by leveraging use of CryptoMapper as the default encryption provider.

Record
CVE-2014-7808
Updated
2026-11-02
EUVDEUVD-2014-7679 No score

Apache Wicket before 1.5.13, 6.x before 6.19.0, and 7.x before 7.0.0-M5 make it easier for attackers to defeat a cryptographic protection mechanism and predict encrypted URLs by leveraging use of CryptoMapper as the default encryption provider.

Record
EUVD-2014-7679
Updated
2026-11-03
GitHub AdvisoriesGHSA-vfmm-jm4v-7frq 7.5

Apache Wicket insecure defaults

Apache Wicket before 1.5.13, 6.x before 6.19.0, and 7.x before 7.0.0-M5 make it easier for attackers to defeat a cryptographic protection mechanism and predict encrypted URLs by leveraging use of CryptoMapper as the default encryption provider.

Record
GHSA-vfmm-jm4v-7frq
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weakness
CWE-326
Updated
2026-11-02
OSVGHSA-vfmm-jm4v-7frq 7.5

Apache Wicket insecure defaults

Apache Wicket before 1.5.13, 6.x before 6.19.0, and 7.x before 7.0.0-M5 make it easier for attackers to defeat a cryptographic protection mechanism and predict encrypted URLs by leveraging use of CryptoMapper as the default encryption provider.

Record
GHSA-vfmm-jm4v-7frq
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weakness
CWE-326
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
org.apache.wicket:wicket-core
Maven
before 1.5.13
1.5.13
org.apache.wicket:wicket-core
Maven
6.0.0-beta1 up to 6.19.0
6.19.0
org.apache.wicket:wicket-core
Maven
7.0.0-M1 up to 7.0.0-M5
7.0.0-M5
org.apache.wicket:wicket-core
Maven
before 1.5.13, plus listed versions
1.5-RC11.5-RC31.5-RC4.21.5-RC5.11.5-RC7
Show 14 moreShow less
1.5-rc21.5.01.5.11.5.101.5.111.5.121.5.21.5.31.5.41.5.51.5.61.5.71.5.81.5.9
1.5.13
org.apache.wicket:wicket-core
Maven
6.0.0-beta1 up to 6.19.0, plus listed versions
6.0.06.0.0-beta26.0.0-beta36.1.06.1.1
Show 18 moreShow less
6.10.06.11.06.12.06.13.06.14.06.15.06.16.06.17.06.18.06.2.06.3.06.4.06.5.06.6.06.7.06.8.06.9.06.9.1
6.19.0
org.apache.wicket:wicket-core
Maven
7.0.0-M1 up to 7.0.0-M5, plus listed versions
7.0.0-M27.0.0-M37.0.0-M4
7.0.0-M5

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2014-7808 is a high vulnerability (CVSS 7.5) in Apache Wicket, published September 15, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.11%, the 65th percentile. Fixed in org.apache.wicket:wicket-core 1.5.13.

References

MoveEnter Open