Every CVE Search/ Get API key

CVE-2014-9030

The do_mmu_update function in arch/x86/mm.c in Xen 3.2.x through 4.4.x does not properly manage...

7.1 HighFix available

The do_mmu_update function in arch/x86/mm.c in Xen 3.2.x through 4.4.x does not properly manage page references, which allows remote domains to cause a denial of service by leveraging control over an HVM guest and a crafted MMU_MACHPHYS_UPDATE.

Exploit likelihood

2.20%Up 1.0 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.1

The do_mmu_update function in arch/x86/mm.c in Xen 3.2.x through 4.4.x does not properly manage page references, which allows remote domains to cause a denial of service by leveraging control over an HVM guest and a crafted MMU_MACHPHYS_UPDATE.

Record
CVE-2014-9030
CVSS 2.0
7.1 HighAV:N/AC:M/Au:N/C:N/I:N/A:C
Weakness
CWE-20
Updated
2026-11-02
CVE List No score

The do_mmu_update function in arch/x86/mm.c in Xen 3.2.x through 4.4.x does not properly manage page references, which allows remote domains to cause a denial of service by leveraging control over an HVM guest and a crafted MMU_MACHPHYS_UPDATE.

Record
CVE-2014-9030
Updated
2026-11-02
EUVDEUVD-2014-8858 No score

The do_mmu_update function in arch/x86/mm.c in Xen 3.2.x through 4.4.x does not properly manage page references, which allows remote domains to cause a denial of service by leveraging control over an HVM guest and a crafted MMU_MACHPHYS_UPDATE.

Record
EUVD-2014-8858
Updated
2026-11-03
GitHub AdvisoriesGHSA-cqc3-c3mm-mqwr No score

The do_mmu_update function in arch/x86/mm.c in Xen 3.2.x through 4.4.x does not properly manage...

The do_mmu_update function in arch/x86/mm.c in Xen 3.2.x through 4.4.x does not properly manage page references, which allows remote domains to cause a denial of service by leveraging control over an HVM guest and a crafted MMU_MACHPHYS_UPDATE.

Record
GHSA-cqc3-c3mm-mqwr
Weakness
CWE-20
Updated
2026-11-02
OSV No score

The do_mmu_update function in arch/x86/mm.c in Xen 3.2.x through 4.4.x does not properly manage page references, which allows remote domains to cause a denial of service by leveraging control over an HVM guest and a crafted MMU_MACHPHYS_UPDATE.

Record
CVE-2014-9030
Updated
2026-11-02
OSVDEBIAN-CVE-2014-9030 No score

The do_mmu_update function in arch/x86/mm.c in Xen 3.2.x through 4.4.x does not properly manage page references, which allows remote domains to cause a denial of service by leveraging control over an HVM guest and a crafted MMU_MACHPHYS_UPDATE.

Record
DEBIAN-CVE-2014-9030
Updated
2026-11-02
OSVSUSE-SU-2015:0940-1 No score

Security update for Xen

This update fixes the following security issues in Xen:

* CVE-2012-5510: Grant table version switch list corruption
  vulnerability (XSA-26)
* CVE-2012-5511: Several HVM operations do not validate the range of
  their inputs (XSA-27)
* CVE-2012-5513: XENMEM_exchange may overwrite hypervisor memory
  (XSA-29)
* CVE-2012-5514: Missing unlock in
  guest_physmap_mark_populate_on_demand() (XSA-30)
* CVE-2012-5515: Several memory hypercall operations allow invalid
  extent order values (XSA-31)

Also the following fix has been applied:

* bnc#777628 - guest 'disappears' after live migration
  Updated block-dmmd script

Security Issues references:

* CVE-2012-5513
  <http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2012-5513>
* CVE-2012-5514
  <http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2012-5514>
* CVE-2012-5511
  <http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2012-5511>
* CVE-2012-5510
  <http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2012-5510>
* CVE-2012-5515
  <http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2012-5515>
Record
SUSE-SU-2015:0940-1
Updated
2026-11-02
OSVUBUNTU-CVE-2014-9030 No score

The do_mmu_update function in arch/x86/mm.c in Xen 3.2.x through 4.4.x does not properly manage page references, which allows remote domains to cause a denial of service by leveraging control over an HVM guest and a crafted MMU_MACHPHYS_UPDATE.

Record
UBUNTU-CVE-2014-9030
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
xen
Debian:12
before 4.4.1-4
4.4.1-4
xen
Debian:13
before 4.4.1-4
4.4.1-4
xen
Debian:14
before 4.4.1-4
4.4.1-4
xen
Debian:7
From an advisory covering 5 CVEs
before 4.1.4-3+deb7u4, plus listed versions
4.1.4-34.1.4-3+deb7u14.1.4-3+deb7u24.1.4-3+deb7u3
4.1.4-3+deb7u4
xen
Ubuntu:14.04:LTS
before 4.4.1-0ubuntu0.14.04.2, plus listed versions
4.3.0-1ubuntu14.3.0-1ubuntu24.3.0-1ubuntu34.3.0-1ubuntu44.3.0-1ubuntu5
Show 6 moreShow less
4.4.0-0ubuntu34.4.0-0ubuntu44.4.0-0ubuntu54.4.0-0ubuntu5.14.4.0-0ubuntu5.24.4.1-0ubuntu0.14.04.1
4.4.1-0ubuntu0.14.04.2

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2014-9030 is a high vulnerability (CVSS 7.1) in Xen, published November 22, 2012. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.20%, the 82nd percentile. Fixed in xen 4.4.1-4.

References

Show 44 moreShow less
MoveEnter Open