Every CVE Search/ Get API key

CVE-2014-9140

Buffer overflow in the ppp_hdlc function in print-ppp.c in tcpdump 4.6.2 and earlier allows...

5.0 MediumFix available

Buffer overflow in the ppp_hdlc function in print-ppp.c in tcpdump 4.6.2 and earlier allows remote attackers to cause a denial of service (crash) cia a crafted PPP packet.

Exploit likelihood

5.76%Up 2.0 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.0

Buffer overflow in the ppp_hdlc function in print-ppp.c in tcpdump 4.6.2 and earlier allows remote attackers to cause a denial of service (crash) cia a crafted PPP packet.

Record
CVE-2014-9140
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:N/A:P
Weakness
CWE-119
Updated
2026-11-02
CVE List No score

Buffer overflow in the ppp_hdlc function in print-ppp.c in tcpdump 4.6.2 and earlier allows remote attackers to cause a denial of service (crash) cia a crafted PPP packet.

Record
CVE-2014-9140
Updated
2026-11-02
EUVDEUVD-2014-8965 No score

Buffer overflow in the ppp_hdlc function in print-ppp.c in tcpdump 4.6.2 and earlier allows remote attackers to cause a denial of service (crash) cia a crafted PPP packet.

Record
EUVD-2014-8965
Updated
2026-11-03
GitHub AdvisoriesGHSA-v564-r5jq-5c36 No score

Buffer overflow in the ppp_hdlc function in print-ppp.c in tcpdump 4.6.2 and earlier allows...

Buffer overflow in the ppp_hdlc function in print-ppp.c in tcpdump 4.6.2 and earlier allows remote attackers to cause a denial of service (crash) cia a crafted PPP packet.

Record
GHSA-v564-r5jq-5c36
Weakness
CWE-119
Updated
2026-11-02
OSV No score

Buffer overflow in the ppp_hdlc function in print-ppp.c in tcpdump 4.6.2 and earlier allows remote attackers to cause a denial of service (crash) cia a crafted PPP packet.

Record
CVE-2014-9140
Updated
2026-11-02
OSVDEBIAN-CVE-2014-9140 No score

Buffer overflow in the ppp_hdlc function in print-ppp.c in tcpdump 4.6.2 and earlier allows remote attackers to cause a denial of service (crash) cia a crafted PPP packet.

Record
DEBIAN-CVE-2014-9140
Updated
2026-11-02
Show 6 moreShow less
OSVMGASA-2014-0511 No score

Updated tcpdump package fixes security vulnerability

It was discovered that tcpdump incorrectly handled printing PPP packets. A remote attacker could use this issue to cause tcpdump to crash, resulting in a denial of service, or possibly execute arbitrary code (CVE-2014-9140).

Record
MGASA-2014-0511
Updated
2026-11-02
OSVSUSE-RU-2015:0335-1 No score

Security update for tcpdump

When running tcpdump, a remote unauthenticated user could have crashed the application or, potentially, execute arbitrary code by injecting crafted packages into the network.

The following vulnerabilities in protocol printers have been fixed:

* IPv6 mobility printer remote DoS (CVE-2015-0261, bnc#922220)
* Ethernet printer remote DoS (CVE-2015-2154, bnc#922222)
* PPP printer remote DoS (CVE-2014-9140, bnc#923142)

Security Issues:

* CVE-2015-0261
  <http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-0261>
* CVE-2015-2154
  <http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-2154>
* CVE-2014-9140
  <http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-9140>
Record
SUSE-RU-2015:0335-1
Updated
2026-11-02
OSVSUSE-SU-2015:0679-1 No score

Security update for tcpdump

tcpdump was updated to fix five vulnerabilities in protocol printers

When running tcpdump, a remote unauthenticated user could have crashed the application or, potentially, execute arbitrary code by injecting crafted packages into the network.

The following vulnerabilities were fixed:

  • IPv6 mobility printer remote DoS (CVE-2015-0261, bnc#922220)
  • PPP printer remote DoS (CVE-2014-9140, bnc#923142)
  • force printer remote DoS (CVE-2015-2155, bnc#922223)
  • ethernet printer remote DoS (CVE-2015-2154, bnc#922222)
  • tcp printer remote DoS (CVE-2015-2153, bnc#922221)
Record
SUSE-SU-2015:0679-1
Updated
2026-11-02
OSVSUSE-SU-2015:0692-1 No score

Security update for tcpdump

When running tcpdump, a remote unauthenticated user could have crashed the application or, potentially, execute arbitrary code by injecting crafted packages into the network.

The following vulnerabilities in protocol printers have been fixed:

* IPv6 mobility printer remote DoS (CVE-2015-0261, bnc#922220)
* Ethernet printer remote DoS (CVE-2015-2154, bnc#922222)
* PPP printer remote DoS (CVE-2014-9140, bnc#923142)

Security Issues:

* CVE-2015-0261
  <http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-0261>
* CVE-2015-2154
  <http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-2154>
* CVE-2014-9140
  <http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-9140>
Record
SUSE-SU-2015:0692-1
Updated
2026-11-02
OSVUBUNTU-CVE-2014-9140 No score

Buffer overflow in the ppp_hdlc function in print-ppp.c in tcpdump 4.6.2 and earlier allows remote attackers to cause a denial of service (crash) cia a crafted PPP packet.

Record
UBUNTU-CVE-2014-9140
Updated
2026-11-02
OSVUSN-2433-1 No score

tcpdump vulnerabilities

Steffen Bauch discovered that tcpdump incorrectly handled printing OSLR packets. A remote attacker could use this issue to cause tcpdump to crash, resulting in a denial of service, or possibly execute arbitrary code. (CVE-2014-8767)

Steffen Bauch discovered that tcpdump incorrectly handled printing GeoNet packets. A remote attacker could use this issue to cause tcpdump to crash, resulting in a denial of service, or possibly execute arbitrary code. This issue only applied to Ubuntu 14.04 LTS and Ubuntu 14.10. (CVE-2014-8768)

Steffen Bauch discovered that tcpdump incorrectly handled printing AODV packets. A remote attacker could use this issue to cause tcpdump to crash, resulting in a denial of service, reveal sensitive information, or possibly execute arbitrary code. (CVE-2014-8769)

It was discovered that tcpdump incorrectly handled printing PPP packets. A remote attacker could use this issue to cause tcpdump to crash, resulting in a denial of service, or possibly execute arbitrary code. (CVE-2014-9140)

In the default installation, attackers would be isolated by the tcpdump AppArmor profile.

Record
USN-2433-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
tcpdump
Debian:12
before 4.6.2-3
4.6.2-3
tcpdump
Debian:13
before 4.6.2-3
4.6.2-3
tcpdump
Debian:14
before 4.6.2-3
4.6.2-3
tcpdump
Debian:6.0
From an advisory covering 3 CVEs
before 4.1.1-1+deb6u1, plus listed versions
4.1.1-1
4.1.1-1+deb6u1
tcpdump
Debian:7
From an advisory covering 3 CVEs
before 4.3.0-1+deb7u1, plus listed versions
4.3.0-1
4.3.0-1+deb7u1
tcpdump
Mageia:4
before 4.4.0-2.2.mga4
4.4.0-2.2.mga4
tcpdump
SUSE:Linux Enterprise Desktop 12
From an advisory covering 5 CVEs
before 4.5.1-7.1
4.5.1-7.1
tcpdump
SUSE:Linux Enterprise Server 12
From an advisory covering 5 CVEs
before 4.5.1-7.1
4.5.1-7.1
tcpdump
SUSE:Linux Enterprise Server for SAP Applications 12
From an advisory covering 5 CVEs
before 4.5.1-7.1
4.5.1-7.1
tcpdump
Ubuntu:14.04:LTS
before 4.5.1-2ubuntu1.1, plus listed versions
4.4.0-1ubuntu14.5.1-2ubuntu1
4.5.1-2ubuntu1.1
tcpdump
Ubuntu:14.04:LTS
From an advisory covering 4 CVEs
before 4.5.1-2ubuntu1.1, plus listed versions
4.4.0-1ubuntu14.5.1-2ubuntu1
4.5.1-2ubuntu1.1

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2014-9140 is a medium vulnerability (CVSS 5.0) in Redhat Tcpdump, published December 3, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 5.76%, the 93rd percentile. Fixed in tcpdump 4.6.2-3.

References

Show 37 moreShow less
MoveEnter Open