CVE-2014-9639
Integer overflow in oggenc in vorbis-tools 1.4.0 allows remote attackers to cause a denial of...
Integer overflow in oggenc in vorbis-tools 1.4.0 allows remote attackers to cause a denial of service (crash) via a crafted number of channels in a WAV file, which triggers an out-of-bounds memory access.
Exploit likelihood
What each source reports
NVD Score used
5.0
Integer overflow in oggenc in vorbis-tools 1.4.0 allows remote attackers to cause a denial of service (crash) via a crafted number of channels in a WAV file, which triggers an out-of-bounds memory access.
- Record
CVE-2014-9639- CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:N/I:N/A:P - Updated
- 2026-11-02
CVE List No score
Integer overflow in oggenc in vorbis-tools 1.4.0 allows remote attackers to cause a denial of service (crash) via a crafted number of channels in a WAV file, which triggers an out-of-bounds memory access.
- Record
CVE-2014-9639- Updated
- 2026-11-02
EUVDEUVD-2014-9449 No score
Integer overflow in oggenc in vorbis-tools 1.4.0 allows remote attackers to cause a denial of service (crash) via a crafted number of channels in a WAV file, which triggers an out-of-bounds memory access.
- Record
EUVD-2014-9449- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-v58c-j43c-7cpx No score
Integer overflow in oggenc in vorbis-tools 1.4.0 allows remote attackers to cause a denial of...
Integer overflow in oggenc in vorbis-tools 1.4.0 allows remote attackers to cause a denial of service (crash) via a crafted number of channels in a WAV file, which triggers an out-of-bounds memory access.
- Record
GHSA-v58c-j43c-7cpx- Updated
- 2026-11-02
OSVAZL-6953 No score
CVE-2014-9639 affecting package vorbis-tools for versions less than 1.4.0-35
Integer overflow in oggenc in vorbis-tools 1.4.0 allows remote attackers to cause a denial of service (crash) via a crafted number of channels in a WAV file, which triggers an out-of-bounds memory access.
- Record
AZL-6953- Updated
- 2026-11-02
OSVAZL-7401 No score
CVE-2014-9639 affecting package vorbis-tools for versions less than 1.4.0-35
Integer overflow in oggenc in vorbis-tools 1.4.0 allows remote attackers to cause a denial of service (crash) via a crafted number of channels in a WAV file, which triggers an out-of-bounds memory access.
- Record
AZL-7401- Updated
- 2026-11-02
Show 7 moreShow less
OSV No score
Integer overflow in oggenc in vorbis-tools 1.4.0 allows remote attackers to cause a denial of service (crash) via a crafted number of channels in a WAV file, which triggers an out-of-bounds memory access.
- Record
CVE-2014-9639- Updated
- 2026-11-02
OSVDEBIAN-CVE-2014-9639 No score
Integer overflow in oggenc in vorbis-tools 1.4.0 allows remote attackers to cause a denial of service (crash) via a crafted number of channels in a WAV file, which triggers an out-of-bounds memory access.
- Record
DEBIAN-CVE-2014-9639- Updated
- 2026-11-02
OSVMGASA-2015-0094 No score
Updated vorbis-tools packages fix security vulnerabilities
Updated vorbis-tools package fixes security vulnerabilities:
oggenc in vorbis-tools 1.4.0 allows remote attackers to cause a denial of service (divide-by-zero error and crash) via a WAV file with the number of channels set to zero (CVE-2014-9638).
Integer overflow in oggenc in vorbis-tools 1.4.0 allows remote attackers to cause a denial of service (crash) via a crafted number of channels in a WAV file, which triggers an out-of-bounds memory access (CVE-2014-9639).
- Record
MGASA-2015-0094- Updated
- 2026-11-02
OSVopenSUSE-SU-2024:10259-1 No score
vorbis-tools-1.4.0-22.6 on GA media
These are all security issues fixed in the vorbis-tools-1.4.0-22.6 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:10259-1- Updated
- 2026-11-02
OSVSUSE-SU-2015:1014-1 No score
Security update for vorbis-tools
Vorbis tools was updated to fix division by zero and integer overflows by crafted WAV files (CVE-2014-9638, CVE-2014-9639, bnc#914439, bnc#914441), that would allow attackers to crash the vorbis tools processes.
- Record
SUSE-SU-2015:1014-1- Updated
- 2026-11-02
OSVSUSE-SU-2015:1775-1 No score
Security update for vorbis-tools
vorbis-tools was updated to fix several security issues.
-
A buffer overflow in aiff_open() that could be triggered by opening prepared malicious files (CVE-2015-6749, bsc#943795).
-
A division by zero and integer overflow by crafted WAV files was fixed (CVE-2014-9638, CVE-2014-9639, bnc#914439, bnc#914441).
- Record
SUSE-SU-2015:1775-1- Updated
- 2026-11-02
OSVUBUNTU-CVE-2014-9639 No score
Integer overflow in oggenc in vorbis-tools 1.4.0 allows remote attackers to cause a denial of service (crash) via a crafted number of channels in a WAV file, which triggers an out-of-bounds memory access.
- Record
UBUNTU-CVE-2014-9639- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
vorbis-toolsAzure Linux:2 |
before 1.4.0-35 | 1.4.0-35 |
opus-toolsDebian:12 |
before 0.1.10-1 | 0.1.10-1 |
opus-toolsDebian:13 |
before 0.1.10-1 | 0.1.10-1 |
opus-toolsDebian:14 |
before 0.1.10-1 | 0.1.10-1 |
vorbis-toolsDebian:12 |
before 1.4.0-7 | 1.4.0-7 |
vorbis-toolsDebian:13 |
before 1.4.0-7 | 1.4.0-7 |
vorbis-toolsDebian:14 |
before 1.4.0-7 | 1.4.0-7 |
vorbis-toolsDebian:7 |
before 1.4.0-1+deb7u1, plus listed versions 1.4.0-1 |
1.4.0-1+deb7u1 |
vorbis-toolsDebian:6.0 |
before 1.4.0-1+deb6u1, plus listed versions 1.4.0-1 |
1.4.0-1+deb6u1 |
vorbis-toolsMageia:4 |
before 1.4.0-6.2.mga4 | 1.4.0-6.2.mga4 |
Show 6 moreShow less
| Package | Affected | Fixed |
|---|---|---|
vorbis-toolsSUSE:Linux Enterprise Desktop 12 |
before 1.4.0-23.1 | 1.4.0-23.1 |
vorbis-toolsSUSE:Linux Enterprise Server 12 |
before 1.4.0-23.1 | 1.4.0-23.1 |
vorbis-toolsSUSE:Linux Enterprise Server for SAP Applications 12 |
before 1.4.0-23.1 | 1.4.0-23.1 |
vorbis-toolsSUSE:Linux Enterprise Desktop 11 SP3 |
before 1.1.1-174.1 | 1.1.1-174.1 |
vorbis-toolsSUSE:Linux Enterprise Desktop 11 SP4 |
before 1.1.1-174.1 | 1.1.1-174.1 |
vorbis-toolsopenSUSE:Tumbleweed |
before 1.4.0-22.6 | 1.4.0-22.6 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2014-9639 is a medium vulnerability (CVSS 5.0) in Xiph Vorbis-tools, published January 23, 2015. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.57%, the 89th percentile. Fixed in vorbis-tools 1.4.0-35.
References
securityfocus.com/bid/72295
openwall.com/lists/oss-security/2015/01/21/5
lists.fedoraproject.org/pipermail/package-announce/2015-February/150543.html
openwall.com/lists/oss-security/2015/01/22/9
lists.opensuse.org/opensuse-updates/2015-03/msg00054.html
seclists.org/fulldisclosure/2015/Jan/78
Show 18 moreShow less
trac.xiph.org/ticket/2136
lists.fedoraproject.org/pipermail/package-announce/2015-February/150570.html
nvd.nist.gov/vuln/detail/CVE-2014-9639
github.com/advisories/GHSA-v58c-j43c-7cpx
security-tracker.debian.org/tracker/CVE-2014-9639
advisories.mageia.org/MGASA-2015-0094.html
bugs.mageia.org/show_bug.cgi?id=15403
suse.com/support/update/announcement/2015/suse-su-20151014-1
bugzilla.suse.com/914439
bugzilla.suse.com/914441
suse.com/security/cve/CVE-2014-9638
suse.com/security/cve/CVE-2014-9639
suse.com/support/update/announcement/2015/suse-su-20151775-1
bugzilla.suse.com/943795
suse.com/security/cve/CVE-2015-6749
ubuntu.com/security/CVE-2014-9639
cve.org/CVERecord?id=CVE-2014-9639
suse.com/security/cve/CVE-2014-9640