Every CVE Search/ Get API key

CVE-2014-9640

oggenc/oggenc.c in vorbis-tools 1.4.0 allows remote attackers to cause a denial of service (out...

5.0 MediumFix available

oggenc/oggenc.c in vorbis-tools 1.4.0 allows remote attackers to cause a denial of service (out-of-bounds read) via a crafted raw file.

Exploit likelihood

3.24%Up 1.8 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.0

oggenc/oggenc.c in vorbis-tools 1.4.0 allows remote attackers to cause a denial of service (out-of-bounds read) via a crafted raw file.

Record
CVE-2014-9640
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:N/A:P
Weakness
CWE-119
Updated
2026-11-02
CVE List No score

oggenc/oggenc.c in vorbis-tools 1.4.0 allows remote attackers to cause a denial of service (out-of-bounds read) via a crafted raw file.

Record
CVE-2014-9640
Updated
2026-11-02
EUVDEUVD-2014-9450 No score

oggenc/oggenc.c in vorbis-tools 1.4.0 allows remote attackers to cause a denial of service (out-of-bounds read) via a crafted raw file.

Record
EUVD-2014-9450
Updated
2026-11-03
GitHub AdvisoriesGHSA-24hp-h6f6-wg59 No score

oggenc/oggenc.c in vorbis-tools 1.4.0 allows remote attackers to cause a denial of service (out...

oggenc/oggenc.c in vorbis-tools 1.4.0 allows remote attackers to cause a denial of service (out-of-bounds read) via a crafted raw file.

Record
GHSA-24hp-h6f6-wg59
Weakness
CWE-119
Updated
2026-11-02
OSV No score

oggenc/oggenc.c in vorbis-tools 1.4.0 allows remote attackers to cause a denial of service (out-of-bounds read) via a crafted raw file.

Record
CVE-2014-9640
Updated
2026-11-02
OSVDEBIAN-CVE-2014-9640 No score

oggenc/oggenc.c in vorbis-tools 1.4.0 allows remote attackers to cause a denial of service (out-of-bounds read) via a crafted raw file.

Record
DEBIAN-CVE-2014-9640
Updated
2026-11-02
Show 5 moreShow less
OSVMGASA-2015-0051 No score

Updated vorbis-tools package fixes security vulnerability

oggenc/oggenc.c in vorbis-tools 1.4.0 allows remote attackers to cause a denial of service (out-of-bounds read) via a crafted raw file (CVE-2014-9640).

Record
MGASA-2015-0051
Updated
2026-11-02
OSVOESA-2021-1028 No score

vorbis-tools security update

Ogg Vorbis is a fully open, non-proprietary, patent-and-royalty-free, general-purpose compressed audio format for mid to high quality (8kHz-48.0kHz, 16+ bit, polyphonic) audio and music at fixed and variable bitrates from 16 to 128 kbps/channel. This places Vorbis in the same competitive class as audio representations such as MPEG-4 (AAC), and similar to, but higher performance than MPEG-1/2 audio layer 3, MPEG-4 audio (TwinVQ), WMA and PAC.\r\n\r\n Security Fix(es):\r\n\r\n oggenc/oggenc.c in vorbis-tools 1.4.0 allows remote attackers to cause a denial of service (out-of-bounds read) via a crafted raw file.(CVE-2014-9640)\r\n\r\n

Record
OESA-2021-1028
Updated
2026-11-02
OSVopenSUSE-SU-2024:10259-1 No score

vorbis-tools-1.4.0-22.6 on GA media

These are all security issues fixed in the vorbis-tools-1.4.0-22.6 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10259-1
Updated
2026-11-02
OSVSUSE-SU-2015:0367-1 No score

Security update for vorbis-tools

  This update fixes the following security issue:

  - A crafted raw file used as input could cause a segmentation fault (CVE-2014-9640, bsc#914938)
Record
SUSE-SU-2015:0367-1
Updated
2026-11-02
OSVUBUNTU-CVE-2014-9640 No score

oggenc/oggenc.c in vorbis-tools 1.4.0 allows remote attackers to cause a denial of service (out-of-bounds read) via a crafted raw file.

Record
UBUNTU-CVE-2014-9640
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
vorbis-tools
Debian:12
before 1.4.0-6
1.4.0-6
vorbis-tools
Debian:13
before 1.4.0-6
1.4.0-6
vorbis-tools
Debian:14
before 1.4.0-6
1.4.0-6
vorbis-tools
Debian:7
before 1.4.0-1+deb7u1, plus listed versions
1.4.0-1
1.4.0-1+deb7u1
vorbis-tools
Debian:6.0
before 1.4.0-1+deb6u1, plus listed versions
1.4.0-1
1.4.0-1+deb6u1
vorbis-tools
Mageia:4
before 1.4.0-6.1.mga4
1.4.0-6.1.mga4
vorbis-tools
openEuler:20.03-LTS
before 1.4.0-31.oe1
1.4.0-31.oe1
vorbis-tools
openEuler:20.03-LTS-SP1
before 1.4.0-31.oe1
1.4.0-31.oe1
vorbis-tools
SUSE:Linux Enterprise Desktop 12
before 1.4.0-19.1
1.4.0-19.1
vorbis-tools
SUSE:Linux Enterprise Server 12
before 1.4.0-19.1
1.4.0-19.1
vorbis-tools
SUSE:Linux Enterprise Server for SAP Applications 12
before 1.4.0-19.1
1.4.0-19.1
vorbis-tools
openSUSE:Tumbleweed
before 1.4.0-22.6
1.4.0-22.6

History

History
RecordedChangedSources
affected
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2014-9640 is a medium vulnerability (CVSS 5.0) in Xiph Vorbis-tools, published January 23, 2015. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.24%, the 88th percentile. Fixed in vorbis-tools 1.4.0-6.

References

Show 15 moreShow less
MoveEnter Open