CVE-2015-1613
RhodeCode before 2.2.7 allows remote authenticated users to obtain API keys and other sensitive...
RhodeCode before 2.2.7 allows remote authenticated users to obtain API keys and other sensitive information via the (1) update_repo, (2) get_locks, or (3) get_user_groups API method.
Exploit likelihood
What each source reports
NVD Score used
4.0
RhodeCode before 2.2.7 allows remote authenticated users to obtain API keys and other sensitive information via the (1) update_repo, (2) get_locks, or (3) get_user_groups API method.
- Record
CVE-2015-1613- CVSS 2.0
- 4.0 Medium
AV:N/AC:L/Au:S/C:P/I:N/A:N - Weakness
- CWE-200
- Updated
- 2026-11-02
CVE List No score
RhodeCode before 2.2.7 allows remote authenticated users to obtain API keys and other sensitive information via the (1) update_repo, (2) get_locks, or (3) get_user_groups API method.
- Record
CVE-2015-1613- Updated
- 2026-11-02
EUVDEUVD-2015-0033 No score
RhodeCode before 2.2.7 allows remote authenticated users to obtain API keys and other sensitive information via the (1) update_repo, (2) get_locks, or (3) get_user_groups API method.
- Record
EUVD-2015-0033- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-qc99-q2vr-37hj No score
RhodeCode before 2.2.7 allows remote authenticated users to obtain API keys and other sensitive...
RhodeCode before 2.2.7 allows remote authenticated users to obtain API keys and other sensitive information via the (1) update_repo, (2) get_locks, or (3) get_user_groups API method.
- Record
GHSA-qc99-q2vr-37hj- Weakness
- CWE-200
- Updated
- 2026-11-02
OSVPYSEC-2015-33 No score
RhodeCode before 2.2.7 allows remote authenticated users to obtain API keys and other sensitive information via the (1) update_repo, (2) get_locks, or (3) get_user_groups API method.
- Record
PYSEC-2015-33- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
rhodecodePyPI |
before 2.2.7, plus listed versions 1.1.01.1.11.1.21.1.31.1.4 Show 34 moreShow less1.1.51.1.61.1.71.1.81.2.01.2.11.2.21.2.31.2.41.2.51.3.01.3.11.3.21.3.31.3.41.3.51.3.61.4.01.4.11.4.21.4.31.4.41.5.01.5.11.5.21.5.31.5.41.6.01.6.0rc11.7.01.7.11.7.22.2.52.2.6 |
2.2.7 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2015-1613 is a medium vulnerability (CVSS 4.0) in Rhodecode Enterprise, published February 16, 2015. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.33%, the 71st percentile. Fixed in rhodecode 2.2.7.