Every CVE Search/ Get API key

CVE-2015-0928

libhtp 0.5.15 allows remote attackers to cause a denial of service (NULL pointer dereference).

7.5 HighFix available

libhtp 0.5.15 allows remote attackers to cause a denial of service (NULL pointer dereference).

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

2.41%Up 1.4 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

libhtp 0.5.15 allows remote attackers to cause a denial of service (NULL pointer dereference).

Record
CVE-2015-0928
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:N/A:P
Weakness
CWE-476
Updated
2026-11-02
CVE List No score

libhtp 0.5.15 allows remote attackers to cause a denial of service (NULL pointer dereference).

Record
CVE-2015-0928
Updated
2026-11-02
EUVDEUVD-2015-0936 No score

libhtp 0.5.15 allows remote attackers to cause a denial of service (NULL pointer dereference).

Record
EUVD-2015-0936
Updated
2026-11-03
GitHub AdvisoriesGHSA-gv3j-jwr9-rf6p 7.5

libhtp 0.5.15 allows remote attackers to cause a denial of service (NULL pointer dereference).

libhtp 0.5.15 allows remote attackers to cause a denial of service (NULL pointer dereference).

Record
GHSA-gv3j-jwr9-rf6p
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-476
Updated
2026-11-02
OSV 7.5

libhtp 0.5.15 allows remote attackers to cause a denial of service (NULL pointer dereference).

Record
CVE-2015-0928
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2015-0928 7.5

libhtp 0.5.15 allows remote attackers to cause a denial of service (NULL pointer dereference).

Record
DEBIAN-CVE-2015-0928
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2015-0928 7.5

libhtp 0.5.15 allows remote attackers to cause a denial of service (NULL pointer dereference).

Record
UBUNTU-CVE-2015-0928
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
suricata
Debian:13
before 2.0.7-1
2.0.7-1
suricata
Debian:14
before 2.0.7-1
2.0.7-1
suricata
Ubuntu:14.04:LTS
before 1.4.7-1ubuntu1.1, plus listed versions
1.4.3-11.4.6-11.4.7-11.4.7-1ubuntu1
1.4.7-1ubuntu1.1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2015-0928 is a high vulnerability (CVSS 7.5) in Oisf Libhtp, published August 28, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.41%, the 84th percentile. Fixed in suricata 2.0.7-1.

References

MoveEnter Open