CVE-2015-1029
The puppetlabs-stdlib module 2.1 through 3.0 and 4.1.0 through 4.5.x before 4.5.1 for Puppet 2.8...
The puppetlabs-stdlib module 2.1 through 3.0 and 4.1.0 through 4.5.x before 4.5.1 for Puppet 2.8.8 and earlier allows remote authenticated users to gain privileges or obtain sensitive information by prepopulating the fact cache.
Exploit likelihood
What each source reports
NVD Score used
6.5
The puppetlabs-stdlib module 2.1 through 3.0 and 4.1.0 through 4.5.x before 4.5.1 for Puppet 2.8.8 and earlier allows remote authenticated users to gain privileges or obtain sensitive information by prepopulating the fact cache.
- Record
CVE-2015-1029- CVSS 2.0
- 6.5 Medium
AV:N/AC:L/Au:S/C:P/I:P/A:P - Weakness
- CWE-264
- Updated
- 2026-11-02
CVE List No score
The puppetlabs-stdlib module 2.1 through 3.0 and 4.1.0 through 4.5.x before 4.5.1 for Puppet 2.8.8 and earlier allows remote authenticated users to gain privileges or obtain sensitive information by prepopulating the fact cache.
- Record
CVE-2015-1029- Updated
- 2026-11-02
EUVDEUVD-2015-1173 No score
The puppetlabs-stdlib module 2.1 through 3.0 and 4.1.0 through 4.5.x before 4.5.1 for Puppet 2.8.8 and earlier allows remote authenticated users to gain privileges or obtain sensitive information by prepopulating the fact cache.
- Record
EUVD-2015-1173- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-g3q8-3w6w-q3m9 No score
The puppetlabs-stdlib module 2.1 through 3.0 and 4.1.0 through 4.5.x before 4.5.1 for Puppet 2.8...
The puppetlabs-stdlib module 2.1 through 3.0 and 4.1.0 through 4.5.x before 4.5.1 for Puppet 2.8.8 and earlier allows remote authenticated users to gain privileges or obtain sensitive information by prepopulating the fact cache.
- Record
GHSA-g3q8-3w6w-q3m9- Updated
- 2026-11-02
OSVAZL-44415 No score
CVE-2015-1029 affecting package puppet for versions less than 7.34.0-1
The puppetlabs-stdlib module 2.1 through 3.0 and 4.1.0 through 4.5.x before 4.5.1 for Puppet 2.8.8 and earlier allows remote authenticated users to gain privileges or obtain sensitive information by prepopulating the fact cache.
- Record
AZL-44415- Updated
- 2026-11-02
OSV No score
The puppetlabs-stdlib module 2.1 through 3.0 and 4.1.0 through 4.5.x before 4.5.1 for Puppet 2.8.8 and earlier allows remote authenticated users to gain privileges or obtain sensitive information by prepopulating the fact cache.
- Record
CVE-2015-1029- Updated
- 2026-11-02
OSVDEBIAN-CVE-2015-1029 No score
The puppetlabs-stdlib module 2.1 through 3.0 and 4.1.0 through 4.5.x before 4.5.1 for Puppet 2.8.8 and earlier allows remote authenticated users to gain privileges or obtain sensitive information by prepopulating the fact cache.
- Record
DEBIAN-CVE-2015-1029- Updated
- 2026-11-02
OSVUBUNTU-CVE-2015-1029 No score
The puppetlabs-stdlib module 2.1 through 3.0 and 4.1.0 through 4.5.x before 4.5.1 for Puppet 2.8.8 and earlier allows remote authenticated users to gain privileges or obtain sensitive information by prepopulating the fact cache.
- Record
UBUNTU-CVE-2015-1029- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
puppetAzure Linux:3 |
before 7.34.0-1 | 7.34.0-1 |
puppet-module-puppetlabs-stdlibDebian:12 |
before 4.9.0-1 | 4.9.0-1 |
puppet-module-puppetlabs-stdlibDebian:13 |
before 4.9.0-1 | 4.9.0-1 |
puppet-module-puppetlabs-stdlibDebian:14 |
before 4.9.0-1 | 4.9.0-1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2015-1029 is a medium vulnerability (CVSS 6.5) in Puppet Stdlib, published January 16, 2015. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.65%, the 76th percentile. Fixed in puppet 7.34.0-1.