Every CVE Search/ Get API key

CVE-2015-1379

The signal handler implementations in socat before 1.7.3.0 and 2.0.0-b8 allow remote attackers to...

7.5 HighFix available

The signal handler implementations in socat before 1.7.3.0 and 2.0.0-b8 allow remote attackers to cause a denial of service (process freeze or crash).

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

3.93%Up 2.7 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

The signal handler implementations in socat before 1.7.3.0 and 2.0.0-b8 allow remote attackers to cause a denial of service (process freeze or crash).

Record
CVE-2015-1379
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:N/A:P
Weakness
CWE-20
Updated
2026-11-02
CVE List No score

The signal handler implementations in socat before 1.7.3.0 and 2.0.0-b8 allow remote attackers to cause a denial of service (process freeze or crash).

Record
CVE-2015-1379
Updated
2026-11-02
EUVDEUVD-2015-1516 No score

The signal handler implementations in socat before 1.7.3.0 and 2.0.0-b8 allow remote attackers to cause a denial of service (process freeze or crash).

Record
EUVD-2015-1516
Updated
2026-11-03
GitHub AdvisoriesGHSA-mhm8-j49g-j7wp 7.5

The signal handler implementations in socat before 1.7.3.0 and 2.0.0-b8 allow remote attackers to...

The signal handler implementations in socat before 1.7.3.0 and 2.0.0-b8 allow remote attackers to cause a denial of service (process freeze or crash).

Record
GHSA-mhm8-j49g-j7wp
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-20
Updated
2026-11-02
OSV 7.5

The signal handler implementations in socat before 1.7.3.0 and 2.0.0-b8 allow remote attackers to cause a denial of service (process freeze or crash).

Record
CVE-2015-1379
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2015-1379 7.5

The signal handler implementations in socat before 1.7.3.0 and 2.0.0-b8 allow remote attackers to cause a denial of service (process freeze or crash).

Record
DEBIAN-CVE-2015-1379
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2015-1379 7.5

The signal handler implementations in socat before 1.7.3.0 and 2.0.0-b8 allow remote attackers to cause a denial of service (process freeze or crash).

Record
UBUNTU-CVE-2015-1379
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVMGASA-2015-0144 No score

Updated socat packages fix CVE-2015-1379

Updated socat package fixes security vulnerability:

In socat before 2.0.0-b8, signal handler implementations are not async-signal-safe and can cause crash or freeze of socat processes. Mostly this issue occurs when socat is in listening mode with fork option and a couple of child processes terminate at the same time (CVE-2015-1379).

Record
MGASA-2015-0144
Updated
2026-11-02
OSVSUSE-SU-2025:0726-1 No score

Security update for socat

This update for socat fixes the following issues:

  • CVE-2015-1379: lack of async-signal-safe signal handlers can lead to crashes or freezing of socat processes (bsc#922903).
Record
SUSE-SU-2025:0726-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
socat
Debian:12
before 1.7.2.4-2
1.7.2.4-2
socat
Debian:13
before 1.7.2.4-2
1.7.2.4-2
socat
Debian:14
before 1.7.2.4-2
1.7.2.4-2
socat
Mageia:4
before 2.0.0-0.b8.1.mga4
2.0.0-0.b8.1.mga4
socat
SUSE:Linux Enterprise Server LTSS Extended Security 12 SP5
before 1.7.2.4-4.6.1
1.7.2.4-4.6.1
socat
Ubuntu:Pro:14.04:LTS
before 1.7.2.3-1ubuntu0.1~esm1, plus listed versions
1.7.1.3-1.5ubuntu11.7.2.2-11.7.2.3-1
1.7.2.3-1ubuntu0.1~esm1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2015-1379 is a high vulnerability (CVSS 7.5) in Dest-unreach Socat, published April 15, 2015. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.93%, the 90th percentile. Fixed in socat 1.7.2.4-2.

References

Show 9 moreShow less
MoveEnter Open