CVE-2015-1464
RT (aka Request Tracker) before 4.0.23 and 4.2.x before 4.2.10 allows remote attackers to hijack...
RT (aka Request Tracker) before 4.0.23 and 4.2.x before 4.2.10 allows remote attackers to hijack sessions via an RSS feed URL.
Exploit likelihood
What each source reports
NVD Score used
6.4
RT (aka Request Tracker) before 4.0.23 and 4.2.x before 4.2.10 allows remote attackers to hijack sessions via an RSS feed URL.
- Record
CVE-2015-1464- CVSS 2.0
- 6.4 Medium
AV:N/AC:L/Au:N/C:P/I:P/A:N - Weakness
- CWE-284
- Updated
- 2026-11-02
CVE List No score
RT (aka Request Tracker) before 4.0.23 and 4.2.x before 4.2.10 allows remote attackers to hijack sessions via an RSS feed URL.
- Record
CVE-2015-1464- Updated
- 2026-11-02
EUVDEUVD-2015-1599 No score
RT (aka Request Tracker) before 4.0.23 and 4.2.x before 4.2.10 allows remote attackers to hijack sessions via an RSS feed URL.
- Record
EUVD-2015-1599- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-g28c-mrpm-x2wh No score
RT (aka Request Tracker) before 4.0.23 and 4.2.x before 4.2.10 allows remote attackers to hijack...
RT (aka Request Tracker) before 4.0.23 and 4.2.x before 4.2.10 allows remote attackers to hijack sessions via an RSS feed URL.
- Record
GHSA-g28c-mrpm-x2wh- Weakness
- CWE-284
- Updated
- 2026-11-02
OSV No score
RT (aka Request Tracker) before 4.0.23 and 4.2.x before 4.2.10 allows remote attackers to hijack sessions via an RSS feed URL.
- Record
CVE-2015-1464- Updated
- 2026-11-02
OSVDEBIAN-CVE-2015-1464 No score
RT (aka Request Tracker) before 4.0.23 and 4.2.x before 4.2.10 allows remote attackers to hijack sessions via an RSS feed URL.
- Record
DEBIAN-CVE-2015-1464- Updated
- 2026-11-02
OSVMGASA-2017-0325 No score
Updated rt/perl-Encode packages fix security vulnerability
RT 4.0.0 and above are vulnerable to a limited privilege escalation leading to unauthorized modification of ticket data. The DeleteTicket right and any custom lifecycle transition rights may be bypassed by any user with ModifyTicket (CVE-2012-4733).
RT 3.8.0 and above include a version of bin/rt that uses semi-predictable names when creating tempfiles. This could possibly be exploited by a malicious user to overwrite files with permissions of the user running bin/rt (CVE-2013-3368).
RT 3.8.0 and above allow calling of arbitrary Mason components (without control of arguments) for users who can see administration pages. This could be used by a malicious user to run private components which may have negative side-effects (CVE-2013-3369).
RT 3.8.0 and above allow direct requests to private callback components. Though no callback components ship with RT, this could be used to exploit an extension or local callback which uses the arguments passed to it insecurely (CVE-2013-3370).
RT 3.8.3 and above are vulnerable to cross-site scripting (XSS) via attachment filenames. The vector is difficult to exploit due to parsing requirements. Additionally, RT 4.0.0 and above are vulnerable to XSS via maliciously-crafted "URLs" in ticket content when RT's "MakeClicky" feature is configured (CVE-2013-3371).
RT 3.8.0 and above are vulnerable to an HTTP header injection limited to the value of the Content-Disposition header. Injection of other arbitrary response headers is not possible. Some (especially older) browsers may allow multiple Content-Disposition values which could lead to XSS. Newer browsers contain security measures to prevent this (CVE-2013-3372).
RT 3.8.0 and above are vulnerable to a MIME header injection in outgoing email generated by RT (CVE-2013-3373).
RT 3.8.0 and above are vulnerable to limited session re-use when using the file-based session store, Apache::Session::File. RT's default session configuration only uses Apache::Session::File for Oracle (CVE-2013-3374).
RT 3.0.0 and above, if running on Perl 5.14.0 or higher, are vulnerable to a remote denial-of-service via the email gateway; any installation which accepts mail from untrusted sources is vulnerable, regardless of the permissions configuration inside RT. This denial-of-service may encompass both CPU and disk usage, depending on RT's logging configuration (CVE-2014-9472).
RT 3.8.8 and above are vulnerable to an information disclosure attack which may reveal RSS feeds URLs, and thus ticket data (CVE-2015-1165).
RSS feed URLs can also be leveraged to perform session hijacking, allowing a user with the URL to log in as the user that created the feed (CVE-2015-1464).
RT 4.0.0 and above are vulnerable to a cross-site scripting (XSS) attack via the user and group rights management pages (CVE-2015-5475).
RT 4.2.0 and above are vulnerable to a cross-site scripting (XSS) attack via the cryptography interface. This vulnerability could allow an attacker with a carefully-crafted key to inject JavaScript into RT's user interface. Installations which use neither GnuPG nor S/MIME are unaffected.
RT 4.0.0 and above are vulnerable to an information leak of cross-site request forgery (CSRF) verification tokens if a user visits a specific URL crafted by an attacker (CVE-2017-5943).
RT 4.0.0 and above are vulnerable to a cross-site scripting (XSS) attack if an attacker uploads a malicious file with a certain content type. Installations which use the AlwaysDownloadAttachments config setting are unaffected. This fix addresses all existant and future uploaded attachments (CVE-2016-6127).
RT 4.0.0 and above are vulnerable to timing side-channel attacks for user passwords. By carefully measuring millions or billions of login attempts, an attacker could crack a user's password even over the internet. RT now uses a constant-time comparison algorithm for secrets to thwart such attacks (CVE-2017-5361).
RT's ExternalAuth feature is vulnerable to a similar timing…
- Record
MGASA-2017-0325- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
request-tracker4Debian:12 |
before 4.2.8-3 | 4.2.8-3 |
request-tracker3.8Debian:6.0 From an advisory covering 3 CVEs |
before 3.8.8-7+squeeze8, plus listed versions 3.8.8-73.8.8-7+squeeze13.8.8-7+squeeze1~bpo50+13.8.8-7+squeeze23.8.8-7+squeeze3 Show 4 moreShow less3.8.8-7+squeeze43.8.8-7+squeeze53.8.8-7+squeeze63.8.8-7+squeeze7 |
3.8.8-7+squeeze8 |
request-tracker4Debian:7 From an advisory covering 3 CVEs |
before 4.0.7-5+deb7u3, plus listed versions 4.0.7-54.0.7-5+deb7u14.0.7-5+deb7u24.0.7-5+deb7u2~bpo60+14.0.7-5+deb7u3~bpo60+1 |
4.0.7-5+deb7u3 |
rtMageia:5 From an advisory covering 16 CVEs |
before 4.0.25-1.mga5 | 4.0.25-1.mga5 |
perl-EncodeMageia:5 From an advisory covering 16 CVEs |
before 2.640.0-1.mga5 | 2.640.0-1.mga5 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2015-1464 is a medium vulnerability (CVSS 6.4) in Bestpractical Request Tracker, published February 26, 2015. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.99%, the 80th percentile. Fixed in request-tracker4 4.2.8-3.
References
blog.bestpractical.com/2015/02/security-vulnerabilities-in-rt.html
debian.org/security/2015/dsa-3176
lists.fedoraproject.org/pipermail/package-announce/2015-March/154047.html
lists.fedoraproject.org/pipermail/package-announce/2015-April/154213.html
nvd.nist.gov/vuln/detail/CVE-2015-1464
github.com/advisories/GHSA-g28c-mrpm-x2wh
Show 7 moreShow less
security-tracker.debian.org/tracker/CVE-2015-1464
advisories.mageia.org/MGASA-2017-0325.html
bugs.mageia.org/show_bug.cgi?id=16665
lists.bestpractical.com/pipermail/rt-announce/2013-May/000226.html
lists.bestpractical.com/pipermail/rt-announce/2015-February/000273.html
lists.bestpractical.com/pipermail/rt-announce/2015-August/000279.html
lists.bestpractical.com/pipermail/rt-announce/2017-June/000297.html
Left out here: the rest of 1 source description. The JSON record has them.