Every CVE Search/ Get API key

CVE-2015-2675

The OAuth implementation in librest before 0.7.93 incorrectly truncates the pointer returned by...

7.5 HighFix available

The OAuth implementation in librest before 0.7.93 incorrectly truncates the pointer returned by the rest_proxy_call_get_url function, which allows remote attackers to cause a denial of service (application crash) via running the EnsureCredentials method from the org.gnome.OnlineAccounts.Account interface on an object representing a Flickr account.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

3.47%Up 2.1 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

The OAuth implementation in librest before 0.7.93 incorrectly truncates the pointer returned by the rest_proxy_call_get_url function, which allows remote attackers to cause a denial of service (application crash) via running the EnsureCredentials method from the org.gnome.OnlineAccounts.Account interface on an object representing a Flickr account.

Record
CVE-2015-2675
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:N/A:P
Weakness
CWE-119
Updated
2026-11-02
CVE List No score

The OAuth implementation in librest before 0.7.93 incorrectly truncates the pointer returned by the rest_proxy_call_get_url function, which allows remote attackers to cause a denial of service (application crash) via running the EnsureCredentials method from the org.gnome.OnlineAccounts.Account interface on an object representing a Flickr account.

Record
CVE-2015-2675
Updated
2026-11-02
EUVDEUVD-2015-2766 No score

The OAuth implementation in librest before 0.7.93 incorrectly truncates the pointer returned by the rest_proxy_call_get_url function, which allows remote attackers to cause a denial of service (application crash) via running the EnsureCredentials method from the org.gnome.OnlineAccounts.Account interface on an object representing a Flickr account.

Record
EUVD-2015-2766
Updated
2026-11-03
GitHub AdvisoriesGHSA-4rgr-65fh-c67c 7.5

The OAuth implementation in librest before 0.7.93 incorrectly truncates the pointer returned by...

The OAuth implementation in librest before 0.7.93 incorrectly truncates the pointer returned by the rest_proxy_call_get_url function, which allows remote attackers to cause a denial of service (application crash) via running the EnsureCredentials method from the org.gnome.OnlineAccounts.Account interface on an object representing a Flickr account.

Record
GHSA-4rgr-65fh-c67c
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-119
Updated
2026-11-02
OSV 7.5

The OAuth implementation in librest before 0.7.93 incorrectly truncates the pointer returned by the rest_proxy_call_get_url function, which allows remote attackers to cause a denial of service (application crash) via running the EnsureCredentials method from the org.gnome.OnlineAccounts.Account interface on an object representing a Flickr account.

Record
CVE-2015-2675
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2015-2675 7.5

The OAuth implementation in librest before 0.7.93 incorrectly truncates the pointer returned by the rest_proxy_call_get_url function, which allows remote attackers to cause a denial of service (application crash) via running the EnsureCredentials method from the org.gnome.OnlineAccounts.Account interface on an object representing a Flickr account.

Record
DEBIAN-CVE-2015-2675
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
librest
Debian:12
before 0.7.92-3
0.7.92-3
librest
Debian:13
before 0.7.92-3
0.7.92-3
librest
Debian:14
before 0.7.92-3
0.7.92-3
rest-debuginfo
Red Hat:enterprise_linux:7::client
before 0:0.7.92-3.el7
0:0.7.92-3.el7
rest-devel
Red Hat:enterprise_linux:7::client
before 0:0.7.92-3.el7
0:0.7.92-3.el7
rest
Red Hat:enterprise_linux:7::client
before 0:0.7.92-3.el7
0:0.7.92-3.el7
rest-debuginfo
Red Hat:enterprise_linux:7::computenode
before 0:0.7.92-3.el7
0:0.7.92-3.el7
rest-devel
Red Hat:enterprise_linux:7::computenode
before 0:0.7.92-3.el7
0:0.7.92-3.el7
rest
Red Hat:enterprise_linux:7::computenode
before 0:0.7.92-3.el7
0:0.7.92-3.el7
rest-debuginfo
Red Hat:enterprise_linux:7::server
before 0:0.7.92-3.el7
0:0.7.92-3.el7
Show 5 moreShow less
Affected packages
PackageAffectedFixed
rest-devel
Red Hat:enterprise_linux:7::server
before 0:0.7.92-3.el7
0:0.7.92-3.el7
rest
Red Hat:enterprise_linux:7::server
before 0:0.7.92-3.el7
0:0.7.92-3.el7
rest-debuginfo
Red Hat:enterprise_linux:7::workstation
before 0:0.7.92-3.el7
0:0.7.92-3.el7
rest-devel
Red Hat:enterprise_linux:7::workstation
before 0:0.7.92-3.el7
0:0.7.92-3.el7
rest
Red Hat:enterprise_linux:7::workstation
before 0:0.7.92-3.el7
0:0.7.92-3.el7

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2015-2675 is a high vulnerability (CVSS 7.5) in Gnome Librest, published August 18, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.47%, the 89th percentile. Fixed in librest 0.7.92-3.

References

Show 8 moreShow less
MoveEnter Open