Every CVE Search/ Get API key

CVE-2015-3146

The (1) SSH_MSG_NEWKEYS and (2) SSH_MSG_KEXDH_REPLY packet handlers in package_cb.c in libssh...

7.5 HighFix available

The (1) SSH_MSG_NEWKEYS and (2) SSH_MSG_KEXDH_REPLY packet handlers in package_cb.c in libssh before 0.6.5 do not properly validate state, which allows remote attackers to cause a denial of service (NULL pointer dereference and crash) via a crafted SSH packet.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

3.96%Up 2.6 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

The (1) SSH_MSG_NEWKEYS and (2) SSH_MSG_KEXDH_REPLY packet handlers in package_cb.c in libssh before 0.6.5 do not properly validate state, which allows remote attackers to cause a denial of service (NULL pointer dereference and crash) via a crafted SSH packet.

Record
CVE-2015-3146
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:N/A:P
Updated
2026-11-02
CVE List No score

The (1) SSH_MSG_NEWKEYS and (2) SSH_MSG_KEXDH_REPLY packet handlers in package_cb.c in libssh before 0.6.5 do not properly validate state, which allows remote attackers to cause a denial of service (NULL pointer dereference and crash) via a crafted SSH packet.

Record
CVE-2015-3146
Updated
2026-11-02
EUVDEUVD-2015-3227 No score

The (1) SSH_MSG_NEWKEYS and (2) SSH_MSG_KEXDH_REPLY packet handlers in package_cb.c in libssh before 0.6.5 do not properly validate state, which allows remote attackers to cause a denial of service (NULL pointer dereference and crash) via a crafted SSH packet.

Record
EUVD-2015-3227
Updated
2026-11-03
GitHub AdvisoriesGHSA-46jx-xcg7-prj7 7.5

The (1) SSH_MSG_NEWKEYS and (2) SSH_MSG_KEXDH_REPLY packet handlers in package_cb.c in libssh...

The (1) SSH_MSG_NEWKEYS and (2) SSH_MSG_KEXDH_REPLY packet handlers in package_cb.c in libssh before 0.6.5 do not properly validate state, which allows remote attackers to cause a denial of service (NULL pointer dereference and crash) via a crafted SSH packet.

Record
GHSA-46jx-xcg7-prj7
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSV 7.5

The (1) SSH_MSG_NEWKEYS and (2) SSH_MSG_KEXDH_REPLY packet handlers in package_cb.c in libssh before 0.6.5 do not properly validate state, which allows remote attackers to cause a denial of service (NULL pointer dereference and crash) via a crafted SSH packet.

Record
CVE-2015-3146
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2015-3146 7.5

The (1) SSH_MSG_NEWKEYS and (2) SSH_MSG_KEXDH_REPLY packet handlers in package_cb.c in libssh before 0.6.5 do not properly validate state, which allows remote attackers to cause a denial of service (NULL pointer dereference and crash) via a crafted SSH packet.

Record
DEBIAN-CVE-2015-3146
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
Show 6 moreShow less
OSVUBUNTU-CVE-2015-3146 7.5

The (1) SSH_MSG_NEWKEYS and (2) SSH_MSG_KEXDH_REPLY packet handlers in package_cb.c in libssh before 0.6.5 do not properly validate state, which allows remote attackers to cause a denial of service (NULL pointer dereference and crash) via a crafted SSH packet.

Record
UBUNTU-CVE-2015-3146
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVMGASA-2015-0209 No score

Updated libssh packages fix CVE-2015-3146

Updated libssh packages fix security vulnerability:

libssh versions 0.5.1 and above, but before 0.6.5, have a logical error in the handling of a SSH_MSG_NEWKEYS and SSH_MSG_KEXDH_REPLY package. A detected error did not set the session into the error state correctly and further processed the packet which leads to a null pointer dereference. This is the packet after the initial key exchange and doesn't require authentication. This could be used for a Denial of Service (DoS) attack (CVE-2015-3146).

Record
MGASA-2015-0209
Updated
2026-11-02
OSVopenSUSE-SU-2024:10036-1 No score

libssh-devel-0.7.2-2.1 on GA media

These are all security issues fixed in the libssh-devel-0.7.2-2.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10036-1
Updated
2026-11-02
OSVSUSE-SU-2015:1707-1 No score

Security update for libssh

The encryption library libssh was updated to fix one security issue.

The following vulnerability was fixed:

  • CVE-2015-3146: Unauthenticated remote attackers could crash the server or client with specially crafted packages.
Record
SUSE-SU-2015:1707-1
Updated
2026-11-02
OSVSUSE-SU-2015:1707-2 No score

Security update for libssh

The encryption library libssh was updated to fix one security issue.

The following vulnerability was fixed:

  • CVE-2015-3146: Unauthenticated remote attackers could crash the server or client with specially crafted packages.
Record
SUSE-SU-2015:1707-2
Updated
2026-11-02
OSVUSN-2912-1 No score

libssh vulnerabilities

Mariusz Ziulek discovered that libssh incorrectly handled certain packets. A remote attacker could possibly use this issue to cause libssh to crash, resulting in a denial of service. (CVE-2015-3146)

Aris Adamantiadis discovered that libssh incorrectly generated ephemeral secret keys of 128 bits instead of the recommended 1024 or 2048 bits when using the diffie-hellman-group1 and diffie-hellman-group14 methods. If a remote attacker were able to perform a machine-in-the-middle attack, this flaw could be exploited to view sensitive information. (CVE-2016-0739)

Record
USN-2912-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
libssh
Debian:12
before 0.6.3-4.2
0.6.3-4.2
libssh
Debian:13
before 0.6.3-4.2
0.6.3-4.2
libssh
Debian:14
before 0.6.3-4.2
0.6.3-4.2
libssh
Mageia:4
before 0.5.5-2.3.mga4
0.5.5-2.3.mga4
libssh
SUSE:Linux Enterprise Workstation Extension 12
before 0.6.3-8.1
0.6.3-8.1
libssh
SUSE:Linux Enterprise Desktop 12
before 0.6.3-8.1
0.6.3-8.1
libssh
SUSE:Linux Enterprise Software Development Kit 12
before 0.6.3-8.1
0.6.3-8.1
libssh
Ubuntu:14.04:LTS
before 0.6.1-0ubuntu3.3, plus listed versions
0.5.4-10.6.1-0ubuntu20.6.1-0ubuntu30.6.1-0ubuntu3.1
0.6.1-0ubuntu3.3
libssh
openSUSE:Tumbleweed
before 0.7.2-2.1
0.7.2-2.1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2015-3146 is a high vulnerability (CVSS 7.5) in Libssh, published May 5, 2015. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.96%, the 90th percentile. Fixed in libssh 0.6.3-4.2.

References

Show 20 moreShow less
MoveEnter Open