CVE-2015-3283
OpenAFS before 1.6.13 allows remote attackers to spoof bos commands via unspecified vectors.
OpenAFS before 1.6.13 allows remote attackers to spoof bos commands via unspecified vectors.
Exploit likelihood
What each source reports
NVD Score used
6.8
OpenAFS before 1.6.13 allows remote attackers to spoof bos commands via unspecified vectors.
- Record
CVE-2015-3283- CVSS 2.0
- 6.8 Medium
AV:N/AC:M/Au:N/C:P/I:P/A:P - Weakness
- CWE-264
- Updated
- 2026-11-02
CVE List No score
OpenAFS before 1.6.13 allows remote attackers to spoof bos commands via unspecified vectors.
- Record
CVE-2015-3283- Updated
- 2026-11-02
EUVDEUVD-2015-3330 No score
OpenAFS before 1.6.13 allows remote attackers to spoof bos commands via unspecified vectors.
- Record
EUVD-2015-3330- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-9w9q-w9xf-7wgw No score
OpenAFS before 1.6.13 allows remote attackers to spoof bos commands via unspecified vectors.
OpenAFS before 1.6.13 allows remote attackers to spoof bos commands via unspecified vectors.
- Record
GHSA-9w9q-w9xf-7wgw- Updated
- 2026-11-02
OSV No score
OpenAFS before 1.6.13 allows remote attackers to spoof bos commands via unspecified vectors.
- Record
CVE-2015-3283- Updated
- 2026-11-02
OSVDEBIAN-CVE-2015-3283 No score
OpenAFS before 1.6.13 allows remote attackers to spoof bos commands via unspecified vectors.
- Record
DEBIAN-CVE-2015-3283- Updated
- 2026-11-02
OSVMGASA-2015-0337 No score
Updated openafs package fixes security vulnerabilities
Updated openafs packages fix security vulnerabilities:
Memory allocated by vos for VLDB entry structures was not cleared prior to use, meaning stack data could be sent over the network, possibly in the clear if crypt mode was not in use (CVE-2015-3282).
The default use by bos of clear rather than crypt mode can allow spoofing commands, including some which modify server state if restricted mode was not enabled (CVE-2015-3283).
A local user executing commands which make pioctl calls to the kernel will have some contents of kernel memory leaked when buffers used are larger than data being returned (CVE-2015-3284).
A local user executing the OSD FS command pioctl can trigger a panic due to an incorrect buffer being used for return status of the command (CVE-2015-3285).
The vlserver allows pattern matching on volume names via regular expressions when listing attributes. Because the regular expression is not checked for situations which can overflow the buffers used, an attack is possible which reads arbitrary memory beyond the end of the buffer and can act on it as part of the expression evaluation, potentially crashing the process (CVE-2015-6587).
- Record
MGASA-2015-0337- Updated
- 2026-11-02
OSVUBUNTU-CVE-2015-3283 No score
OpenAFS before 1.6.13 allows remote attackers to spoof bos commands via unspecified vectors.
- Record
UBUNTU-CVE-2015-3283- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
openafsDebian:12 |
before 1.6.13-1 | 1.6.13-1 |
openafsDebian:13 |
before 1.6.13-1 | 1.6.13-1 |
openafsDebian:6.0 From an advisory covering 6 CVEs |
before 1.4.12.1+dfsg-4+squeeze4, plus listed versions 1.4.12.1+dfsg-31.4.12.1+dfsg-41.4.12.1+dfsg-4+squeeze11.4.12.1+dfsg-4+squeeze21.4.12.1+dfsg-4+squeeze31.4.12.1+dfsg-4~bpo50+1 |
1.4.12.1+dfsg-4+squeeze4 |
openafsDebian:7 From an advisory covering 5 CVEs |
before 1.6.1-3+deb7u3, plus listed versions 1.6.1-31.6.1-3+deb7u11.6.1-3+deb7u1~bpo60+11.6.1-3+deb7u21.6.1-3+deb7u2~bpo60+1 |
1.6.1-3+deb7u3 |
openafsDebian:8 From an advisory covering 5 CVEs |
before 1.6.9-2+deb8u3, plus listed versions 1.6.9-2+deb8u2 |
1.6.9-2+deb8u3 |
openafsMageia:4 From an advisory covering 5 CVEs |
before 1.6.13-1.mga4 | 1.6.13-1.mga4 |
openafsMageia:5 From an advisory covering 5 CVEs |
before 1.6.13-1.mga5 | 1.6.13-1.mga5 |
openafsUbuntu:14.04:LTS |
before 1.6.7-1ubuntu1.1, plus listed versions 1.6.5-1ubuntu31.6.5.1-11.6.5.1-1ubuntu11.6.6~pre2-11.6.6-11.6.7-11.6.7-1ubuntu1 |
1.6.7-1ubuntu1.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2015-3283 is a medium vulnerability (CVSS 6.8) in Openafs, published July 30, 2015. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.08%, the 81st percentile. Fixed in openafs 1.6.13-1.
References
securitytracker.com/id/1033262
openafs.org/dl/openafs/1.6.13/RELNOTES-1.6.13
debian.org/security/2015/dsa-3320
lists.openafs.org/pipermail/openafs-announce/2015/000486.html
openafs.org/pages/security/OPENAFS-SA-2015-002.txt
nvd.nist.gov/vuln/detail/CVE-2015-3283
Show 12 moreShow less
github.com/advisories/GHSA-9w9q-w9xf-7wgw
security-tracker.debian.org/tracker/CVE-2015-3283
advisories.mageia.org/MGASA-2015-0337.html
bugs.mageia.org/show_bug.cgi?id=16515
openafs.org/pages/security/OPENAFS-SA-2015-001.txt
openafs.org/pages/security/OPENAFS-SA-2015-003.txt
openafs.org/pages/security/OPENAFS-SA-2015-004.txt
openafs.org/pages/security/OPENAFS-SA-2015-006.txt
openafs.org/pipermail/openafs-announce/2015/000486.html
openwall.com/lists/oss-security/2015/09/02/2
ubuntu.com/security/CVE-2015-3283
cve.org/CVERecord?id=CVE-2015-3283