Every CVE Search/ Get API key

CVE-2015-4146

The EAP-pwd peer implementation in hostapd and wpa_supplicant 1.0 through 2.4 does not clear the...

5.0 MediumFix available

The EAP-pwd peer implementation in hostapd and wpa_supplicant 1.0 through 2.4 does not clear the L (Length) and M (More) flags before determining if a response should be fragmented, which allows remote attackers to cause a denial of service (crash) via a crafted message.

Exploit likelihood

3.48%Up 2.1 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.0

The EAP-pwd peer implementation in hostapd and wpa_supplicant 1.0 through 2.4 does not clear the L (Length) and M (More) flags before determining if a response should be fragmented, which allows remote attackers to cause a denial of service (crash) via a crafted message.

Record
CVE-2015-4146
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:N/A:P
Updated
2026-11-02
CVE List No score

The EAP-pwd peer implementation in hostapd and wpa_supplicant 1.0 through 2.4 does not clear the L (Length) and M (More) flags before determining if a response should be fragmented, which allows remote attackers to cause a denial of service (crash) via a crafted message.

Record
CVE-2015-4146
Updated
2026-11-02
EUVDEUVD-2015-4170 No score

The EAP-pwd peer implementation in hostapd and wpa_supplicant 1.0 through 2.4 does not clear the L (Length) and M (More) flags before determining if a response should be fragmented, which allows remote attackers to cause a denial of service (crash) via a crafted message.

Record
EUVD-2015-4170
Updated
2026-11-03
GitHub AdvisoriesGHSA-f2m4-x3g9-fqq7 No score

The EAP-pwd peer implementation in hostapd and wpa_supplicant 1.0 through 2.4 does not clear the...

The EAP-pwd peer implementation in hostapd and wpa_supplicant 1.0 through 2.4 does not clear the L (Length) and M (More) flags before determining if a response should be fragmented, which allows remote attackers to cause a denial of service (crash) via a crafted message.

Record
GHSA-f2m4-x3g9-fqq7
Updated
2026-11-02
OSV No score

The EAP-pwd peer implementation in hostapd and wpa_supplicant 1.0 through 2.4 does not clear the L (Length) and M (More) flags before determining if a response should be fragmented, which allows remote attackers to cause a denial of service (crash) via a crafted message.

Record
CVE-2015-4146
Updated
2026-11-02
OSVDEBIAN-CVE-2015-4146 No score

The EAP-pwd peer implementation in hostapd and wpa_supplicant 1.0 through 2.4 does not clear the L (Length) and M (More) flags before determining if a response should be fragmented, which allows remote attackers to cause a denial of service (crash) via a crafted message.

Record
DEBIAN-CVE-2015-4146
Updated
2026-11-02
OSVopenSUSE-SU-2024:10499-1 No score

wpa_supplicant-2.6-1.1 on GA media

These are all security issues fixed in the wpa_supplicant-2.6-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10499-1
Updated
2026-11-02
OSVUBUNTU-CVE-2015-4146 No score

The EAP-pwd peer implementation in hostapd and wpa_supplicant 1.0 through 2.4 does not clear the L (Length) and M (More) flags before determining if a response should be fragmented, which allows remote attackers to cause a denial of service (crash) via a crafted message.

Record
UBUNTU-CVE-2015-4146
Updated
2026-11-02
OSVUSN-2650-1 No score

wpa, wpasupplicant vulnerabilities

Kostya Kortchinsky discovered multiple flaws in wpa_supplicant and hostapd. A remote attacker could use these issues to cause wpa_supplicant or hostapd to crash, resulting in a denial of service. (CVE-2015-4141, CVE-2015-4142, CVE-2015-4143, CVE-2015-4144, CVE-2015-4145, CVE-2015-4146)

Record
USN-2650-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
wpa
Debian:12
before 2.3-2.2
2.3-2.2
wpa
Debian:13
before 2.3-2.2
2.3-2.2
wpa
Debian:14
before 2.3-2.2
2.3-2.2
wpa
Debian:7
From an advisory covering 11 CVEs
before 1.0-3+deb7u3, plus listed versions
1.0-31.0-3+deb7u11.0-3+deb7u2
1.0-3+deb7u3
wpa
Debian:8
From an advisory covering 11 CVEs
before 2.3-1+deb8u3, plus listed versions
2.3-12.3-1+deb8u12.3-1+deb8u2
2.3-1+deb8u3
wpa
Ubuntu:14.04:LTS
before 2.1-0ubuntu1.3, plus listed versions
1.0-3ubuntu21.0-3ubuntu31.0-3ubuntu42.1-0ubuntu12.1-0ubuntu1.12.1-0ubuntu1.2
2.1-0ubuntu1.3
wpa
Ubuntu:14.04:LTS
From an advisory covering 6 CVEs
before 2.1-0ubuntu1.3, plus listed versions
1.0-3ubuntu21.0-3ubuntu31.0-3ubuntu42.1-0ubuntu12.1-0ubuntu1.12.1-0ubuntu1.2
2.1-0ubuntu1.3
wpa_supplicant
openSUSE:Tumbleweed
From an advisory covering 13 CVEs
before 2.6-1.1
2.6-1.1

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2015-4146 is a medium vulnerability (CVSS 5.0) in W1.fi Hostapd, published June 1, 2015. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.48%, the 89th percentile. Fixed in wpa 2.3-2.2.

References

Show 28 moreShow less
MoveEnter Open