CVE-2015-5315
The eap_pwd_process function in eap_peer/eap_pwd.c in wpa_supplicant 2.x before 2.6 does not...
The eap_pwd_process function in eap_peer/eap_pwd.c in wpa_supplicant 2.x before 2.6 does not validate that the reassembly buffer is large enough for the final fragment when EAP-pwd is enabled in a network configuration profile, which allows remote attackers to cause a denial of service (process termination) via a large final fragment in an EAP-pwd message.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- High
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
5.9
The eap_pwd_process function in eap_peer/eap_pwd.c in wpa_supplicant 2.x before 2.6 does not validate that the reassembly buffer is large enough for the final fragment when EAP-pwd is enabled in a network configuration profile, which allows remote attackers to cause a denial of service (process termination) via a large final fragment in an EAP-pwd message.
- Record
CVE-2015-5315- CVSS 3.0
- 5.9 Medium
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:N/A:P - Weakness
- CWE-119
- Updated
- 2026-11-02
CVE List No score
The eap_pwd_process function in eap_peer/eap_pwd.c in wpa_supplicant 2.x before 2.6 does not validate that the reassembly buffer is large enough for the final fragment when EAP-pwd is enabled in a network configuration profile, which allows remote attackers to cause a denial of service (process termination) via a large final fragment in an EAP-pwd message.
- Record
CVE-2015-5315- Updated
- 2026-11-02
EUVDEUVD-2015-5286 No score
The eap_pwd_process function in eap_peer/eap_pwd.c in wpa_supplicant 2.x before 2.6 does not validate that the reassembly buffer is large enough for the final fragment when EAP-pwd is enabled in a network configuration profile, which allows remote attackers to cause a denial of service (process termination) via a large final fragment in an EAP-pwd message.
- Record
EUVD-2015-5286- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-qmc2-8wcw-c6p2
5.9
The eap_pwd_process function in eap_peer/eap_pwd.c in wpa_supplicant 2.x before 2.6 does not...
The eap_pwd_process function in eap_peer/eap_pwd.c in wpa_supplicant 2.x before 2.6 does not validate that the reassembly buffer is large enough for the final fragment when EAP-pwd is enabled in a network configuration profile, which allows remote attackers to cause a denial of service (process termination) via a large final fragment in an EAP-pwd message.
- Record
GHSA-qmc2-8wcw-c6p2- CVSS 3.0
- 5.9 Medium
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-119
- Updated
- 2026-11-02
OSV
5.9
The eap_pwd_process function in eap_peer/eap_pwd.c in wpa_supplicant 2.x before 2.6 does not validate that the reassembly buffer is large enough for the final fragment when EAP-pwd is enabled in a network configuration profile, which allows remote attackers to cause a denial of service (process termination) via a large final fragment in an EAP-pwd message.
- Record
CVE-2015-5315- CVSS 3.0
- 5.9 Medium
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2015-5315
5.9
The eap_pwd_process function in eap_peer/eap_pwd.c in wpa_supplicant 2.x before 2.6 does not validate that the reassembly buffer is large enough for the final fragment when EAP-pwd is enabled in a network configuration profile, which allows remote attackers to cause a denial of service (process termination) via a large final fragment in an EAP-pwd message.
- Record
DEBIAN-CVE-2015-5315- CVSS 3.0
- 5.9 Medium
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2015-5315
5.9
The eap_pwd_process function in eap_peer/eap_pwd.c in wpa_supplicant 2.x before 2.6 does not validate that the reassembly buffer is large enough for the final fragment when EAP-pwd is enabled in a network configuration profile, which allows remote attackers to cause a denial of service (process termination) via a large final fragment in an EAP-pwd message.
- Record
UBUNTU-CVE-2015-5315- CVSS 3.0
- 5.9 Medium
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVopenSUSE-SU-2024:10499-1 No score
wpa_supplicant-2.6-1.1 on GA media
These are all security issues fixed in the wpa_supplicant-2.6-1.1 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:10499-1- Updated
- 2026-11-02
OSVUSN-2808-1 No score
wpa vulnerabilities
It was discovered that wpa_supplicant incorrectly handled WMM Sleep Mode Response frame processing. A remote attacker could use this issue to perform broadcast/multicast packet injections, or cause a denial of service. (CVE-2015-5310)
It was discovered that wpa_supplicant and hostapd incorrectly handled certain EAP-pwd messages. A remote attacker could use this issue to cause a denial of service. (CVE-2015-5314, CVE-2015-5315)
It was discovered that wpa_supplicant incorrectly handled certain EAP-pwd Confirm messages. A remote attacker could use this issue to cause a denial of service. This issue only applied to Ubuntu 15.10. (CVE-2015-5316)
- Record
USN-2808-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
wpaDebian:12 |
before 2.3-2.3 | 2.3-2.3 |
wpaDebian:13 |
before 2.3-2.3 | 2.3-2.3 |
wpaDebian:14 |
before 2.3-2.3 | 2.3-2.3 |
wpaDebian:7 From an advisory covering 11 CVEs |
before 1.0-3+deb7u3, plus listed versions 1.0-31.0-3+deb7u11.0-3+deb7u2 |
1.0-3+deb7u3 |
wpaDebian:8 From an advisory covering 11 CVEs |
before 2.3-1+deb8u3, plus listed versions 2.3-12.3-1+deb8u12.3-1+deb8u2 |
2.3-1+deb8u3 |
wpaUbuntu:14.04:LTS |
before 2.1-0ubuntu1.4, plus listed versions 1.0-3ubuntu21.0-3ubuntu31.0-3ubuntu42.1-0ubuntu12.1-0ubuntu1.12.1-0ubuntu1.22.1-0ubuntu1.3 |
2.1-0ubuntu1.4 |
wpaUbuntu:14.04:LTS From an advisory covering 3 CVEs |
before 2.1-0ubuntu1.4, plus listed versions 1.0-3ubuntu21.0-3ubuntu31.0-3ubuntu42.1-0ubuntu12.1-0ubuntu1.12.1-0ubuntu1.22.1-0ubuntu1.3 |
2.1-0ubuntu1.4 |
wpa_supplicantopenSUSE:Tumbleweed From an advisory covering 13 CVEs |
before 2.6-1.1 | 2.6-1.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2015-5315 is a medium vulnerability (CVSS 5.9) in Debian Linux, published November 10, 2015. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.52%, the 84th percentile. Fixed in wpa 2.3-2.3.
References
ubuntu.com/usn/USN-2808-1
debian.org/security/2015/dsa-3397
w1.fi/security/2015-7/eap-pwd-missing-last-fragment-length-validation.txt
openwall.com/lists/oss-security/2015/11/10/10
nvd.nist.gov/vuln/detail/CVE-2015-5315
github.com/advisories/GHSA-qmc2-8wcw-c6p2
Show 21 moreShow less
security-tracker.debian.org/tracker/CVE-2015-5315
ubuntu.com/security/CVE-2015-5315
w1.fi/security/2015-7
ubuntu.com/security/notices/USN-2808-1
cve.org/CVERecord?id=CVE-2015-5315
ubuntu.com/security/CVE-2015-5310
ubuntu.com/security/CVE-2015-5314
ubuntu.com/security/CVE-2015-5316
suse.com/security/cve/CVE-2014-3686
suse.com/security/cve/CVE-2015-1863
suse.com/security/cve/CVE-2015-4141
suse.com/security/cve/CVE-2015-4142
suse.com/security/cve/CVE-2015-4143
suse.com/security/cve/CVE-2015-4144
suse.com/security/cve/CVE-2015-4145
suse.com/security/cve/CVE-2015-4146
suse.com/security/cve/CVE-2015-5310
suse.com/security/cve/CVE-2015-5315
suse.com/security/cve/CVE-2015-5316
suse.com/security/cve/CVE-2016-4476
suse.com/security/cve/CVE-2016-4477