Every CVE Search/ Get API key

CVE-2015-5522

Heap-based buffer overflow in the ParseValue function in lexer.c in tidy before 4.9.31 allows...

6.8 MediumFix available

Heap-based buffer overflow in the ParseValue function in lexer.c in tidy before 4.9.31 allows remote attackers to cause a denial of service (crash) via vectors involving a command character in an href.

Exploit likelihood

4.63%Up 1.2 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 6.8

Heap-based buffer overflow in the ParseValue function in lexer.c in tidy before 4.9.31 allows remote attackers to cause a denial of service (crash) via vectors involving a command character in an href.

Record
CVE-2015-5522
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Weakness
CWE-119
Updated
2026-11-02
CVE List No score

Heap-based buffer overflow in the ParseValue function in lexer.c in tidy before 4.9.31 allows remote attackers to cause a denial of service (crash) via vectors involving a command character in an href.

Record
CVE-2015-5522
Updated
2026-11-02
EUVDEUVD-2015-5477 No score

Heap-based buffer overflow in the ParseValue function in lexer.c in tidy before 4.9.31 allows remote attackers to cause a denial of service (crash) via vectors involving a command character in an href.

Record
EUVD-2015-5477
Updated
2026-11-03
GitHub AdvisoriesGHSA-wp28-phrj-p6rh No score

Heap-based buffer overflow in the ParseValue function in lexer.c in tidy before 4.9.31 allows...

Heap-based buffer overflow in the ParseValue function in lexer.c in tidy before 4.9.31 allows remote attackers to cause a denial of service (crash) via vectors involving a command character in an href.

Record
GHSA-wp28-phrj-p6rh
Weakness
CWE-119
Updated
2026-11-02
OSVopenSUSE-SU-2024:10210-1 No score

libtidy-devel-5.2.0-2.3 on GA media

These are all security issues fixed in the libtidy-devel-5.2.0-2.3 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10210-1
Updated
2026-11-02
OSVSUSE-SU-2015:1513-1 No score

Security update for tidy

This update fixes two heap-based buffer overflows in tidy/libtidy. These vulnerabilities could allow remote attackers to cause a denial of service (crash) via vectors involving a command character in an href. (CVE-2015-5522, CVE-2015-5523)

Record
SUSE-SU-2015:1513-1
Updated
2026-11-02
OSVSUSE-SU-2015:1525-1 No score

Security update for tidy

This update fixes two heap-based buffer overflows in tidy/libtidy. These vulnerabilities could allow remote attackers to cause a denial of service (crash) via vectors involving a command character in an href. (CVE-2015-5522, CVE-2015-5523)

Record
SUSE-SU-2015:1525-1
Updated
2026-11-02
OSVUBUNTU-CVE-2015-5522 No score

Heap-based buffer overflow in the ParseValue function in lexer.c in tidy before 4.9.31 allows remote attackers to cause a denial of service (crash) via vectors involving a command character in an href.

Record
UBUNTU-CVE-2015-5522
Updated
2026-11-02
OSVUSN-2695-1 No score

tidy vulnerabilities

Fernando Muñoz discovered that HTML Tidy incorrectly handled memory. If a user or automated system were tricked into processing specially crafted data, applications linked against HTML Tidy could be made to crash, leading to a denial of service, or possibly execute arbitrary code.

Record
USN-2695-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
tidy
Debian:6.0
From an advisory covering 2 CVEs
before 20091223cvs-1+deb6u1, plus listed versions
20091223cvs-1
20091223cvs-1+deb6u1
tidy
Debian:7
From an advisory covering 2 CVEs
before 20091223cvs-1.2+deb7u1, plus listed versions
20091223cvs-1.2
20091223cvs-1.2+deb7u1
tidy
Debian:8
From an advisory covering 2 CVEs
before 20091223cvs-1.4+deb8u1, plus listed versions
20091223cvs-1.4
20091223cvs-1.4+deb8u1
tidy
SUSE:Linux Enterprise Software Development Kit 12
From an advisory covering 2 CVEs
before 1.0.20100204cvs-25.3
1.0.20100204cvs-25.3
tidy
SUSE:Linux Enterprise Software Development Kit 11 SP3
From an advisory covering 2 CVEs
before 1.0-37.1
1.0-37.1
tidy
SUSE:Linux Enterprise Software Development Kit 11 SP4
From an advisory covering 2 CVEs
before 1.0-37.1
1.0-37.1
tidy
SUSE:Linux Enterprise Desktop 11 SP3
From an advisory covering 2 CVEs
before 1.0-37.1
1.0-37.1
tidy
SUSE:Linux Enterprise Desktop 11 SP4
From an advisory covering 2 CVEs
before 1.0-37.1
1.0-37.1
tidy
Ubuntu:14.04:LTS
before 20091223cvs-1.2ubuntu1.1, plus listed versions
20091223cvs-1.220091223cvs-1.2ubuntu1
20091223cvs-1.2ubuntu1.1
tidy
Ubuntu:14.04:LTS
From an advisory covering 2 CVEs
before 20091223cvs-1.2ubuntu1.1, plus listed versions
20091223cvs-1.220091223cvs-1.2ubuntu1
20091223cvs-1.2ubuntu1.1
tidy
openSUSE:Tumbleweed
From an advisory covering 3 CVEs
before 5.2.0-2.3
5.2.0-2.3

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2015-5522 is a medium vulnerability (CVSS 6.8) in Htacg Tidy, published July 16, 2015. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 4.63%, the 91st percentile. Fixed in tidy 20091223cvs-1.2ubuntu1.1.

References

Show 21 moreShow less
MoveEnter Open