CVE-2015-6031
Buffer overflow in the IGDstartelt function in igd_desc_parse.c in the MiniUPnP client (aka...
Buffer overflow in the IGDstartelt function in igd_desc_parse.c in the MiniUPnP client (aka MiniUPnPc) before 1.9.20150917 allows remote UPNP servers to cause a denial of service (application crash) and possibly execute arbitrary code via an "oversized" XML element name.
Exploit likelihood
What each source reports
NVD Score used
6.8
Buffer overflow in the IGDstartelt function in igd_desc_parse.c in the MiniUPnP client (aka MiniUPnPc) before 1.9.20150917 allows remote UPNP servers to cause a denial of service (application crash) and possibly execute arbitrary code via an "oversized" XML element name.
- Record
CVE-2015-6031- CVSS 2.0
- 6.8 Medium
AV:N/AC:M/Au:N/C:P/I:P/A:P - Weakness
- CWE-119
- Updated
- 2026-11-02
CVE List No score
Buffer overflow in the IGDstartelt function in igd_desc_parse.c in the MiniUPnP client (aka MiniUPnPc) before 1.9.20150917 allows remote UPNP servers to cause a denial of service (application crash) and possibly execute arbitrary code via an "oversized" XML element name.
- Record
CVE-2015-6031- Updated
- 2026-11-02
EUVDEUVD-2015-5974 No score
Buffer overflow in the IGDstartelt function in igd_desc_parse.c in the MiniUPnP client (aka MiniUPnPc) before 1.9.20150917 allows remote UPNP servers to cause a denial of service (application crash) and possibly execute arbitrary code via an "oversized" XML element name.
- Record
EUVD-2015-5974- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-m2cw-vw6v-jp5c No score
Buffer overflow in the IGDstartelt function in igd_desc_parse.c in the MiniUPnP client (aka...
Buffer overflow in the IGDstartelt function in igd_desc_parse.c in the MiniUPnP client (aka MiniUPnPc) before 1.9.20150917 allows remote UPNP servers to cause a denial of service (application crash) and possibly execute arbitrary code via an "oversized" XML element name.
- Record
GHSA-m2cw-vw6v-jp5c- Weakness
- CWE-119
- Updated
- 2026-11-02
OSV No score
Buffer overflow in the IGDstartelt function in igd_desc_parse.c in the MiniUPnP client (aka MiniUPnPc) before 1.9.20150917 allows remote UPNP servers to cause a denial of service (application crash) and possibly execute arbitrary code via an "oversized" XML element name.
- Record
CVE-2015-6031- Updated
- 2026-11-02
OSVDEBIAN-CVE-2015-6031 No score
Buffer overflow in the IGDstartelt function in igd_desc_parse.c in the MiniUPnP client (aka MiniUPnPc) before 1.9.20150917 allows remote UPNP servers to cause a denial of service (application crash) and possibly execute arbitrary code via an "oversized" XML element name.
- Record
DEBIAN-CVE-2015-6031- Updated
- 2026-11-02
OSVMGASA-2015-0416 No score
Updated miniupnpc package fixes security vulnerability
An exploitable buffer overflow vulnerability exists in the XML parser functionality of the MiniUPnP library. A specially crafted XML response can lead to a buffer overflow on the stack resulting in remote code execution. An attacker can set up a server on the local network to trigger this vulnerability (CVE-2015-6031).
- Record
MGASA-2015-0416- Updated
- 2026-11-02
OSVUBUNTU-CVE-2015-6031 No score
Buffer overflow in the IGDstartelt function in igd_desc_parse.c in the MiniUPnP client (aka MiniUPnPc) before 1.9.20150917 allows remote UPNP servers to cause a denial of service (application crash) and possibly execute arbitrary code via an "oversized" XML element name.
- Record
UBUNTU-CVE-2015-6031- Updated
- 2026-11-02
OSVUSN-2780-1 No score
miniupnpc vulnerability
Aleksandar Nikolic discovered a buffer overflow vulnerability in the XML parser functionality of the MiniUPnP library. A remote attacker could use this to cause a denial of service (application crash) or possibly execute arbitrary code with privileges of the user running an application that uses the MiniUPnP library.
- Record
USN-2780-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
miniupnpcDebian:12 |
before 1.9.20140610-2.1 | 1.9.20140610-2.1 |
miniupnpcDebian:13 |
before 1.9.20140610-2.1 | 1.9.20140610-2.1 |
miniupnpcDebian:14 |
before 1.9.20140610-2.1 | 1.9.20140610-2.1 |
miniupnpcDebian:7 |
before 1.5-2+deb7u1, plus listed versions 1.5-2 |
1.5-2+deb7u1 |
miniupnpcDebian:8 |
before 1.9.20140610-2+deb8u1, plus listed versions 1.9.20140610-2 |
1.9.20140610-2+deb8u1 |
miniupnpcMageia:5 |
before 1.9.20141128-1.1.mga5 | 1.9.20141128-1.1.mga5 |
miniupnpcUbuntu:14.04:LTS |
before 1.6-3ubuntu2.14.04.2, plus listed versions 1.6-3ubuntu21.6-3ubuntu2.14.04.1 |
1.6-3ubuntu2.14.04.2 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2015-6031 is a medium vulnerability (CVSS 6.8) in Miniupnp Project Miniupnpc, published October 16, 2015. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 4.76%, the 91st percentile. Fixed in miniupnpc 1.9.20140610-2.1.
References
github.com/miniupnp/miniupnp/blob/master/miniupnpc/Changelog.txt
security.gentoo.org/glsa/201801-08
debian.org/security/2015/dsa-3379
ubuntu.com/usn/USN-2780-1
securityfocus.com/bid/77306
talosintel.com/reports/TALOS-2015-0035
Show 12 moreShow less
ubuntu.com/usn/USN-2780-2
lists.opensuse.org/opensuse-updates/2015-11/msg00122.html
github.com/miniupnp/miniupnp/commit/79cca974a4c2ab1199786732a67ff6d898051b78
nvd.nist.gov/vuln/detail/CVE-2015-6031
github.com/advisories/GHSA-m2cw-vw6v-jp5c
security-tracker.debian.org/tracker/CVE-2015-6031
advisories.mageia.org/MGASA-2015-0416.html
bugs.mageia.org/show_bug.cgi?id=16985
ubuntu.com/security/CVE-2015-6031
ubuntu.com/security/notices/USN-2780-1
ubuntu.com/security/notices/USN-2780-2
cve.org/CVERecord?id=CVE-2015-6031