Every CVE Search/ Get API key

CVE-2015-7102

WebKit in Apple iOS before 9.2, Safari before 9.0.2, and tvOS before 9.1 allows remote attackers...

6.8 Medium

WebKit in Apple iOS before 9.2, Safari before 9.0.2, and tvOS before 9.1 allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption and application crash) via a crafted web site, a different vulnerability than CVE-2015-7048, CVE-2015-7095, CVE-2015-7096, CVE-2015-7097, CVE-2015-7098, CVE-2015-7099, CVE-2015-7100, CVE-2015-7101, and CVE-2015-7103.

Exploit likelihood

2.78%Down 1.1 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 6.8

WebKit in Apple iOS before 9.2, Safari before 9.0.2, and tvOS before 9.1 allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption and application crash) via a crafted web site, a different vulnerability than CVE-2015-7048, CVE-2015-7095, CVE-2015-7096, CVE-2015-7097, CVE-2015-7098, CVE-2015-7099, CVE-2015-7100, CVE-2015-7101, and CVE-2015-7103.

Record
CVE-2015-7102
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Weakness
CWE-119
Updated
2026-11-02
CVE List No score

WebKit in Apple iOS before 9.2, Safari before 9.0.2, and tvOS before 9.1 allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption and application crash) via a crafted web site, a different vulnerability than CVE-2015-7048, CVE-2015-7095, CVE-2015-7096, CVE-2015-7097, CVE-2015-7098, CVE-2015-7099, CVE-2015-7100, CVE-2015-7101, and CVE-2015-7103.

Record
CVE-2015-7102
Updated
2026-11-02
EUVDEUVD-2015-7034 No score

WebKit in Apple iOS before 9.2, Safari before 9.0.2, and tvOS before 9.1 allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption and application crash) via a crafted web site, a different vulnerability than CVE-2015-7048, CVE-2015-7095, CVE-2015-7096, CVE-2015-7097, CVE-2015-7098, CVE-2015-7099, CVE-2015-7100, CVE-2015-7101, and CVE-2015-7103.

Record
EUVD-2015-7034
Updated
2026-11-03
GitHub AdvisoriesGHSA-xh27-gh58-w45h No score

WebKit in Apple iOS before 9.2, Safari before 9.0.2, and tvOS before 9.1 allows remote attackers...

WebKit in Apple iOS before 9.2, Safari before 9.0.2, and tvOS before 9.1 allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption and application crash) via a crafted web site, a different vulnerability than CVE-2015-7048, CVE-2015-7095, CVE-2015-7096, CVE-2015-7097, CVE-2015-7098, CVE-2015-7099, CVE-2015-7100, CVE-2015-7101, and CVE-2015-7103.

Record
GHSA-xh27-gh58-w45h
Weakness
CWE-119
Updated
2026-11-02
OSVMGASA-2016-0116 No score

Updated webkit2 packages fix security vulnerability

The webkit2 package has been updated to version 2.10.9, fixing several security issues and other bugs.

Record
MGASA-2016-0116
Updated
2026-11-02
OSVUBUNTU-CVE-2015-7102 No score

WebKit in Apple iOS before 9.2, Safari before 9.0.2, and tvOS before 9.1 allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption and application crash) via a crafted web site, a different vulnerability than CVE-2015-7048, CVE-2015-7095, CVE-2015-7096, CVE-2015-7097, CVE-2015-7098, CVE-2015-7099, CVE-2015-7100, CVE-2015-7101, and CVE-2015-7103.

Record
UBUNTU-CVE-2015-7102
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
webkit2
Mageia:5
From an advisory covering 106 CVEs
before 2.10.9-1.mga5
2.10.9-1.mga5
qtwebkit-opensource-src
Ubuntu:16.04:LTS
All versions, plus listed versions
5.4.2+dfsg-1ubuntu2.15.5.1+dfsg-2ubuntu1
None known
qtwebkit-source
Ubuntu:16.04:LTS
All versions, plus listed versions
2.3.2-0ubuntu102.3.2-0ubuntu11
None known
webkitgtk
Ubuntu:16.04:LTS
All versions, plus listed versions
2.4.9-2ubuntu22.4.10-0ubuntu12.4.11-0ubuntu0.1
None known

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2015-7102 is a medium vulnerability (CVSS 6.8) in Apple Safari, published December 11, 2015. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.78%, the 86th percentile. No source names a fixed version.

References

Show 27 moreShow less
MoveEnter Open