Every CVE Search/ Get API key

CVE-2015-8077

Integer overflow in the index_urlfetch function in imap/index.c in Cyrus IMAP 2.3.19, 2.4.18, and...

7.5 High

Integer overflow in the index_urlfetch function in imap/index.c in Cyrus IMAP 2.3.19, 2.4.18, and 2.5.6 allows remote attackers to have unspecified impact via vectors related to urlfetch range checks and the start_octet variable. NOTE: this vulnerability exists because of an incomplete fix for CVE-2015-8076.

Exploit likelihood

3.26%Up 1.1 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

Integer overflow in the index_urlfetch function in imap/index.c in Cyrus IMAP 2.3.19, 2.4.18, and 2.5.6 allows remote attackers to have unspecified impact via vectors related to urlfetch range checks and the start_octet variable. NOTE: this vulnerability exists because of an incomplete fix for CVE-2015-8076.

Record
CVE-2015-8077
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-189
Updated
2026-11-02
CVE List No score

Integer overflow in the index_urlfetch function in imap/index.c in Cyrus IMAP 2.3.19, 2.4.18, and 2.5.6 allows remote attackers to have unspecified impact via vectors related to urlfetch range checks and the start_octet variable. NOTE: this vulnerability exists because of an incomplete fix for CVE-2015-8076.

Record
CVE-2015-8077
Updated
2026-11-02
EUVDEUVD-2015-7970 No score

Integer overflow in the index_urlfetch function in imap/index.c in Cyrus IMAP 2.3.19, 2.4.18, and 2.5.6 allows remote attackers to have unspecified impact via vectors related to urlfetch range checks and the start_octet variable. NOTE: this vulnerability exists because of an incomplete fix for CVE-2015-8076.

Record
EUVD-2015-7970
Updated
2026-11-03
GitHub AdvisoriesGHSA-gjf9-hv65-fr5w No score

Integer overflow in the index_urlfetch function in imap/index.c in Cyrus IMAP 2.3.19, 2.4.18, and...

Integer overflow in the index_urlfetch function in imap/index.c in Cyrus IMAP 2.3.19, 2.4.18, and 2.5.6 allows remote attackers to have unspecified impact via vectors related to urlfetch range checks and the start_octet variable. NOTE: this vulnerability exists because of an incomplete fix for CVE-2015-8076.

Record
GHSA-gjf9-hv65-fr5w
Updated
2026-11-02
OSVMGASA-2016-0045 No score

Updated cyrus-imapd packages fix security vulnerability

Cyrus-imapd versions 2.4.18 and earlier are vulnerable to potential integer and buffer overflows (CVE-2015-8077, CVE-2015-8078).

Record
MGASA-2016-0045
Updated
2026-11-02
OSVopenSUSE-SU-2024:10015-1 No score

cyradm-2.4.18-3.4 on GA media

These are all security issues fixed in the cyradm-2.4.18-3.4 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10015-1
Updated
2026-11-02
OSVSUSE-SU-2016:1457-1 No score

Security update for cyrus-imapd

  • Previous versions of cyrus-imapd would not allow its users to disable old protocols like SSLv1 and SSLv2 that are unsafe due to various known attacks like BEAST and POODLE. https://bugzilla.cyrusimap.org/show_bug.cgi?id=3867 remedies this issue by adding the configuration option 'tls_versions' to the imapd.conf file. Note that users who upgrade existing installation of this package will not have their imapd.conf file overwritten, i.e. their IMAP server will continue to support SSLv1 and SSLv2 like before. To disable support for those protocols, it's necessary to edit imapd.conf manually to state 'tls_versions: tls1_0 tls1_1 tls1_2'. New installations, however, will have an imapd.conf file that contains these settings already, i.e. newly installed IMAP servers do not support SSLv1 and SSLv2 unless that support is explicitly enabled by the user. (bsc#901748)

  • An integer overflow vulnerability in cyrus-imapd's urlfetch range checking code was fixed. (CVE-2015-8076, CVE-2015-8077, CVE-2015-8078, bsc#981670, bsc#954200, bsc#954201)

  • Support for Elliptic Curve Diffie–Hellman (ECDH) has been added to cyrus-imapd. (bsc#860611)

Record
SUSE-SU-2016:1457-1
Updated
2026-11-02
OSVSUSE-SU-2016:1459-1 No score

Security update for cyrus-imapd

This update for cyrus-imapd fixes the following issues:

  • Previous versions of cyrus-imapd would not allow its users to disable old SSL variants that are vulnerable to attacks like BEAST and POODLE. This patch adds the configuration option 'tls_versions' to remedy that issue. Note that users who upgrade an existing installation will not have their imapd.conf file overwritten, i.e. their IMAP server will continue to support SSLv2 and SSLv3 like before. To disable support for those protocols, edit imapd.conf manually to include 'tls_versions: tls1_0 tls1_1 tls1_2'. New installations, however, will have an imapd.conf file that contains these settings already, i.e. newly installed IMAP servers do not support unsafe versions of SSL unless that support is explicitly enabled by the user. (bsc#901748)

  • An integer overflow vulnerability in cyrus-imapd's urlfetch range checking code was fixed. (CVE-2015-8076, CVE-2015-8077, CVE-2015-8078, bsc#981670, bsc#954200, bsc#954201)

  • Support for Elliptic Curve Diffie–Hellman (ECDH) has been added to cyrus-imapd. (bsc#860611)

Record
SUSE-SU-2016:1459-1
Updated
2026-11-02
OSVUBUNTU-CVE-2015-8077 No score

Integer overflow in the index_urlfetch function in imap/index.c in Cyrus IMAP 2.3.19, 2.4.18, and 2.5.6 allows remote attackers to have unspecified impact via vectors related to urlfetch range checks and the start_octet variable. NOTE: this vulnerability exists because of an incomplete fix for CVE-2015-8076.

Record
UBUNTU-CVE-2015-8077
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
cyrus-imapd
Mageia:5
From an advisory covering 2 CVEs
before 2.4.18-1.2.mga5
2.4.18-1.2.mga5
cyrus-imapd
SUSE:Linux Enterprise Server 12
From an advisory covering 4 CVEs
before 2.3.18-37.1
2.3.18-37.1
cyrus-imapd
SUSE:Linux Enterprise Server for SAP Applications 12
From an advisory covering 4 CVEs
before 2.3.18-37.1
2.3.18-37.1
cyrus-imapd
SUSE:Linux Enterprise Server 12 SP1
From an advisory covering 4 CVEs
before 2.3.18-37.1
2.3.18-37.1
cyrus-imapd
SUSE:Linux Enterprise Server for SAP Applications 12 SP1
From an advisory covering 4 CVEs
before 2.3.18-37.1
2.3.18-37.1
cyrus-imapd
SUSE:Linux Enterprise Software Development Kit 11 SP4
From an advisory covering 4 CVEs
before 2.3.11-60.65.67.1
2.3.11-60.65.67.1
cyrus-imapd
SUSE:Linux Enterprise Server 11 SP4
From an advisory covering 4 CVEs
before 2.3.11-60.65.67.1
2.3.11-60.65.67.1
cyrus-imapd
SUSE:Linux Enterprise Server for SAP Applications 11 SP4
From an advisory covering 4 CVEs
before 2.3.11-60.65.67.1
2.3.11-60.65.67.1
cyrus-imapd-2.4
Ubuntu:16.04:LTS
All versions, plus listed versions
2.4.17+caldav~beta10-182.4.17+nocaldav-22.4.18-3
None known
cyrus-imapd
openSUSE:Tumbleweed
From an advisory covering 4 CVEs
before 2.4.18-3.4
2.4.18-3.4

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2015-8077 is a high vulnerability (CVSS 7.5) in Cyrus Imap, published December 3, 2015. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.26%, the 88th percentile. No source names a fixed version.

References

Show 23 moreShow less
MoveEnter Open