Every CVE Search/ Get API key

CVE-2015-8107

Format string vulnerability in GNU a2ps 4.14 allows remote attackers to execute arbitrary code.

7.8 HighFix available

Format string vulnerability in GNU a2ps 4.14 allows remote attackers to execute arbitrary code.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

2.77%Up 1.0 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.8

Format string vulnerability in GNU a2ps 4.14 allows remote attackers to execute arbitrary code.

Record
CVE-2015-8107
CVSS 3.0
7.8 HighCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Weakness
CWE-134
Updated
2026-11-02
CVE List No score

Format string vulnerability in GNU a2ps 4.14 allows remote attackers to execute arbitrary code.

Record
CVE-2015-8107
Updated
2026-11-02
EUVDEUVD-2015-7999 No score

Format string vulnerability in GNU a2ps 4.14 allows remote attackers to execute arbitrary code.

Record
EUVD-2015-7999
Updated
2026-11-03
GitHub AdvisoriesGHSA-3qwx-fr6j-m6r7 7.8

Format string vulnerability in GNU a2ps 4.14 allows remote attackers to execute arbitrary code.

Format string vulnerability in GNU a2ps 4.14 allows remote attackers to execute arbitrary code.

Record
GHSA-3qwx-fr6j-m6r7
CVSS 3.0
7.8 HighCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-134
Updated
2026-11-02
OSV 7.8

Format string vulnerability in GNU a2ps 4.14 allows remote attackers to execute arbitrary code.

Record
CVE-2015-8107
CVSS 3.0
7.8 HighCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2015-8107 7.8

Format string vulnerability in GNU a2ps 4.14 allows remote attackers to execute arbitrary code.

Record
DEBIAN-CVE-2015-8107
CVSS 3.0
7.8 HighCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2015-8107 7.8

Format string vulnerability in GNU a2ps 4.14 allows remote attackers to execute arbitrary code.

Record
UBUNTU-CVE-2015-8107
CVSS 3.0
7.8 HighCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
a2ps
Debian:12
before 1:4.14-1.2
1:4.14-1.2
a2ps
Debian:13
before 1:4.14-1.2
1:4.14-1.2
a2ps
Debian:14
before 1:4.14-1.2
1:4.14-1.2

History

History
RecordedChangedSources
affected
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2015-8107 is a high vulnerability (CVSS 7.8) in Gnu A2ps, published April 13, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.77%, the 86th percentile. Fixed in a2ps 1:4.14-1.2.

References

MoveEnter Open