Every CVE Search/ Get API key

CVE-2015-8875

Multiple integer overflows in the (1) pixops_composite_nearest, (2)...

7.8 HighFix available

Multiple integer overflows in the (1) pixops_composite_nearest, (2) pixops_composite_color_nearest, and (3) pixops_process functions in pixops/pixops.c in gdk-pixbuf before 2.33.1 allow remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a crafted image, which triggers a heap-based buffer overflow.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

2.77%Down 1.1 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.8

Multiple integer overflows in the (1) pixops_composite_nearest, (2) pixops_composite_color_nearest, and (3) pixops_process functions in pixops/pixops.c in gdk-pixbuf before 2.33.1 allow remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a crafted image, which triggers a heap-based buffer overflow.

Record
CVE-2015-8875
CVSS 3.0
7.8 HighCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Weakness
CWE-189
Updated
2026-11-02
CVE List No score

Multiple integer overflows in the (1) pixops_composite_nearest, (2) pixops_composite_color_nearest, and (3) pixops_process functions in pixops/pixops.c in gdk-pixbuf before 2.33.1 allow remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a crafted image, which triggers a heap-based buffer overflow.

Record
CVE-2015-8875
Updated
2026-11-02
EUVDEUVD-2015-8731 No score

Multiple integer overflows in the (1) pixops_composite_nearest, (2) pixops_composite_color_nearest, and (3) pixops_process functions in pixops/pixops.c in gdk-pixbuf before 2.33.1 allow remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a crafted image, which triggers a heap-based buffer overflow.

Record
EUVD-2015-8731
Updated
2026-11-03
GitHub AdvisoriesGHSA-vvxc-jgjh-cjf4 7.8

Multiple integer overflows in the (1) pixops_composite_nearest, (2)...

Multiple integer overflows in the (1) pixops_composite_nearest, (2) pixops_composite_color_nearest, and (3) pixops_process functions in pixops/pixops.c in gdk-pixbuf before 2.33.1 allow remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a crafted image, which triggers a heap-based buffer overflow.

Record
GHSA-vvxc-jgjh-cjf4
CVSS 3.0
7.8 HighCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSV 7.8

Multiple integer overflows in the (1) pixops_composite_nearest, (2) pixops_composite_color_nearest, and (3) pixops_process functions in pixops/pixops.c in gdk-pixbuf before 2.33.1 allow remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a crafted image, which triggers a heap-based buffer overflow.

Record
CVE-2015-8875
CVSS 3.0
7.8 HighCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2015-8875 7.8

Multiple integer overflows in the (1) pixops_composite_nearest, (2) pixops_composite_color_nearest, and (3) pixops_process functions in pixops/pixops.c in gdk-pixbuf before 2.33.1 allow remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a crafted image, which triggers a heap-based buffer overflow.

Record
DEBIAN-CVE-2015-8875
CVSS 3.0
7.8 HighCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2015-8875 7.8

Multiple integer overflows in the (1) pixops_composite_nearest, (2) pixops_composite_color_nearest, and (3) pixops_process functions in pixops/pixops.c in gdk-pixbuf before 2.33.1 allow remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a crafted image, which triggers a heap-based buffer overflow.

Record
UBUNTU-CVE-2015-8875
CVSS 3.0
7.8 HighCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVMGASA-2016-0192 No score

Updated gdk-pixbuf2.0 packages fix security vulnerability

The gdk-pixbuf2.0 library is vulnerable to overflows in the pixops_composite_nearest(), pixops_composite_color_nearest() and pixops_process() functions in pixops/pixops.c (CVE-2015-8875).

Record
MGASA-2016-0192
Updated
2026-11-02
OSVUSN-3085-1 No score

gdk-pixbuf vulnerabilities

It was discovered that the GDK-PixBuf library did not properly handle specially crafted bmp images, leading to a heap-based buffer overflow. If a user or automated system were tricked into opening a specially crafted bmp file, a remote attacker could use this flaw to cause GDK-PixBuf to crash, resulting in a denial of service, or possibly execute arbitrary code. This issue only affected Ubuntu 12.04 LTS and Ubuntu 14.04 LTS. (CVE-2015-7552)

It was discovered that the GDK-PixBuf library contained an integer overflow when handling certain images. If a user or automated system were tricked into opening a crafted image file, a remote attacker could use this flaw to cause GDK-PixBuf to crash, resulting in a denial of service, or possibly execute arbitrary code. This issue only affected Ubuntu 12.04 LTS and Ubuntu 14.04 LTS. (CVE-2015-8875)

Franco Costantini discovered that the GDK-PixBuf library contained an out-of-bounds write error when parsing an ico file. If a user or automated system were tricked into opening a crafted ico file, a remote attacker could use this flaw to cause GDK-PixBuf to crash, resulting in a denial of service. This issue only affected Ubuntu 14.04 LTS and Ubuntu 16.04 LTS. (CVE-2016-6352)

Record
USN-3085-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
gdk-pixbuf
Debian:12
before 2.34.0-1
2.34.0-1
gdk-pixbuf
Debian:13
before 2.34.0-1
2.34.0-1
gdk-pixbuf
Debian:14
before 2.34.0-1
2.34.0-1
gdk-pixbuf
Debian:7
before 2.26.1-1+deb7u4, plus listed versions
2.26.1-12.26.1-1+deb7u12.26.1-1+deb7u22.26.1-1+deb7u3
2.26.1-1+deb7u4
gdk-pixbuf
Debian:8
before 2.31.1-2+deb8u5, plus listed versions
2.31.1-22.31.1-2+deb8u12.31.1-2+deb8u22.31.1-2+deb8u32.31.1-2+deb8u42.31.1-2+deb8u4+kbsd8u1
2.31.1-2+deb8u5
gdk-pixbuf2.0
Mageia:5
before 2.32.1-1.1.mga5
2.32.1-1.1.mga5
gdk-pixbuf
Ubuntu:14.04:LTS
before 2.30.7-0ubuntu1.6, plus listed versions
2.28.1-1ubuntu22.30.0-0ubuntu22.30.1-0ubuntu22.30.2-0ubuntu12.30.2-0ubuntu2
Show 7 moreShow less
2.30.3-0ubuntu12.30.4-0ubuntu12.30.5-0ubuntu12.30.6-12.30.7-0ubuntu12.30.7-0ubuntu1.12.30.7-0ubuntu1.2
2.30.7-0ubuntu1.6
gdk-pixbuf
Ubuntu:16.04:LTS
before 2.32.2-1ubuntu1.2, plus listed versions
2.32.1-12.32.2-12.32.2-1ubuntu1
2.32.2-1ubuntu1.2

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2015-8875 is a high vulnerability (CVSS 7.8) in Gnome Gdk-pixbuf, published April 30, 2016. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.77%, the 86th percentile. Fixed in gdk-pixbuf 2.34.0-1.

References

Show 10 moreShow less
MoveEnter Open