Every CVE Search/ Get API key

CVE-2015-8929

Memory leak in the __archive_read_get_extract function in archive_read_extract2.c in libarchive...

5.5 MediumFix available

Memory leak in the __archive_read_get_extract function in archive_read_extract2.c in libarchive before 3.2.0 allows remote attackers to cause a denial of service via a tar file.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

1.54%Up 0.2 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.5

Memory leak in the __archive_read_get_extract function in archive_read_extract2.c in libarchive before 3.2.0 allows remote attackers to cause a denial of service via a tar file.

Record
CVE-2015-8929
CVSS 3.0
5.5 MediumCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:N/A:P
Weakness
CWE-119
Updated
2026-11-02
CVE List No score

Memory leak in the __archive_read_get_extract function in archive_read_extract2.c in libarchive before 3.2.0 allows remote attackers to cause a denial of service via a tar file.

Record
CVE-2015-8929
Updated
2026-11-02
EUVDEUVD-2015-8785 No score

Memory leak in the __archive_read_get_extract function in archive_read_extract2.c in libarchive before 3.2.0 allows remote attackers to cause a denial of service via a tar file.

Record
EUVD-2015-8785
Updated
2026-11-03
GitHub AdvisoriesGHSA-24gg-vmf8-whvm 5.5

Memory leak in the __archive_read_get_extract function in archive_read_extract2.c in libarchive...

Memory leak in the __archive_read_get_extract function in archive_read_extract2.c in libarchive before 3.2.0 allows remote attackers to cause a denial of service via a tar file.

Record
GHSA-24gg-vmf8-whvm
CVSS 3.0
5.5 MediumCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Weakness
CWE-119
Updated
2026-11-02
OSV 5.5

Memory leak in the __archive_read_get_extract function in archive_read_extract2.c in libarchive before 3.2.0 allows remote attackers to cause a denial of service via a tar file.

Record
CVE-2015-8929
CVSS 3.0
5.5 MediumCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2015-8929 5.5

Memory leak in the __archive_read_get_extract function in archive_read_extract2.c in libarchive before 3.2.0 allows remote attackers to cause a denial of service via a tar file.

Record
DEBIAN-CVE-2015-8929
CVSS 3.0
5.5 MediumCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2015-8929 5.5

Memory leak in the __archive_read_get_extract function in archive_read_extract2.c in libarchive before 3.2.0 allows remote attackers to cause a denial of service via a tar file.

Record
UBUNTU-CVE-2015-8929
CVSS 3.0
5.5 MediumCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVSUSE-SU-2016:1909-1 No score

Security update for libarchive

libarchive was updated to fix 20 security issues.

These security issues were fixed:

  • CVE-2015-8918: Overlapping memcpy in CAB parser (bsc#985698).
  • CVE-2015-8919: Heap out of bounds read in LHA/LZH parser (bsc#985697).
  • CVE-2015-8920: Stack out of bounds read in ar parser (bsc#985675).
  • CVE-2015-8921: Global out of bounds read in mtree parser (bsc#985682).
  • CVE-2015-8922: Null pointer access in 7z parser (bsc#985685).
  • CVE-2015-8923: Unclear crashes in ZIP parser (bsc#985703).
  • CVE-2015-8924: Heap buffer read overflow in tar (bsc#985609).
  • CVE-2015-8925: Unclear invalid memory read in mtree parser (bsc#985706).
  • CVE-2015-8926: NULL pointer access in RAR parser (bsc#985704).
  • CVE-2015-8928: Heap out of bounds read in mtree parser (bsc#985679).
  • CVE-2015-8929: Memory leak in tar parser (bsc#985669).
  • CVE-2015-8930: Endless loop in ISO parser (bsc#985700).
  • CVE-2015-8931: Undefined behavior / signed integer overflow in mtree parser (bsc#985689).
  • CVE-2015-8932: Compress handler left shifting larger than int size (bsc#985665).
  • CVE-2015-8933: Undefined behavior / signed integer overflow in TAR parser (bsc#985688).
  • CVE-2015-8934: Out of bounds read in RAR (bsc#985673).
  • CVE-2016-4300: Heap buffer overflow vulnerability in the 7zip read_SubStreamsInfo (bsc#985832).
  • CVE-2016-4301: Stack buffer overflow in the mtree parse_device (bsc#985826).
  • CVE-2016-4302: Heap buffer overflow in the Rar decompression functionality (bsc#985835).
  • CVE-2016-4809: Memory allocate error with symbolic links in cpio archives (bsc#984990).
Record
SUSE-SU-2016:1909-1
Updated
2026-11-02
OSVSUSE-SU-2016:1939-1 No score

Security update for bsdtar

bsdtar was updated to fix seven security issues.

These security issues were fixed:

  • CVE-2015-8929: Memory leak in tar parser (bsc#985669).
  • CVE-2016-4809: Memory allocate error with symbolic links in cpio archives (bsc#984990).
  • CVE-2015-8920: Stack out of bounds read in ar parser (bsc#985675).
  • CVE-2015-8921: Global out of bounds read in mtree parser (bsc#985682).
  • CVE-2015-8924: Heap buffer read overflow in tar (bsc#985609).
  • CVE-2015-8918: Overlapping memcpy in CAB parser (bsc#985698).
  • CVE-2015-2304: Reject absolute paths in input mode of bsdcpio exactly when '..' is rejected (bsc#920870).
Record
SUSE-SU-2016:1939-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
libarchive
Debian:12
before 3.2.0-2
3.2.0-2
libarchive
Debian:13
before 3.2.0-2
3.2.0-2
libarchive
Debian:14
before 3.2.0-2
3.2.0-2
libarchive
SUSE:Linux Enterprise Desktop 12 SP1
before 3.1.2-22.1
3.1.2-22.1
libarchive
SUSE:Linux Enterprise Software Development Kit 12 SP1
before 3.1.2-22.1
3.1.2-22.1
libarchive
SUSE:Linux Enterprise Server 12 SP1
before 3.1.2-22.1
3.1.2-22.1
libarchive
SUSE:Linux Enterprise Server for SAP Applications 12 SP1
before 3.1.2-22.1
3.1.2-22.1
bsdtar
SUSE:Linux Enterprise Software Development Kit 11 SP4
before 2.5.5-9.1
2.5.5-9.1
bsdtar
SUSE:OpenStack Cloud 5
before 2.5.5-9.1
2.5.5-9.1
bsdtar
SUSE:Manager 2.1
before 2.5.5-9.1
2.5.5-9.1
Show 8 moreShow less
Affected packages
PackageAffectedFixed
bsdtar
SUSE:Manager Proxy 2.1
before 2.5.5-9.1
2.5.5-9.1
bsdtar
SUSE:Linux Enterprise Point of Sale 11 SP3
before 2.5.5-9.1
2.5.5-9.1
bsdtar
SUSE:Linux Enterprise Server 11 SP2-LTSS
before 2.5.5-9.1
2.5.5-9.1
bsdtar
SUSE:Linux Enterprise Server 11 SP3-LTSS
before 2.5.5-9.1
2.5.5-9.1
bsdtar
SUSE:Linux Enterprise Server 11 SP3-TERADATA
before 2.5.5-9.1
2.5.5-9.1
bsdtar
SUSE:Linux Enterprise Server 11 SP4
before 2.5.5-9.1
2.5.5-9.1
bsdtar
SUSE:Linux Enterprise Server for SAP Applications 11 SP4
before 2.5.5-9.1
2.5.5-9.1
bsdtar
SUSE:Studio Onsite 1.3
before 2.5.5-9.1
2.5.5-9.1

History

History
RecordedChangedSources
affected
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2015-8929 is a medium vulnerability (CVSS 5.5) in Libarchive, published July 29, 2016. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.54%, the 74th percentile. Fixed in libarchive 3.2.0-2.

References

Show 50 moreShow less
MoveEnter Open