Every CVE Search/ Get API key

CVE-2016-9584

libical allows remote attackers to cause a denial of service (use-after-free) and possibly read...

9.1 CriticalFix available

libical allows remote attackers to cause a denial of service (use-after-free) and possibly read heap memory via a crafted ics file.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
None
Availability
High

Exploit likelihood

2.32%Up 1.3 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 9.1

libical allows remote attackers to cause a denial of service (use-after-free) and possibly read heap memory via a crafted ics file.

Record
CVE-2016-9584
CVSS 3.0
9.1 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H
CVSS 2.0
6.4 MediumAV:N/AC:L/Au:N/C:P/I:N/A:P
Weakness
CWE-416
Updated
2026-11-02
CVE List No score

libical allows remote attackers to cause a denial of service (use-after-free) and possibly read heap memory via a crafted ics file.

Record
CVE-2016-9584
Updated
2026-11-02
EUVDEUVD-2016-10390 No score

libical allows remote attackers to cause a denial of service (use-after-free) and possibly read heap memory via a crafted ics file.

Record
EUVD-2016-10390
Updated
2026-11-03
GitHub AdvisoriesGHSA-hcxq-m379-hxr9 9.1

libical allows remote attackers to cause a denial of service (use-after-free) and possibly read...

libical allows remote attackers to cause a denial of service (use-after-free) and possibly read heap memory via a crafted ics file.

Record
GHSA-hcxq-m379-hxr9
CVSS 3.0
9.1 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H
Weakness
CWE-416
Updated
2026-11-02
OSV 9.1

libical allows remote attackers to cause a denial of service (use-after-free) and possibly read heap memory via a crafted ics file.

Record
CVE-2016-9584
CVSS 3.0
9.1 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2016-9584 9.1

libical allows remote attackers to cause a denial of service (use-after-free) and possibly read heap memory via a crafted ics file.

Record
DEBIAN-CVE-2016-9584
CVSS 3.0
9.1 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H
Updated
2026-11-02
Show 5 moreShow less
OSVUBUNTU-CVE-2016-9584 9.1

libical allows remote attackers to cause a denial of service (use-after-free) and possibly read heap memory via a crafted ics file.

Record
UBUNTU-CVE-2016-9584
CVSS 3.0
9.1 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H
Updated
2026-11-02
OSVMGASA-2018-0021 No score

Updated libical packages fix security vulnerability

libical 1.0 allows remote attackers to cause a denial of service (use-after-free) via a crafted ics file (CVE-2016-5824).

The icaltime_from_string function in libical 0.47 and 1.0 allows remote attackers to cause a denial of service (out-of-bounds heap read) via a crafted string to the icalparser_parse_string function (CVE-2016-5827).

libical allows remote attackers to cause a denial of service (use-after-free) and possibly read heap memory via a crafted ics file (CVE-2016-9584).

Record
MGASA-2018-0021
Updated
2026-11-02
OSVopenSUSE-SU-2024:10947-1 No score

libical-devel-3.0.10-1.4 on GA media

These are all security issues fixed in the libical-devel-3.0.10-1.4 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10947-1
Updated
2026-11-02
OSVSUSE-SU-2017:1989-1 No score

Security update for libical

This update for libical fixes the following issues:

Security issues fixed:

  • CVE-2016-5824: libical 1.0 allows remote attackers to cause a denial of service (use-after-free) via a crafted ics file. (bsc#986639)
  • CVE-2016-5827: The icaltime_from_string function in libical 0.47 and 1.0 allows remote attackers to cause a denial of service (out-of-bounds heap read) via a crafted string to the icalparser_parse_string function. (bsc#986631)
  • CVE-2016-9584: libical allows remote attackers to cause a denial of service (use-after-free) and possibly read heap memory via a crafted ics file. (bsc#1015964)

Bug fixes:

  • libical crashes while parsing timezones (bsc#1044995)
Record
SUSE-SU-2017:1989-1
Updated
2026-11-02
OSVSUSE-SU-2018:0119-1 No score

Recommended update for libical

This update for libical fixes the following issues:

Security issues fixed:

  • CVE-2016-5823: The icalproperty_new_clone function in libical 0.47 and 1.0 allows remote attackers to cause a denial of service (use-after-free) via a crafted ics file. (bnc#986632)
  • CVE-2016-5824: libical 1.0 allows remote attackers to cause a denial of service (use-after-free) via a crafted ics file. (bsc#986639)
  • CVE-2016-5825: The icalparser_parse_string function in libical 0.47 and 1.0 allows remote attackers to cause a denial of service (out-of-bounds heap read) via a crafted ics file. (bsc#986642)
  • CVE-2016-5826: The parser_get_next_char function in libical 0.47 and 1.0 allows remote attackers to cause a denial of service (out-of-bounds heap read) by crafting a string to the icalparser_parse_string function. (bsc#986658)
  • CVE-2016-5827: The icaltime_from_string function in libical 0.47 and 1.0 allows remote attackers to cause a denial of service (out-of-bounds heap read) via a crafted string to the icalparser_parse_string function. (bsc#986631)
  • CVE-2016-9584: libical allows remote attackers to cause a denial of service (use-after-free) and possibly read heap memory via a crafted ics file. (bnc#1015964)

Bug fixes:

  • libical crashes while parsing timezones (bsc#1044995)
Record
SUSE-SU-2018:0119-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
libical3
Debian:12
before 3.0.1-1
3.0.1-1
libical3
Debian:13
before 3.0.1-1
3.0.1-1
libical3
Debian:14
before 3.0.1-1
3.0.1-1
libical
Debian:7
before 0.48-2+deb7u1, plus listed versions
0.48-2
0.48-2+deb7u1
libical
Mageia:5
before 1.0-4.1.mga5
1.0-4.1.mga5
libical
Mageia:6
before 2.0.0-2.1.mga6
2.0.0-2.1.mga6
libical
SUSE:Linux Enterprise Desktop 12 SP2
before 1.0.1-16.3.1
1.0.1-16.3.1
libical
SUSE:Linux Enterprise Desktop 12 SP3
before 1.0.1-16.3.1
1.0.1-16.3.1
libical
SUSE:Linux Enterprise Server for Raspberry Pi 12 SP2
before 1.0.1-16.3.1
1.0.1-16.3.1
libical
SUSE:Linux Enterprise Software Development Kit 12 SP2
before 1.0.1-16.3.1
1.0.1-16.3.1
Show 10 moreShow less
Affected packages
PackageAffectedFixed
libical
SUSE:Linux Enterprise Software Development Kit 12 SP3
before 1.0.1-16.3.1
1.0.1-16.3.1
libical
SUSE:Linux Enterprise Server 12 SP2
before 1.0.1-16.3.1
1.0.1-16.3.1
libical
SUSE:Linux Enterprise Server for SAP Applications 12 SP2
before 1.0.1-16.3.1
1.0.1-16.3.1
libical
SUSE:Linux Enterprise Server 12 SP3
before 1.0.1-16.3.1
1.0.1-16.3.1
libical
SUSE:Linux Enterprise Server for SAP Applications 12 SP3
before 1.0.1-16.3.1
1.0.1-16.3.1
libical
SUSE:Linux Enterprise Software Development Kit 11 SP4
before 0.43-1.10.6.1
0.43-1.10.6.1
libical
SUSE:Linux Enterprise Server 11 SP4
before 0.43-1.10.6.1
0.43-1.10.6.1
libical
SUSE:Linux Enterprise Server for SAP Applications 11 SP4
before 0.43-1.10.6.1
0.43-1.10.6.1
libical
Ubuntu:16.04:LTS
All versions, plus listed versions
1.0.1-0ubuntu11.0.1-0ubuntu2
None known
libical
Ubuntu:18.04:LTS
All versions, plus listed versions
2.0.0-0.52.0.0-0.5build12.0.0-1ubuntu12.0.0-4
None known

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2016-9584 is a critical vulnerability (CVSS 9.1) in Libical Project Libical, published January 18, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.32%, the 83rd percentile. Fixed in libical3 3.0.1-1.

References

Show 19 moreShow less
MoveEnter Open