Every CVE Search/ Get API key

CVE-2016-9817

Xen through 4.7.x allows local ARM guest OS users to cause a denial of service (host crash) via...

6.5 MediumFix available

Xen through 4.7.x allows local ARM guest OS users to cause a denial of service (host crash) via vectors involving a (1) data or (2) prefetch abort with the ESR_EL2.EA bit set.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

0.46%Down 0.6 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 6.5

Xen through 4.7.x allows local ARM guest OS users to cause a denial of service (host crash) via vectors involving a (1) data or (2) prefetch abort with the ESR_EL2.EA bit set.

Record
CVE-2016-9817
CVSS 3.0
6.5 MediumCVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:C/C:N/I:N/A:H
CVSS 2.0
4.9 MediumAV:L/AC:L/Au:N/C:N/I:N/A:C
Weakness
CWE-284
Updated
2026-11-02
CVE List No score

Xen through 4.7.x allows local ARM guest OS users to cause a denial of service (host crash) via vectors involving a (1) data or (2) prefetch abort with the ESR_EL2.EA bit set.

Record
CVE-2016-9817
Updated
2026-11-02
EUVDEUVD-2016-10617 No score

Xen through 4.7.x allows local ARM guest OS users to cause a denial of service (host crash) via vectors involving a (1) data or (2) prefetch abort with the ESR_EL2.EA bit set.

Record
EUVD-2016-10617
Updated
2026-11-03
GitHub AdvisoriesGHSA-gx95-jg8g-jg8q 6.5

Xen through 4.7.x allows local ARM guest OS users to cause a denial of service (host crash) via...

Xen through 4.7.x allows local ARM guest OS users to cause a denial of service (host crash) via vectors involving a (1) data or (2) prefetch abort with the ESR_EL2.EA bit set.

Record
GHSA-gx95-jg8g-jg8q
CVSS 3.0
6.5 MediumCVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:C/C:N/I:N/A:H
Weakness
CWE-284
Updated
2026-11-02
OSVALPINE-CVE-2016-9817 6.5

Xen through 4.7.x allows local ARM guest OS users to cause a denial of service (host crash) via vectors involving a (1) data or (2) prefetch abort with the ESR_EL2.EA bit set.

Record
ALPINE-CVE-2016-9817
CVSS 3.0
6.5 MediumCVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:C/C:N/I:N/A:H
Updated
2026-11-02
OSV 6.5

Xen through 4.7.x allows local ARM guest OS users to cause a denial of service (host crash) via vectors involving a (1) data or (2) prefetch abort with the ESR_EL2.EA bit set.

Record
CVE-2016-9817
CVSS 3.0
6.5 MediumCVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:C/C:N/I:N/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2016-9817 6.5

Xen through 4.7.x allows local ARM guest OS users to cause a denial of service (host crash) via vectors involving a (1) data or (2) prefetch abort with the ESR_EL2.EA bit set.

Record
DEBIAN-CVE-2016-9817
CVSS 3.0
6.5 MediumCVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:C/C:N/I:N/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2016-9817 6.5

Xen through 4.7.x allows local ARM guest OS users to cause a denial of service (host crash) via vectors involving a (1) data or (2) prefetch abort with the ESR_EL2.EA bit set.

Record
UBUNTU-CVE-2016-9817
CVSS 3.0
6.5 MediumCVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:C/C:N/I:N/A:H
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
xen
Alpine:v3.10
before 4.7.1-r3
4.7.1-r3
xen
Alpine:v3.11
before 4.7.1-r3
4.7.1-r3
xen
Alpine:v3.12
before 4.7.1-r3
4.7.1-r3
xen
Alpine:v3.13
before 4.7.1-r3
4.7.1-r3
xen
Alpine:v3.14
before 4.7.1-r3
4.7.1-r3
xen
Alpine:v3.15
before 4.7.1-r3
4.7.1-r3
xen
Alpine:v3.16
before 4.7.1-r3
4.7.1-r3
xen
Alpine:v3.17
before 4.7.1-r3
4.7.1-r3
xen
Alpine:v3.18
before 4.7.1-r3
4.7.1-r3
xen
Alpine:v3.19
before 4.7.1-r3
4.7.1-r3
Show 17 moreShow less
Affected packages
PackageAffectedFixed
xen
Alpine:v3.20
before 4.7.1-r3
4.7.1-r3
xen
Alpine:v3.21
before 4.7.1-r3
4.7.1-r3
xen
Alpine:v3.22
before 4.7.1-r3
4.7.1-r3
xen
Alpine:v3.23
before 4.7.1-r3
4.7.1-r3
xen
Alpine:v3.24
before 4.7.1-r3
4.7.1-r3
xen
Alpine:v3.3
before 4.6.3-r4
4.6.3-r4
xen
Alpine:v3.4
before 4.6.3-r6
4.6.3-r6
xen
Alpine:v3.5
before 4.7.1-r3
4.7.1-r3
xen
Alpine:v3.6
before 4.7.1-r3
4.7.1-r3
xen
Alpine:v3.7
before 4.7.1-r3
4.7.1-r3
xen
Alpine:v3.8
before 4.7.1-r3
4.7.1-r3
xen
Alpine:v3.9
before 4.7.1-r3
4.7.1-r3
xen
Debian:12
before 4.8.0-1
4.8.0-1
xen
Debian:13
before 4.8.0-1
4.8.0-1
xen
Debian:14
before 4.8.0-1
4.8.0-1
xen
Ubuntu:14.04:LTS
before 4.4.2-0ubuntu0.14.04.9, plus listed versions
4.3.0-1ubuntu14.3.0-1ubuntu24.3.0-1ubuntu34.3.0-1ubuntu44.3.0-1ubuntu5
Show 18 moreShow less
4.4.0-0ubuntu34.4.0-0ubuntu44.4.0-0ubuntu54.4.0-0ubuntu5.14.4.0-0ubuntu5.24.4.1-0ubuntu0.14.04.14.4.1-0ubuntu0.14.04.24.4.1-0ubuntu0.14.04.34.4.1-0ubuntu0.14.04.44.4.1-0ubuntu0.14.04.54.4.1-0ubuntu0.14.04.64.4.2-0ubuntu0.14.04.14.4.2-0ubuntu0.14.04.24.4.2-0ubuntu0.14.04.34.4.2-0ubuntu0.14.04.44.4.2-0ubuntu0.14.04.54.4.2-0ubuntu0.14.04.64.4.2-0ubuntu0.14.04.7
4.4.2-0ubuntu0.14.04.9
xen
Ubuntu:16.04:LTS
before 4.6.0-1ubuntu4.3, plus listed versions
4.5.1-0ubuntu14.5.1-0ubuntu24.6.0-1ubuntu14.6.0-1ubuntu24.6.0-1ubuntu44.6.0-1ubuntu4.14.6.0-1ubuntu4.2
4.6.0-1ubuntu4.3

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2016-9817 is a medium vulnerability (CVSS 6.5) in Xen, published February 27, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.46%, the 40th percentile. Fixed in xen 4.7.1-r3.

References

Show 8 moreShow less
MoveEnter Open