Every CVE Search/ Get API key

CVE-2016-10109

Use-after-free vulnerability in pcsc-lite before 1.8.20 allows a remote attackers to cause denial...

7.5 HighFix available

Use-after-free vulnerability in pcsc-lite before 1.8.20 allows a remote attackers to cause denial of service (crash) via a command that uses "cardsList" after the handle has been released through the SCardReleaseContext function.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

4.04%Up 2.1 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

Use-after-free vulnerability in pcsc-lite before 1.8.20 allows a remote attackers to cause denial of service (crash) via a command that uses "cardsList" after the handle has been released through the SCardReleaseContext function.

Record
CVE-2016-10109
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:N/A:P
Weakness
CWE-416
Updated
2026-11-02
CVE List No score

Use-after-free vulnerability in pcsc-lite before 1.8.20 allows a remote attackers to cause denial of service (crash) via a command that uses "cardsList" after the handle has been released through the SCardReleaseContext function.

Record
CVE-2016-10109
Updated
2026-11-02
EUVDEUVD-2016-1300 No score

Use-after-free vulnerability in pcsc-lite before 1.8.20 allows a remote attackers to cause denial of service (crash) via a command that uses "cardsList" after the handle has been released through the SCardReleaseContext function.

Record
EUVD-2016-1300
Updated
2026-11-03
GitHub AdvisoriesGHSA-qx6j-79wm-v56c 7.5

Use-after-free vulnerability in pcsc-lite before 1.8.20 allows a remote attackers to cause denial...

Use-after-free vulnerability in pcsc-lite before 1.8.20 allows a remote attackers to cause denial of service (crash) via a command that uses "cardsList" after the handle has been released through the SCardReleaseContext function.

Record
GHSA-qx6j-79wm-v56c
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-416
Updated
2026-11-02
OSVBELL-CVE-2016-10109 7.5

CVE-2016-10109 does not affect BellSoft software

Record
BELL-CVE-2016-10109
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSV 7.5

Use-after-free vulnerability in pcsc-lite before 1.8.20 allows a remote attackers to cause denial of service (crash) via a command that uses "cardsList" after the handle has been released through the SCardReleaseContext function.

Record
CVE-2016-10109
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
Show 6 moreShow less
OSVDEBIAN-CVE-2016-10109 7.5

Use-after-free vulnerability in pcsc-lite before 1.8.20 allows a remote attackers to cause denial of service (crash) via a command that uses "cardsList" after the handle has been released through the SCardReleaseContext function.

Record
DEBIAN-CVE-2016-10109
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2016-10109 7.5

Use-after-free vulnerability in pcsc-lite before 1.8.20 allows a remote attackers to cause denial of service (crash) via a command that uses "cardsList" after the handle has been released through the SCardReleaseContext function.

Record
UBUNTU-CVE-2016-10109
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVMGASA-2017-0026 No score

Updated pcsc-lite packages fix security vulnerability

Once MSGRemoveContext is invoked (via SCARD_RELEASE_CONTEXT), cardsList is freed. A repeated invocation of SCARD_RELEASE_CONTEXT (with an empty context handle) results in a use-after-free followed by a double-free.

After MSGRemoveContext, invocation of SCardEstablishContext enable further use-after-free of cardsList in MSGCheckHandleAssociation, MSGRemoveContext, MSGAddHandle, MSGRemoveHandle.

To avoid this problem, destroy the list only when the client connection is terminated. (CVE-2016-10109)

Record
MGASA-2017-0026
Updated
2026-11-02
OSVopenSUSE-SU-2024:11155-1 No score

libpcsclite1-1.9.3-1.2 on GA media

These are all security issues fixed in the libpcsclite1-1.9.3-1.2 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:11155-1
Updated
2026-11-02
OSVSUSE-SU-2017:0286-1 No score

Security update for pcsc-lite

pcsc-lite was updated to fix one security issue.

This security issue was fixed:

  • CVE-2016-10109: This use-after-free and double-free issue allowed local attacker to cause a Denial of Service and possible privilege escalation (bsc#1017902).
Record
SUSE-SU-2017:0286-1
Updated
2026-11-02
OSVUSN-3176-1 No score

pcsc-lite vulnerability

Peter Wu discovered that the PC/SC service did not correctly handle certain resources. A local attacker could use this issue to cause PC/SC to crash, resulting in a denial of service, or possibly execute arbitrary code with root privileges.

Record
USN-3176-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
pcsc-lite
Debian:12
before 1.8.20-1
1.8.20-1
pcsc-lite
Debian:13
before 1.8.20-1
1.8.20-1
pcsc-lite
Debian:14
before 1.8.20-1
1.8.20-1
pcsc-lite
Debian:7
before 1.8.4-1+deb7u2, plus listed versions
1.8.4-11.8.4-1+deb7u1
1.8.4-1+deb7u2
pcsc-lite
Debian:8
before 1.8.13-1+deb8u1, plus listed versions
1.8.13-1
1.8.13-1+deb8u1
pcsc-lite
Mageia:5
before 1.8.11-4.1.mga5
1.8.11-4.1.mga5
pcsc-lite
SUSE:Linux Enterprise Desktop 12 SP2
before 1.8.10-6.1
1.8.10-6.1
pcsc-lite
SUSE:Linux Enterprise Server for Raspberry Pi 12 SP2
before 1.8.10-6.1
1.8.10-6.1
pcsc-lite
SUSE:Linux Enterprise Software Development Kit 12 SP2
before 1.8.10-6.1
1.8.10-6.1
pcsc-lite
SUSE:Linux Enterprise Server 12 SP1
before 1.8.10-6.1
1.8.10-6.1
Show 7 moreShow less
Affected packages
PackageAffectedFixed
pcsc-lite
SUSE:Linux Enterprise Server for SAP Applications 12 SP1
before 1.8.10-6.1
1.8.10-6.1
pcsc-lite
SUSE:Linux Enterprise Server 12 SP2
before 1.8.10-6.1
1.8.10-6.1
pcsc-lite
SUSE:Linux Enterprise Server for SAP Applications 12 SP2
before 1.8.10-6.1
1.8.10-6.1
pcsc-lite
SUSE:Linux Enterprise Workstation Extension 12 SP1
before 1.8.10-6.1
1.8.10-6.1
pcsc-lite
SUSE:Linux Enterprise Workstation Extension 12 SP2
before 1.8.10-6.1
1.8.10-6.1
pcsc-lite
Ubuntu:14.04:LTS
before 1.8.10-1ubuntu1.1, plus listed versions
1.8.6-3ubuntu1b11.8.6-3ubuntu21.8.10-1ubuntu1
1.8.10-1ubuntu1.1
pcsc-lite
Ubuntu:16.04:LTS
before 1.8.14-1ubuntu1.16.04.1, plus listed versions
1.8.14-1ubuntu1
1.8.14-1ubuntu1.16.04.1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2016-10109 is a high vulnerability (CVSS 7.5) in Muscle Pcsc-lite, published December 31, 2016. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 4.04%, the 90th percentile. Fixed in pcsc-lite 1.8.20-1.

References

Show 18 moreShow less
MoveEnter Open