Every CVE Search/ Get API key

CVE-2016-10714

In zsh before 5.3, an off-by-one error resulted in undersized buffers that were intended to...

9.8 CriticalFix available

In zsh before 5.3, an off-by-one error resulted in undersized buffers that were intended to support PATH_MAX characters.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

2.13%Up 1.2 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 9.8

In zsh before 5.3, an off-by-one error resulted in undersized buffers that were intended to support PATH_MAX characters.

Record
CVE-2016-10714
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-189
Updated
2026-11-02
CVE List No score

In zsh before 5.3, an off-by-one error resulted in undersized buffers that were intended to support PATH_MAX characters.

Record
CVE-2016-10714
Updated
2026-11-02
EUVDEUVD-2016-1713 No score

In zsh before 5.3, an off-by-one error resulted in undersized buffers that were intended to support PATH_MAX characters.

Record
EUVD-2016-1713
Updated
2026-11-03
GitHub AdvisoriesGHSA-86jf-f87h-wc84 9.8

In zsh before 5.3, an off-by-one error resulted in undersized buffers that were intended to...

In zsh before 5.3, an off-by-one error resulted in undersized buffers that were intended to support PATH_MAX characters.

Record
GHSA-86jf-f87h-wc84
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSV 9.8

In zsh before 5.3, an off-by-one error resulted in undersized buffers that were intended to support PATH_MAX characters.

Record
CVE-2016-10714
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2016-10714 9.8

In zsh before 5.3, an off-by-one error resulted in undersized buffers that were intended to support PATH_MAX characters.

Record
DEBIAN-CVE-2016-10714
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
Show 4 moreShow less
OSVUBUNTU-CVE-2016-10714 9.8

In zsh before 5.3, an off-by-one error resulted in undersized buffers that were intended to support PATH_MAX characters.

Record
UBUNTU-CVE-2016-10714
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVSUSE-SU-2018:1072-1 No score

Security update for zsh

This update for zsh fixes the following issues:

  • CVE-2014-10070: environment variable injection could lead to local privilege escalation (bnc#1082885)

  • CVE-2014-10071: buffer overflow in exec.c could lead to denial of service. (bnc#1082977)

  • CVE-2014-10072: buffer overflow In utils.c when scanning very long directory paths for symbolic links. (bnc#1082975)

  • CVE-2016-10714: In zsh before 5.3, an off-by-one error resulted in undersized buffers that were intended to support PATH_MAX characters. (bnc#1083250)

  • CVE-2017-18205: In builtin.c when sh compatibility mode is used, a NULL pointer dereference could lead to denial of service (bnc#1082998)

  • CVE-2018-1071: exec.c:hashcmd() function vulnerability could lead to denial of service. (bnc#1084656)

  • CVE-2018-1083: Autocomplete vulnerability could lead to privilege escalation. (bnc#1087026)

  • CVE-2018-7549: In params.c in zsh through 5.4.2, there is a crash during a copy of an empty hash table, as demonstrated by typeset -p. (bnc#1082991)

  • CVE-2017-18206: buffer overrun in xsymlinks could lead to denial of service (bnc#1083002)

  • Autocomplete and REPORTTIME broken (bsc#896914)

Record
SUSE-SU-2018:1072-1
Updated
2026-11-02
OSVSUSE-SU-2022:14910-1 No score

Security update for zsh

This update for zsh fixes the following issues:

  • CVE-2019-20044: Fixed an insecure dropping of privileges when unsetting the PRIVILEGED option (bsc#1163882).
  • CVE-2018-13259: Fixed an unexpected truncation of long shebang lines (bsc#1107294).
  • CVE-2018-7549: Fixed a crash when an empty hash table (bsc#1082991).
  • CVE-2018-1083: Fixed a stack-based buffer overflow when using tab completion on directories with long names (bsc#1087026).
  • CVE-2018-1071: Fixed a stack-based buffer overflow when executing certain commands (bsc#1084656).
  • CVE-2018-0502: Fixed a mishandling of shebang lines (bsc#1107296).
  • CVE-2017-18206: Fixed a buffer overflow related to symlink processing (bsc#1083002).
  • CVE-2017-18205: Fixed an application crash when using cd with no arguments (bsc#1082998).
  • CVE-2016-10714: Fixed a potential application crash when handling maximum length paths (bsc#1083250).
  • CVE-2014-10072: Fixed a buffer overflow when scanning very long directory paths for symbolic links (bsc#1082975).
  • CVE-2014-10071: Fixed a buffer overflow when redirecting output to a long file descriptor (bsc#1082977).
  • CVE-2014-10070: Fixed a privilege escalation vulnerability via environment variables (bsc#1082885).
Record
SUSE-SU-2022:14910-1
Updated
2026-11-02
OSVUSN-3593-1 No score

zsh vulnerabilities

It was discovered that Zsh incorrectly handled certain enviroment variables. An attacker could possibly use this issue to gain privileged access to the system. This issue only affected Ubuntu 14.04 LTS. (CVE-2014-10070)

It was discovered that Zsh incorrectly handled certain inputs. An attacker could possibly use this to execute arbitrary code. This issue only affected Ubuntu 14.04 LTS. (CVE-2014-10071)

It was discovered that Zsh incorrectly handled some symbolic links. An attacker could possibly use this to execute arbitrary code. This issue only affected Ubuntu 14.04 LTS. (CVE-2014-10072)

It was discovered that Zsh incorrectly handled certain errors. An attacker could possibly use this issue to cause a denial of service. (CVE-2016-10714)

It was discovered that Zsh incorrectly handled certain commands. An attacker could possibly use this to execute arbitrary code. (CVE-2017-18205)

It was discovered that Zsh incorrectly handled certain symlinks. An attacker could possibly use this to execute arbitrary code. This issue only affected Ubuntu 16.04 LTS and Ubuntu 17.10. (CVE-2017-18206)

It was discovered that Zsh incorrectly handled certain inputs. An attacker could possible use to execute arbitrary code. This issue only affected Ubuntu 17.10. (CVE-2018-7548)

It was discovered that Zsh incorrectly handled certain inputs. An attacker could possibly use this to cause a denial of service. (CVE-2018-7549)

Record
USN-3593-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
zsh
Debian:12
before 5.3-1
5.3-1
zsh
Debian:13
before 5.3-1
5.3-1
zsh
Debian:14
before 5.3-1
5.3-1
zsh
Debian:7
before 4.3.17-1+deb7u1, plus listed versions
4.3.17-1
4.3.17-1+deb7u1
zsh
SUSE:Linux Enterprise Desktop 12 SP3
before 5.0.5-6.7.2
5.0.5-6.7.2
zsh
SUSE:Linux Enterprise Server 12 SP3
before 5.0.5-6.7.2
5.0.5-6.7.2
zsh
SUSE:Linux Enterprise Server for SAP Applications 12 SP3
before 5.0.5-6.7.2
5.0.5-6.7.2
zsh
SUSE:Linux Enterprise Point of Sale 11 SP3
before 4.3.6-67.9.8.1
4.3.6-67.9.8.1
zsh
SUSE:Linux Enterprise Server 11 SP4-LTSS
before 4.3.6-67.9.8.1
4.3.6-67.9.8.1
zsh
Ubuntu:14.04:LTS
before 5.0.2-3ubuntu6.1, plus listed versions
5.0.2-3ubuntu6
5.0.2-3ubuntu6.1
zsh
Ubuntu:16.04:LTS
before 5.1.1-1ubuntu2.1, plus listed versions
5.1.1-1ubuntu15.1.1-1ubuntu2
5.1.1-1ubuntu2.1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2016-10714 is a critical vulnerability (CVSS 9.8) in Zsh, published February 27, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.13%, the 82nd percentile. Fixed in zsh 5.3-1.

References

Show 36 moreShow less
MoveEnter Open