CVE-2016-10743
hostapd before 2.6 does not prevent use of the low-quality PRNG that is reached by an os_random()...
hostapd before 2.6 does not prevent use of the low-quality PRNG that is reached by an os_random() function call.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- High
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
7.5
hostapd before 2.6 does not prevent use of the low-quality PRNG that is reached by an os_random() function call.
- Record
CVE-2016-10743- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N - CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:N/I:P/A:N - Weakness
- CWE-332
- Updated
- 2026-11-02
CVE List No score
hostapd before 2.6 does not prevent use of the low-quality PRNG that is reached by an os_random() function call.
- Record
CVE-2016-10743- Updated
- 2026-11-02
EUVDEUVD-2016-1740 No score
hostapd before 2.6 does not prevent use of the low-quality PRNG that is reached by an os_random() function call.
- Record
EUVD-2016-1740- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-9m94-6895-mgv3
7.5
hostapd before 2.6 does not prevent use of the low-quality PRNG that is reached by an os_random()...
hostapd before 2.6 does not prevent use of the low-quality PRNG that is reached by an os_random() function call.
- Record
GHSA-9m94-6895-mgv3- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N - Weakness
- CWE-332
- Updated
- 2026-11-02
OSV
7.5
hostapd before 2.6 does not prevent use of the low-quality PRNG that is reached by an os_random() function call.
- Record
CVE-2016-10743- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N - Updated
- 2026-11-02
OSVDEBIAN-CVE-2016-10743
7.5
hostapd before 2.6 does not prevent use of the low-quality PRNG that is reached by an os_random() function call.
- Record
DEBIAN-CVE-2016-10743- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N - Updated
- 2026-11-02
OSVUBUNTU-CVE-2016-10743
7.5
hostapd before 2.6 does not prevent use of the low-quality PRNG that is reached by an os_random() function call.
- Record
UBUNTU-CVE-2016-10743- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N - Updated
- 2026-11-02
OSVUSN-3944-1 No score
wpa vulnerabilities
It was discovered that wpa_supplicant and hostapd were vulnerable to a side channel attack against EAP-pwd. A remote attacker could possibly use this issue to recover certain passwords. (CVE-2019-9495)
Mathy Vanhoef discovered that wpa_supplicant and hostapd incorrectly validated received scalar and element values in EAP-pwd-Commit messages. A remote attacker could possibly use this issue to perform a reflection attack and authenticate without the appropriate password. (CVE-2019-9497, CVE-2019-9498, CVE-2019-9499)
It was discovered that hostapd incorrectly handled obtaining random numbers. In rare cases where the urandom device isn't available, it would fall back to using a low-quality PRNG. This issue only affected Ubuntu 14.04 LTS and Ubuntu 16.04 LTS. (CVE-2016-10743)
- Record
USN-3944-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
wpaDebian:12 |
before 2:2.6-7 | 2:2.6-7 |
wpaDebian:13 |
before 2:2.6-7 | 2:2.6-7 |
wpaDebian:14 |
before 2:2.6-7 | 2:2.6-7 |
wpaDebian:8 |
before 2.3-1+deb8u7, plus listed versions 2.3-12.3-1+deb8u12.3-1+deb8u22.3-1+deb8u32.3-1+deb8u42.3-1+deb8u52.3-1+deb8u6 |
2.3-1+deb8u7 |
wpaUbuntu:14.04:LTS |
before 2.1-0ubuntu1.7, plus listed versions 1.0-3ubuntu21.0-3ubuntu31.0-3ubuntu42.1-0ubuntu12.1-0ubuntu1.1 Show 5 moreShow less2.1-0ubuntu1.22.1-0ubuntu1.32.1-0ubuntu1.42.1-0ubuntu1.52.1-0ubuntu1.6 |
2.1-0ubuntu1.7 |
wpaUbuntu:16.04:LTS |
before 2.4-0ubuntu6.4, plus listed versions 2.4-0ubuntu32.4-0ubuntu42.4-0ubuntu52.4-0ubuntu62.4-0ubuntu6.22.4-0ubuntu6.3 |
2.4-0ubuntu6.4 |
wpaUbuntu:14.04:LTS From an advisory covering 5 CVEs |
before 2.1-0ubuntu1.7, plus listed versions 1.0-3ubuntu21.0-3ubuntu31.0-3ubuntu42.1-0ubuntu12.1-0ubuntu1.1 Show 5 moreShow less2.1-0ubuntu1.22.1-0ubuntu1.32.1-0ubuntu1.42.1-0ubuntu1.52.1-0ubuntu1.6 |
2.1-0ubuntu1.7 |
wpaUbuntu:16.04:LTS From an advisory covering 5 CVEs |
before 2.4-0ubuntu6.4, plus listed versions 2.4-0ubuntu32.4-0ubuntu42.4-0ubuntu52.4-0ubuntu62.4-0ubuntu6.22.4-0ubuntu6.3 |
2.4-0ubuntu6.4 |
wpaUbuntu:18.04:LTS From an advisory covering 5 CVEs |
before 2:2.6-15ubuntu2.2, plus listed versions 2.4-0ubuntu102:2.4-1.1ubuntu12:2.6-15ubuntu12:2.6-15ubuntu22:2.6-15ubuntu2.1 |
2:2.6-15ubuntu2.2 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2016-10743 is a high vulnerability (CVSS 7.5) in W1.fi Hostapd, published March 23, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.37%, the 83rd percentile. Fixed in wpa 2:2.6-7.
References
w1.fi/cgit/hostap/commit?id=98a516eae8260e6fd5c48ddecf8d006285da7389
lists.debian.org/debian-lts-announce/2019/03/msg00035.html
usn.ubuntu.com/3944-1
openwall.com/lists/oss-security/2020/02/27/1
openwall.com/lists/oss-security/2020/02/27/2
seclists.org/fulldisclosure/2020/Feb/26
Show 11 moreShow less
packetstormsecurity.com/files/156573/Hostapd-Insufficient-Entropy.html
nvd.nist.gov/vuln/detail/CVE-2016-10743
github.com/advisories/GHSA-9m94-6895-mgv3
security-tracker.debian.org/tracker/CVE-2016-10743
ubuntu.com/security/CVE-2016-10743
ubuntu.com/security/notices/USN-3944-1
cve.org/CVERecord?id=CVE-2016-10743
ubuntu.com/security/CVE-2019-9495
ubuntu.com/security/CVE-2019-9497
ubuntu.com/security/CVE-2019-9498
ubuntu.com/security/CVE-2019-9499