Every CVE Search/ Get API key

CVE-2016-2522

The dissect_ber_constrained_bitstring function in epan/dissectors/packet-ber.c in the ASN.1 BER...

5.9 MediumFix available

The dissect_ber_constrained_bitstring function in epan/dissectors/packet-ber.c in the ASN.1 BER dissector in Wireshark 2.0.x before 2.0.2 does not verify that a certain length is nonzero, which allows remote attackers to cause a denial of service (out-of-bounds read and application crash) via a crafted packet.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
High
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

2.08%Up 0.9 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.9

The dissect_ber_constrained_bitstring function in epan/dissectors/packet-ber.c in the ASN.1 BER dissector in Wireshark 2.0.x before 2.0.2 does not verify that a certain length is nonzero, which allows remote attackers to cause a denial of service (out-of-bounds read and application crash) via a crafted packet.

Record
CVE-2016-2522
CVSS 3.0
5.9 MediumCVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:N/A:P
Weakness
CWE-119
Updated
2026-11-02
CVE List No score

The dissect_ber_constrained_bitstring function in epan/dissectors/packet-ber.c in the ASN.1 BER dissector in Wireshark 2.0.x before 2.0.2 does not verify that a certain length is nonzero, which allows remote attackers to cause a denial of service (out-of-bounds read and application crash) via a crafted packet.

Record
CVE-2016-2522
Updated
2026-11-02
EUVDEUVD-2016-3600 No score

The dissect_ber_constrained_bitstring function in epan/dissectors/packet-ber.c in the ASN.1 BER dissector in Wireshark 2.0.x before 2.0.2 does not verify that a certain length is nonzero, which allows remote attackers to cause a denial of service (out-of-bounds read and application crash) via a crafted packet.

Record
EUVD-2016-3600
Updated
2026-11-03
GitHub AdvisoriesGHSA-2g5w-fjfx-gpv9 5.9

The dissect_ber_constrained_bitstring function in epan/dissectors/packet-ber.c in the ASN.1 BER...

The dissect_ber_constrained_bitstring function in epan/dissectors/packet-ber.c in the ASN.1 BER dissector in Wireshark 2.0.x before 2.0.2 does not verify that a certain length is nonzero, which allows remote attackers to cause a denial of service (out-of-bounds read and application crash) via a crafted packet.

Record
GHSA-2g5w-fjfx-gpv9
CVSS 3.0
5.9 MediumCVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-119
Updated
2026-11-02
OSV 5.9

The dissect_ber_constrained_bitstring function in epan/dissectors/packet-ber.c in the ASN.1 BER dissector in Wireshark 2.0.x before 2.0.2 does not verify that a certain length is nonzero, which allows remote attackers to cause a denial of service (out-of-bounds read and application crash) via a crafted packet.

Record
CVE-2016-2522
CVSS 3.0
5.9 MediumCVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2016-2522 5.9

The dissect_ber_constrained_bitstring function in epan/dissectors/packet-ber.c in the ASN.1 BER dissector in Wireshark 2.0.x before 2.0.2 does not verify that a certain length is nonzero, which allows remote attackers to cause a denial of service (out-of-bounds read and application crash) via a crafted packet.

Record
DEBIAN-CVE-2016-2522
CVSS 3.0
5.9 MediumCVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2016-2522 5.9

The dissect_ber_constrained_bitstring function in epan/dissectors/packet-ber.c in the ASN.1 BER dissector in Wireshark 2.0.x before 2.0.2 does not verify that a certain length is nonzero, which allows remote attackers to cause a denial of service (out-of-bounds read and application crash) via a crafted packet.

Record
UBUNTU-CVE-2016-2522
CVSS 3.0
5.9 MediumCVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVMGASA-2016-0091 No score

Updated wireshark packages fix security vulnerabilities

Updated wireshark packages fix security vulnerabilities:

ASN.1 BER dissector crash (CVE-2016-2522).

DNP dissector infinite loop (CVE-2016-2523).

X.509AF dissector crash (CVE-2016-2524).

HTTP/2 dissector crash (CVE-2016-2525).

HiQnet dissector crash (CVE-2016-2526).

3GPP TS 32.423 Trace file parser crash (CVE-2016-2527).

LBMC dissector crash (CVE-2016-2528).

iSeries file parser crash (CVE-2016-2529).

RSL dissector crash (CVE-2016-2530, CVE-2016-2531).

LLRP dissector crash (CVE-2016-2532).

The wireshark package has been updated to version 2.0.2, fixing these issues as well as other dissector crashes, a dissector loop issue, another file parser crash, and several other bugs. See the upstream release notes for details.

Record
MGASA-2016-0091
Updated
2026-11-02
OSVopenSUSE-SU-2024:10199-1 No score

wireshark-2.2.2-1.1 on GA media

These are all security issues fixed in the wireshark-2.2.2-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10199-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
wireshark
Debian:12
before 2.0.2+ga16e22e-1
2.0.2+ga16e22e-1
wireshark
Debian:13
before 2.0.2+ga16e22e-1
2.0.2+ga16e22e-1
wireshark
Debian:14
before 2.0.2+ga16e22e-1
2.0.2+ga16e22e-1
wireshark
Mageia:5
before 2.0.2-1.mga5
2.0.2-1.mga5
wireshark
Ubuntu:14.04:LTS
before 2.6.3-1~ubuntu14.04.1, plus listed versions
1.10.2-11.10.3-11.10.5-1ubuntu11.10.5-21.10.6-11.12.1+g01b65bf-4+deb8u11ubuntu0.14.04.1
2.6.3-1~ubuntu14.04.1
wireshark
Ubuntu:16.04:LTS
before 2.6.3-1~ubuntu16.04.1, plus listed versions
1.12.7+g7fc8978-11.12.8+g5b6e543-22.0.1+g59ea380-3build12.0.2+ga16e22e-12.2.6+g32dac6a-2ubuntu0.16.04
2.6.3-1~ubuntu16.04.1
wireshark
Ubuntu:18.04:LTS
before 2.6.3-1~ubuntu18.04.1, plus listed versions
2.4.2-12.4.3-12.4.4-12.4.5-1
2.6.3-1~ubuntu18.04.1
wireshark
openSUSE:Tumbleweed
before 2.2.2-1.1
2.2.2-1.1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2016-2522 is a medium vulnerability (CVSS 5.9) in Wireshark, published February 28, 2016. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.08%, the 81st percentile. Fixed in wireshark 2.0.2+ga16e22e-1.

References

Show 194 moreShow less
This page doesn't list everything

Left out here: 93 references. The JSON record has them.

MoveEnter Open