CVE-2016-4561
Cross-site scripting (XSS) vulnerability in the cgierror function in CGI.pm in ikiwiki before 3...
Cross-site scripting (XSS) vulnerability in the cgierror function in CGI.pm in ikiwiki before 3.20160506 might allow remote attackers to inject arbitrary web script or HTML via unspecified vectors involving an error message.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
6.1
Cross-site scripting (XSS) vulnerability in the cgierror function in CGI.pm in ikiwiki before 3.20160506 might allow remote attackers to inject arbitrary web script or HTML via unspecified vectors involving an error message.
- Record
CVE-2016-4561- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
Cross-site scripting (XSS) vulnerability in the cgierror function in CGI.pm in ikiwiki before 3.20160506 might allow remote attackers to inject arbitrary web script or HTML via unspecified vectors involving an error message.
- Record
CVE-2016-4561- Updated
- 2026-11-02
EUVDEUVD-2016-5548 No score
Cross-site scripting (XSS) vulnerability in the cgierror function in CGI.pm in ikiwiki before 3.20160506 might allow remote attackers to inject arbitrary web script or HTML via unspecified vectors involving an error message.
- Record
EUVD-2016-5548- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-vxg6-rr45-x5cv
6.1
Cross-site scripting (XSS) vulnerability in the cgierror function in CGI.pm in ikiwiki before 3...
Cross-site scripting (XSS) vulnerability in the cgierror function in CGI.pm in ikiwiki before 3.20160506 might allow remote attackers to inject arbitrary web script or HTML via unspecified vectors involving an error message.
- Record
GHSA-vxg6-rr45-x5cv- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSV
6.1
Cross-site scripting (XSS) vulnerability in the cgierror function in CGI.pm in ikiwiki before 3.20160506 might allow remote attackers to inject arbitrary web script or HTML via unspecified vectors involving an error message.
- Record
CVE-2016-4561- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVDEBIAN-CVE-2016-4561
6.1
Cross-site scripting (XSS) vulnerability in the cgierror function in CGI.pm in ikiwiki before 3.20160506 might allow remote attackers to inject arbitrary web script or HTML via unspecified vectors involving an error message.
- Record
DEBIAN-CVE-2016-4561- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVUBUNTU-CVE-2016-4561
6.1
Cross-site scripting (XSS) vulnerability in the cgierror function in CGI.pm in ikiwiki before 3.20160506 might allow remote attackers to inject arbitrary web script or HTML via unspecified vectors involving an error message.
- Record
UBUNTU-CVE-2016-4561- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVMGASA-2019-0113 No score
Updated ikiwiki packages fix security vulnerability
Several security issues identified in ikiwiki fixed by updating to version 3.20190228. See references for details
- Record
MGASA-2019-0113- Updated
- 2026-11-02
OSVopenSUSE-SU-2024:10860-1 No score
ikiwiki-3.20200202.3-2.7 on GA media
These are all security issues fixed in the ikiwiki-3.20200202.3-2.7 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:10860-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
ikiwikiDebian:12 |
before 3.20160506 | 3.20160506 |
ikiwikiDebian:13 |
before 3.20160506 | 3.20160506 |
ikiwikiDebian:14 |
before 3.20160506 | 3.20160506 |
ikiwikiDebian:7 |
before 3.20120629.2+deb7u1, plus listed versions 3.201206293.20120629.13.20120629.2 |
3.20120629.2+deb7u1 |
ikiwikiDebian:8 |
before 3.20141016.3, plus listed versions 3.20141016.2 |
3.20141016.3 |
ikiwikiMageia:6 |
before 3.20190228-1.1.mga6 | 3.20190228-1.1.mga6 |
ikiwikiUbuntu:16.04:LTS |
All versions, plus listed versions 3.201506143.20160121 |
None known |
ikiwikiopenSUSE:Tumbleweed |
before 3.20200202.3-2.7 | 3.20200202.3-2.7 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2016-4561 is a medium vulnerability (CVSS 6.1) in Ikiwiki, published May 8, 2016. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.47%, the 73rd percentile. Fixed in ikiwiki 3.20160506.
References
source.ikiwiki.branchable.com?p=source.git%3Ba=commitdiff%3Bh=32ef584dc5abb6ddb9f794f94ea0b2934967bba7
debian.org/security/2016/dsa-3571
ikiwiki.info/security
nvd.nist.gov/vuln/detail/CVE-2016-4561
source.ikiwiki.branchable.com?p=source.git;a=commitdiff;h=32ef584dc5abb6ddb9f794f94ea0b2934967bba7
github.com/advisories/GHSA-vxg6-rr45-x5cv
Show 24 moreShow less
security-tracker.debian.org/tracker/CVE-2016-4561
advisories.mageia.org/MGASA-2019-0113.html
bugs.mageia.org/show_bug.cgi?id=24453
openwall.com/lists/oss-security/2019/02/28/1
openwall.com/lists/oss-security/2017/01/12/2
openwall.com/lists/oss-security/2016/05/06/8
openwall.com/lists/oss-security/2016/05/06/9
debian.org/security/2019/dsa-4399
ubuntu.com/security/CVE-2016-4561
cve.org/CVERecord?id=CVE-2016-4561
suse.com/security/cve/CVE-2008-0169
suse.com/security/cve/CVE-2009-2944
suse.com/security/cve/CVE-2011-0428
suse.com/security/cve/CVE-2011-1401
suse.com/security/cve/CVE-2012-0220
suse.com/security/cve/CVE-2014-1572
suse.com/security/cve/CVE-2016-10026
suse.com/security/cve/CVE-2016-1238
suse.com/security/cve/CVE-2016-3714
suse.com/security/cve/CVE-2016-4561
suse.com/security/cve/CVE-2016-9645
suse.com/security/cve/CVE-2016-9646
suse.com/security/cve/CVE-2017-0356
suse.com/security/cve/CVE-2019-9187