CVE-2016-4589
WebKit in Apple iOS before 9.3.3, Safari before 9.1.2, and tvOS before 9.2.2 allows remote...
WebKit in Apple iOS before 9.3.3, Safari before 9.1.2, and tvOS before 9.2.2 allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption) via a crafted web site, a different vulnerability than CVE-2016-4622, CVE-2016-4623, and CVE-2016-4624.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
8.8
WebKit in Apple iOS before 9.3.3, Safari before 9.1.2, and tvOS before 9.2.2 allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption) via a crafted web site, a different vulnerability than CVE-2016-4622, CVE-2016-4623, and CVE-2016-4624.
- Record
CVE-2016-4589- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - CVSS 2.0
- 6.8 Medium
AV:N/AC:M/Au:N/C:P/I:P/A:P - Weakness
- CWE-119
- Updated
- 2026-11-02
CVE List No score
WebKit in Apple iOS before 9.3.3, Safari before 9.1.2, and tvOS before 9.2.2 allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption) via a crafted web site, a different vulnerability than CVE-2016-4622, CVE-2016-4623, and CVE-2016-4624.
- Record
CVE-2016-4589- Updated
- 2026-11-02
EUVDEUVD-2016-5575 No score
WebKit in Apple iOS before 9.3.3, Safari before 9.1.2, and tvOS before 9.2.2 allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption) via a crafted web site, a different vulnerability than CVE-2016-4622, CVE-2016-4623, and CVE-2016-4624.
- Record
EUVD-2016-5575- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-vvf3-m43m-fjm2
8.8
WebKit in Apple iOS before 9.3.3, Safari before 9.1.2, and tvOS before 9.2.2 allows remote...
WebKit in Apple iOS before 9.3.3, Safari before 9.1.2, and tvOS before 9.2.2 allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption) via a crafted web site, a different vulnerability than CVE-2016-4622, CVE-2016-4623, and CVE-2016-4624.
- Record
GHSA-vvf3-m43m-fjm2- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-119
- Updated
- 2026-11-02
OSVUBUNTU-CVE-2016-4589
8.8
WebKit in Apple iOS before 9.3.3, Safari before 9.1.2, and tvOS before 9.2.2 allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption) via a crafted web site, a different vulnerability than CVE-2016-4622, CVE-2016-4623, and CVE-2016-4624.
- Record
UBUNTU-CVE-2016-4589- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUSN-3079-1 No score
webkit2gtk vulnerabilities
A large number of security issues were discovered in the WebKitGTK+ Web and JavaScript engines. If a user were tricked into viewing a malicious website, a remote attacker could exploit a variety of issues related to web browser security, including cross-site scripting attacks, denial of service attacks, and arbitrary code execution.
- Record
USN-3079-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
webkit2gtkUbuntu:16.04:LTS |
before 2.12.5-0ubuntu0.16.04.1, plus listed versions 2.8.5+dfsg1-32.10.3+dfsg1-12.10.4+dfsg1-12.10.5-12.10.6-12.10.6-1ubuntu12.10.8-1ubuntu12.10.9-1ubuntu1 |
2.12.5-0ubuntu0.16.04.1 |
qtwebkit-opensource-srcUbuntu:16.04:LTS |
All versions, plus listed versions 5.4.2+dfsg-1ubuntu2.15.5.1+dfsg-2ubuntu1 |
None known |
qtwebkit-sourceUbuntu:16.04:LTS |
All versions, plus listed versions 2.3.2-0ubuntu102.3.2-0ubuntu11 |
None known |
webkitgtkUbuntu:16.04:LTS |
All versions, plus listed versions 2.4.9-2ubuntu22.4.10-0ubuntu12.4.11-0ubuntu0.1 |
None known |
webkit2gtkUbuntu:16.04:LTS From an advisory covering 16 CVEs |
before 2.12.5-0ubuntu0.16.04.1, plus listed versions 2.8.5+dfsg1-32.10.3+dfsg1-12.10.4+dfsg1-12.10.5-12.10.6-12.10.6-1ubuntu12.10.8-1ubuntu12.10.9-1ubuntu1 |
2.12.5-0ubuntu0.16.04.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2016-4589 is a high vulnerability (CVSS 8.8) in Apple Webkit, published July 21, 2016. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.82%, the 86th percentile. Fixed in webkit2gtk 2.12.5-0ubuntu0.16.04.1.
References
lists.apple.com/archives/security-announce/2016/Jul/msg00003.html
lists.apple.com/archives/security-announce/2016/Jul/msg00001.html
securityfocus.com/bid/91830
support.apple.com/HT206900
securitytracker.com/id/1036343
packetstormsecurity.com/files/138502/WebKitGTK-SOP-Bypass-Information-Disclosure.html
Show 25 moreShow less
securityfocus.com/archive/1/539295/100/0/threaded
support.apple.com/HT206905
support.apple.com/HT206902
lists.apple.com/archives/security-announce/2016/Jul/msg00004.html
nvd.nist.gov/vuln/detail/CVE-2016-4589
github.com/advisories/GHSA-vvf3-m43m-fjm2
ubuntu.com/security/CVE-2016-4589
webkitgtk.org/security/WSA-2016-0005.html
ubuntu.com/security/notices/USN-3079-1
cve.org/CVERecord?id=CVE-2016-4589
ubuntu.com/security/CVE-2016-1854
ubuntu.com/security/CVE-2016-1856
ubuntu.com/security/CVE-2016-1857
ubuntu.com/security/CVE-2016-1858
ubuntu.com/security/CVE-2016-1859
ubuntu.com/security/CVE-2016-4583
ubuntu.com/security/CVE-2016-4585
ubuntu.com/security/CVE-2016-4586
ubuntu.com/security/CVE-2016-4588
ubuntu.com/security/CVE-2016-4590
ubuntu.com/security/CVE-2016-4591
ubuntu.com/security/CVE-2016-4622
ubuntu.com/security/CVE-2016-4623
ubuntu.com/security/CVE-2016-4624
ubuntu.com/security/CVE-2016-4651