Every CVE Search/ Get API key

CVE-2016-5827

The icaltime_from_string function in libical 0.47 and 1.0 allows remote attackers to cause a...

7.5 HighFix available

The icaltime_from_string function in libical 0.47 and 1.0 allows remote attackers to cause a denial of service (out-of-bounds heap read) via a crafted string to the icalparser_parse_string function.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

3.07%Up 1.9 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

The icaltime_from_string function in libical 0.47 and 1.0 allows remote attackers to cause a denial of service (out-of-bounds heap read) via a crafted string to the icalparser_parse_string function.

Record
CVE-2016-5827
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:N/A:P
Weakness
CWE-125
Updated
2026-11-02
CVE List No score

The icaltime_from_string function in libical 0.47 and 1.0 allows remote attackers to cause a denial of service (out-of-bounds heap read) via a crafted string to the icalparser_parse_string function.

Record
CVE-2016-5827
Updated
2026-11-02
EUVDEUVD-2016-6762 No score

The icaltime_from_string function in libical 0.47 and 1.0 allows remote attackers to cause a denial of service (out-of-bounds heap read) via a crafted string to the icalparser_parse_string function.

Record
EUVD-2016-6762
Updated
2026-11-03
GitHub AdvisoriesGHSA-r9rv-6pgm-3cxf 7.5

The icaltime_from_string function in libical 0.47 and 1.0 allows remote attackers to cause a...

The icaltime_from_string function in libical 0.47 and 1.0 allows remote attackers to cause a denial of service (out-of-bounds heap read) via a crafted string to the icalparser_parse_string function.

Record
GHSA-r9rv-6pgm-3cxf
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-125
Updated
2026-11-02
OSV 7.5

The icaltime_from_string function in libical 0.47 and 1.0 allows remote attackers to cause a denial of service (out-of-bounds heap read) via a crafted string to the icalparser_parse_string function.

Record
CVE-2016-5827
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2016-5827 7.5

The icaltime_from_string function in libical 0.47 and 1.0 allows remote attackers to cause a denial of service (out-of-bounds heap read) via a crafted string to the icalparser_parse_string function.

Record
UBUNTU-CVE-2016-5827
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
Show 4 moreShow less
OSVMGASA-2018-0021 No score

Updated libical packages fix security vulnerability

libical 1.0 allows remote attackers to cause a denial of service (use-after-free) via a crafted ics file (CVE-2016-5824).

The icaltime_from_string function in libical 0.47 and 1.0 allows remote attackers to cause a denial of service (out-of-bounds heap read) via a crafted string to the icalparser_parse_string function (CVE-2016-5827).

libical allows remote attackers to cause a denial of service (use-after-free) and possibly read heap memory via a crafted ics file (CVE-2016-9584).

Record
MGASA-2018-0021
Updated
2026-11-02
OSVopenSUSE-SU-2024:10947-1 No score

libical-devel-3.0.10-1.4 on GA media

These are all security issues fixed in the libical-devel-3.0.10-1.4 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10947-1
Updated
2026-11-02
OSVSUSE-SU-2017:1989-1 No score

Security update for libical

This update for libical fixes the following issues:

Security issues fixed:

  • CVE-2016-5824: libical 1.0 allows remote attackers to cause a denial of service (use-after-free) via a crafted ics file. (bsc#986639)
  • CVE-2016-5827: The icaltime_from_string function in libical 0.47 and 1.0 allows remote attackers to cause a denial of service (out-of-bounds heap read) via a crafted string to the icalparser_parse_string function. (bsc#986631)
  • CVE-2016-9584: libical allows remote attackers to cause a denial of service (use-after-free) and possibly read heap memory via a crafted ics file. (bsc#1015964)

Bug fixes:

  • libical crashes while parsing timezones (bsc#1044995)
Record
SUSE-SU-2017:1989-1
Updated
2026-11-02
OSVSUSE-SU-2018:0119-1 No score

Recommended update for libical

This update for libical fixes the following issues:

Security issues fixed:

  • CVE-2016-5823: The icalproperty_new_clone function in libical 0.47 and 1.0 allows remote attackers to cause a denial of service (use-after-free) via a crafted ics file. (bnc#986632)
  • CVE-2016-5824: libical 1.0 allows remote attackers to cause a denial of service (use-after-free) via a crafted ics file. (bsc#986639)
  • CVE-2016-5825: The icalparser_parse_string function in libical 0.47 and 1.0 allows remote attackers to cause a denial of service (out-of-bounds heap read) via a crafted ics file. (bsc#986642)
  • CVE-2016-5826: The parser_get_next_char function in libical 0.47 and 1.0 allows remote attackers to cause a denial of service (out-of-bounds heap read) by crafting a string to the icalparser_parse_string function. (bsc#986658)
  • CVE-2016-5827: The icaltime_from_string function in libical 0.47 and 1.0 allows remote attackers to cause a denial of service (out-of-bounds heap read) via a crafted string to the icalparser_parse_string function. (bsc#986631)
  • CVE-2016-9584: libical allows remote attackers to cause a denial of service (use-after-free) and possibly read heap memory via a crafted ics file. (bnc#1015964)

Bug fixes:

  • libical crashes while parsing timezones (bsc#1044995)
Record
SUSE-SU-2018:0119-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
libical
Mageia:5
before 1.0-4.1.mga5
1.0-4.1.mga5
libical
Mageia:6
before 2.0.0-2.1.mga6
2.0.0-2.1.mga6
libical
SUSE:Linux Enterprise Desktop 12 SP2
before 1.0.1-16.3.1
1.0.1-16.3.1
libical
SUSE:Linux Enterprise Desktop 12 SP3
before 1.0.1-16.3.1
1.0.1-16.3.1
libical
SUSE:Linux Enterprise Server for Raspberry Pi 12 SP2
before 1.0.1-16.3.1
1.0.1-16.3.1
libical
SUSE:Linux Enterprise Software Development Kit 12 SP2
before 1.0.1-16.3.1
1.0.1-16.3.1
libical
SUSE:Linux Enterprise Software Development Kit 12 SP3
before 1.0.1-16.3.1
1.0.1-16.3.1
libical
SUSE:Linux Enterprise Server 12 SP2
before 1.0.1-16.3.1
1.0.1-16.3.1
libical
SUSE:Linux Enterprise Server for SAP Applications 12 SP2
before 1.0.1-16.3.1
1.0.1-16.3.1
libical
SUSE:Linux Enterprise Server 12 SP3
before 1.0.1-16.3.1
1.0.1-16.3.1
Show 6 moreShow less
Affected packages
PackageAffectedFixed
libical
SUSE:Linux Enterprise Server for SAP Applications 12 SP3
before 1.0.1-16.3.1
1.0.1-16.3.1
libical
SUSE:Linux Enterprise Software Development Kit 11 SP4
before 0.43-1.10.6.1
0.43-1.10.6.1
libical
SUSE:Linux Enterprise Server 11 SP4
before 0.43-1.10.6.1
0.43-1.10.6.1
libical
SUSE:Linux Enterprise Server for SAP Applications 11 SP4
before 0.43-1.10.6.1
0.43-1.10.6.1
libical
Ubuntu:16.04:LTS
All versions, plus listed versions
1.0.1-0ubuntu11.0.1-0ubuntu2
None known
libical
Ubuntu:18.04:LTS
All versions, plus listed versions
2.0.0-0.52.0.0-0.5build12.0.0-1ubuntu12.0.0-4
None known

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2016-5827 is a high vulnerability (CVSS 7.5) in Libical Project Libical, published January 27, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.07%, the 87th percentile. Fixed in libical 1.0-4.1.mga5.

References

Show 20 moreShow less
MoveEnter Open