Every CVE Search/ Get API key

CVE-2016-6254

Heap-based buffer overflow in the parse_packet function in network.c in collectd before 5.4.3 and...

9.1 CriticalFix available

Heap-based buffer overflow in the parse_packet function in network.c in collectd before 5.4.3 and 5.x before 5.5.2 allows remote attackers to cause a denial of service (daemon crash) or possibly execute arbitrary code via a crafted network packet.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
High
Availability
High

Exploit likelihood

5.74%Up 1.9 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 9.1

Heap-based buffer overflow in the parse_packet function in network.c in collectd before 5.4.3 and 5.x before 5.5.2 allows remote attackers to cause a denial of service (daemon crash) or possibly execute arbitrary code via a crafted network packet.

Record
CVE-2016-6254
CVSS 3.0
9.1 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H
CVSS 2.0
6.4 MediumAV:N/AC:L/Au:N/C:N/I:P/A:P
Weakness
CWE-119
Updated
2026-11-02
CVE List No score

Heap-based buffer overflow in the parse_packet function in network.c in collectd before 5.4.3 and 5.x before 5.5.2 allows remote attackers to cause a denial of service (daemon crash) or possibly execute arbitrary code via a crafted network packet.

Record
CVE-2016-6254
Updated
2026-11-02
EUVDEUVD-2016-7184 No score

Heap-based buffer overflow in the parse_packet function in network.c in collectd before 5.4.3 and 5.x before 5.5.2 allows remote attackers to cause a denial of service (daemon crash) or possibly execute arbitrary code via a crafted network packet.

Record
EUVD-2016-7184
Updated
2026-11-03
GitHub AdvisoriesGHSA-w8rr-j32h-prm7 9.1

Heap-based buffer overflow in the parse_packet function in network.c in collectd before 5.4.3 and...

Heap-based buffer overflow in the parse_packet function in network.c in collectd before 5.4.3 and 5.x before 5.5.2 allows remote attackers to cause a denial of service (daemon crash) or possibly execute arbitrary code via a crafted network packet.

Record
GHSA-w8rr-j32h-prm7
CVSS 3.0
9.1 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H
Weakness
CWE-119
Updated
2026-11-02
OSVALPINE-CVE-2016-6254 9.1

Heap-based buffer overflow in the parse_packet function in network.c in collectd before 5.4.3 and 5.x before 5.5.2 allows remote attackers to cause a denial of service (daemon crash) or possibly execute arbitrary code via a crafted network packet.

Record
ALPINE-CVE-2016-6254
CVSS 3.0
9.1 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H
Updated
2026-11-03
OSVBELL-CVE-2016-6254 9.1

CVE-2016-6254 does not affect BellSoft software

Record
BELL-CVE-2016-6254
CVSS 3.0
9.1 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H
Updated
2026-11-02
Show 6 moreShow less
OSV 9.1

Heap-based buffer overflow in the parse_packet function in network.c in collectd before 5.4.3 and 5.x before 5.5.2 allows remote attackers to cause a denial of service (daemon crash) or possibly execute arbitrary code via a crafted network packet.

Record
CVE-2016-6254
CVSS 3.0
9.1 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2016-6254 9.1

Heap-based buffer overflow in the parse_packet function in network.c in collectd before 5.4.3 and 5.x before 5.5.2 allows remote attackers to cause a denial of service (daemon crash) or possibly execute arbitrary code via a crafted network packet.

Record
DEBIAN-CVE-2016-6254
CVSS 3.0
9.1 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2016-6254 9.1

Heap-based buffer overflow in the parse_packet function in network.c in collectd before 5.4.3 and 5.x before 5.5.2 allows remote attackers to cause a denial of service (daemon crash) or possibly execute arbitrary code via a crafted network packet.

Record
UBUNTU-CVE-2016-6254
CVSS 3.0
9.1 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H
Updated
2026-11-02
OSVopenSUSE-SU-2024:10462-1 No score

collectd-5.5.2-1.4 on GA media

These are all security issues fixed in the collectd-5.5.2-1.4 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10462-1
Updated
2026-11-02
OSVSUSE-SU-2016:2187-1 No score

Security update for collectd

This update for collectd fixes the following issues:

  • heap overflow in the network plug-in (bsc#990853, CVE-2016-6254)
  • add rrdcached plugin to filelist
  • disable ipvs plugin for now: does not build
Record
SUSE-SU-2016:2187-1
Updated
2026-11-02
OSVUSN-4793-1 No score

collectd vulnerabilities

It was discovered that collectd mishandled certain malformed packets. A remote attacker could use this vulnerability to cause collectd to crash or possibly execute arbitrary code. (CVE-2016-6254)

It was discovered that collectd failed to handle certain input. An attacker could use this vulnerability to cause collectd to crash. (CVE-2017-16820)

It was discovered that collectd mishandles certain malformed network packets. A remote attacker could use this vulnerability to cause a Denial of Service or consume system resources. (CVE-2017-7401)

Record
USN-4793-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
collectd
Alpine:v3.10
5.4.0 up to 5.5.2-r0
5.5.2-r0
collectd
Alpine:v3.11
5.4.0 up to 5.5.2-r0
5.5.2-r0
collectd
Alpine:v3.12
5.4.0 up to 5.5.2-r0
5.5.2-r0
collectd
Alpine:v3.13
5.4.0 up to 5.5.2-r0
5.5.2-r0
collectd
Alpine:v3.14
5.4.0 up to 5.5.2-r0
5.5.2-r0
collectd
Alpine:v3.15
5.4.0 up to 5.5.2-r0
5.5.2-r0
collectd
Alpine:v3.16
5.4.0 up to 5.5.2-r0
5.5.2-r0
collectd
Alpine:v3.17
5.4.0 up to 5.5.2-r0
5.5.2-r0
collectd
Alpine:v3.18
5.4.0 up to 5.5.2-r0
5.5.2-r0
collectd
Alpine:v3.19
5.4.0 up to 5.5.2-r0
5.5.2-r0
Show 17 moreShow less
Affected packages
PackageAffectedFixed
collectd
Alpine:v3.20
5.4.0 up to 5.5.2-r0
5.5.2-r0
collectd
Alpine:v3.21
5.4.0 up to 5.5.2-r0
5.5.2-r0
collectd
Alpine:v3.22
5.4.0 up to 5.5.2-r0
5.5.2-r0
collectd
Alpine:v3.23
5.4.0 up to 5.5.2-r0
5.5.2-r0
collectd
Alpine:v3.24
5.4.0 up to 5.5.2-r0
5.5.2-r0
collectd
Alpine:v3.4
5.4.0 up to 5.5.2-r0
5.5.2-r0
collectd
Alpine:v3.5
5.4.0 up to 5.5.2-r0
5.5.2-r0
collectd
Alpine:v3.6
5.4.0 up to 5.5.2-r0
5.5.2-r0
collectd
Alpine:v3.9
5.4.0 up to 5.5.2-r0
5.5.2-r0
collectd
Debian:12
before 5.5.2-1
5.5.2-1
collectd
Debian:13
before 5.5.2-1
5.5.2-1
collectd
Debian:7
before 5.1.0-3+deb7u1, plus listed versions
5.1.0-3
5.1.0-3+deb7u1
collectd
Debian:8
before 5.4.1-6+deb8u1, plus listed versions
5.4.1-6
5.4.1-6+deb8u1
collectd
SUSE:Lifecycle Management Server 1.3
before 4.9.4-0.25.1
4.9.4-0.25.1
collectd
SUSE:WebYast 1.3
before 4.9.4-0.25.1
4.9.4-0.25.1
collectd
Ubuntu:Pro:14.04:LTS
before 5.4.0-3ubuntu2.2+esm1, plus listed versions
5.1.0-3.1ubuntu35.1.0-3.1ubuntu45.4.0-3ubuntu15.4.0-3ubuntu25.4.0-3ubuntu2.15.4.0-3ubuntu2.2
5.4.0-3ubuntu2.2+esm1
collectd
Ubuntu:Pro:16.04:LTS
before 5.5.1-1ubuntu0.1~esm1, plus listed versions
5.4.1-6ubuntu15.5.0-45.5.1-15.5.1-1build15.5.1-1build2
5.5.1-1ubuntu0.1~esm1

History

History
RecordedChangedSources
affectedOSV
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2016-6254 is a critical vulnerability (CVSS 9.1) in Collectd, published July 30, 2016. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 5.74%, the 93rd percentile. Fixed in collectd 5.5.2-r0.

References

Show 14 moreShow less
MoveEnter Open